Bug 872057 - XKB directory listing is incomplete
Summary: XKB directory listing is incomplete
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-xkb-utils
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Peter Hutterer
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks: 871460
TreeView+ depends on / blocked
 
Reported: 2012-11-01 05:43 UTC by Peter Hutterer
Modified: 2013-02-26 15:55 UTC (History)
2 users (show)

Fixed In Version: xorg-x11-xkb-utils-7.7-4.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 08:07:18 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0305 0 normal SHIPPED_LIVE xorg-x11-xkb-utils bug fix and enhancement update 2013-02-20 20:55:05 UTC

Description Peter Hutterer 2012-11-01 05:43:37 UTC
Description of problem:
Upstream regression in xkbcomp commit 9887842e33174a6e98675b912e419c711dd20c0f. A performance optimization commit caused the read buffer to not be reset on a new file if a parse error occurs and the new scanchar() function keeps returning characters from the old file.

This prevents the symbols.dir directory listing from being generated properly for the xkeyboard-config build. When xkbcomp is called by the build, it is called in the git tree. The Makefiles in that tree cause the above errors.

Version-Release number of selected component (if applicable):
xorg-x11-xkb-utils-7.7-3.el6

How reproducible:
rpmbuild --rebuild xkeyboard-config-nvr.src.rpm. The symbols.dir should be around 11000 lines.

Direct call
xkbcomp -lfhlpR "path/to/xkeyboard-config.git/symbols/*"

Again, the output should be around 11000 lines. The current truncated output is between 50 and 250 lines, depending on the version of xkeyboard-config.

Comment 1 RHEL Program Management 2012-11-01 05:50:45 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 3 Peter Hutterer 2012-11-01 23:54:18 UTC
MODIFIED

xorg-x11-xkb-utils-7.7-4.el6 is available in brew

Comment 8 errata-xmlrpc 2013-02-21 08:07:18 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0305.html


Note You need to log in before you can comment on or make changes to this bug.