Bug 872254 - user libvirtd need to shut down cleanly when the session dies
user libvirtd need to shut down cleanly when the session dies
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 12:17 EDT by Alexander Larsson
Modified: 2012-12-09 13:56 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-09 13:56:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
session dbus integration support (7.58 KB, patch)
2012-11-01 12:17 EDT, Alexander Larsson
no flags Details | Diff
Save all domains when session bus dies or system is being shutdown (10.19 KB, patch)
2012-11-01 12:18 EDT, Alexander Larsson
no flags Details | Diff

  None (edit)
Description Alexander Larsson 2012-11-01 12:17:21 EDT
Created attachment 636737 [details]
session dbus integration support

When running in user mode, we need libvirtd to die when the session exits and/or when the system is shut down, otherwise we leave running processes after logout which may unexpectedly use CPU and risk data corruption to the vm images (for instance due to unclean shutdowns or if another vm is stated with the same disk image).

I've posted some patches upstream that does this here:
https://www.redhat.com/archives/libvir-list/2012-October/msg00365.html

Will attach the patches.
Comment 1 Alexander Larsson 2012-11-01 12:18:43 EDT
Created attachment 636738 [details]
Save all domains when session bus dies or system is being shutdown
Comment 2 Cole Robinson 2012-12-09 13:56:41 EST
Been in F18 for a few weeks

Note You need to log in before you can comment on or make changes to this bug.