Bug 872291 - "man hwclock" says to run non-existent "adjtimex" utility
Summary: "man hwclock" says to run non-existent "adjtimex" utility
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: util-linux-ng
Version: 6.3
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: rc
: ---
Assignee: Karel Zak
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-01 17:56 UTC by Patrick J. LoPresti
Modified: 2013-11-21 20:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The hwclock man page references non-existing adjtimex utility. Consequence: Fix: The hwclock man page has been fixed. Result:
Clone Of:
Environment:
Last Closed: 2013-11-21 20:44:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:1648 normal SHIPPED_LIVE util-linux-ng bug fix and enhancement update 2013-11-20 21:53:24 UTC

Description Patrick J. LoPresti 2012-11-01 17:56:48 UTC
Description of problem:
"man hwclock" says I can run "adjtimex --print" to view the kernel's clock variables.  But there is no "adjtimex" utility in RHEL 6.

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. man hwclock
2. adjtimex --print # just following instructions
3. :-(
  
Actual results:
adjtimex: Command not found

Expected results:
Dump of kernel clock

Additional info:
Best fix would be to add the "adjtimex" package back into RHEL.  Alternatively, fix the "hwclock" man page to provide an updated procedure for reading the kernel clock variables.  (In particular, I want to know whether the kernel is updating the RTC automatically, and I know no way to do this other than running "adjtimex --print" as documented in the hwclock man page.)

Comment 2 RHEL Product and Program Management 2012-12-14 08:20:47 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 8 errata-xmlrpc 2013-11-21 20:44:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1648.html


Note You need to log in before you can comment on or make changes to this bug.