Bug 872320 - Review Request: maven-patch-plugin - Maven Patch Plugin
Review Request: maven-patch-plugin - Maven Patch Plugin
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mikolaj Izdebski
Fedora Extras Quality Assurance
:
Depends On: 879885
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 15:23 EDT by Mattias Ellert
Modified: 2012-12-03 23:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-01 04:51:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mizdebsk: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description Mattias Ellert 2012-11-01 15:23:44 EDT
Spec URL: http://www.grid.tsl.uu.se/review/maven-patch-plugin.spec
SRPM URL: http://www.grid.tsl.uu.se/review/maven-patch-plugin-1.1.1-1.fc17.src.rpm

Description: The Patch Plugin is used to apply patches to source files.
Fedora Account System Username: ellert
Comment 1 Mikolaj Izdebski 2012-11-23 08:03:25 EST
I am taking this review.
Comment 2 Mikolaj Izdebski 2012-11-23 08:23:56 EST
It fails to build in rawhide:
https://koji.fedoraproject.org/koji/taskinfo?taskID=4720875

It looks like antlr dependency is missing.
Please make sure the package builds in rawhide.
Comment 3 Mattias Ellert 2012-11-25 01:04:40 EST
It built in rawhide three weeks ago:

https://koji.fedoraproject.org/koji/taskinfo?taskID=4649093

Something has happened since then with the dependencies that has made maven more picky about dependency resolution.

The antlr.jar is not missing - antlr-tool is dragged in as a dependency. However, tha antlr-tool package does not provide any maven-fragment and maven-pom files, and the groovy package states a dependency on antlr in its pom file.

The maven version in rawhide now complains about this. It didn't do this three weeks ago, and it still doesn't complain about it in f17 and f18.

I have filed a bug on groovy about the unsatisfiable dependency:
https://bugzilla.redhat.com/show_bug.cgi?id=879885

In the mean time, since the broken groovy package is not used to build the package, but only during running the test suite, I have disabled running the tests on fedora 19.

New version:

Spec URL: http://www.grid.tsl.uu.se/review/maven-patch-plugin.spec
SRPM URL: http://www.grid.tsl.uu.se/review/maven-patch-plugin-1.1.1-2.fc17.src.rpm
Comment 4 Mikolaj Izdebski 2012-11-25 06:38:04 EST
Package Review
==============

Key:
- = N/A
x = Pass
! = Fail


==== Generic ====
[x]: MUST Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: MUST Package successfully compiles and builds into binary rpms on at
     least one supported primary architecture.
[x]: MUST %build honors applicable compiler flags or justifies otherwise.
[x]: MUST All build dependencies are listed in BuildRequires, except for any
     that are listed in the exceptions section of Packaging Guidelines.
[x]: MUST Package contains no bundled libraries.
[x]: MUST Changelog in prescribed format.
[x]: MUST Sources contain only permissible code or content.
[x]: MUST Each %files section contains %defattr if rpm < 4.4
[x]: MUST Macros in Summary, %description expandable at SRPM build time.
[x]: MUST Package contains desktop file if it is a GUI application.
[x]: MUST Development files must be in a -devel package
[x]: MUST Package requires other packages for directories it uses.
[x]: MUST Package uses nothing in %doc for runtime.
[x]: MUST Package is not known to require ExcludeArch.
[x]: MUST Permissions on files are set properly.
[x]: MUST Package does not contain duplicates in %files.
[x]: MUST Package complies to the Packaging Guidelines
[x]: MUST Spec file lacks Packager, Vendor, PreReq tags.
[x]: MUST Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: MUST Large documentation files are in a -doc subpackage, if required.
[x]: MUST If (and only if) the source package includes the text of the
     license(s) in its own file, then that file, containing the text of the
     license(s) for the package is included in %doc.
[x]: MUST License field in the package spec file matches the actual license.
[!]: MUST License file installed when any subpackage combination is installed.
[x]: MUST Package consistently uses macro is (instead of hard-coded directory
     names).
[x]: MUST Package is named using only allowed ascii characters.
[x]: MUST Package is named according to the Package Naming Guidelines.
[x]: MUST Package does not generate any conflict.
[x]: MUST Package obeys FHS, except libexecdir and /usr/target.
[x]: MUST If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: MUST Package must own all directories that it creates.
[x]: MUST Package does not own files or directories owned by other packages.
[x]: MUST Package installs properly.
[x]: MUST Package is not relocatable.
[x]: MUST Requires correct, justified where necessary.
[x]: MUST Rpmlint is run on all rpms the build produces.
[x]: MUST Sources used to build the package match the upstream source, as
     provided in the spec URL.
[x]: MUST Spec file is legible and written in American English.
[x]: MUST Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: MUST Package contains systemd file(s) if in need.
[x]: MUST File names are valid UTF-8.
[x]: SHOULD Reviewer should test that the package builds in mock.
[x]: SHOULD Buildroot is not present
[x]: SHOULD Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: SHOULD If the source package does not include license text(s) as a
     separate file from upstream, the packager SHOULD query upstream to
     include it.
[x]: SHOULD Dist tag is present.
[x]: SHOULD No file requires outside of /etc, /bin, /sbin, /usr/bin,
     /usr/sbin.
[x]: SHOULD Final provides and requires are sane (rpm -q --provides and rpm -q
     --requires).
[x]: SHOULD Package functions as described.
[x]: SHOULD Latest version is packaged.
[x]: SHOULD Package does not include license text files separate from
     upstream.
[x]: SHOULD SourceX tarball generation or download is documented.
[x]: SHOULD SourceX / PatchY prefixed with %{name}.
[x]: SHOULD SourceX is a working URL.
[x]: SHOULD Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[x]: SHOULD Package should compile and build into binary rpms on all supported
     architectures.
[-]: SHOULD %check is present and all tests pass.
[x]: SHOULD Packages should try to preserve timestamps of original installed
     files.
[x]: SHOULD Spec use %global instead of %define.


==== Java ====
[x]: MUST If source tarball includes bundled jar/class files these need to be
     removed prior to building
[x]: MUST Packages have proper BuildRequires/Requires on jpackage-utils
[x]: MUST Fully versioned dependency in subpackages, if present.
[x]: MUST Javadoc documentation files are generated and included in -javadoc
     subpackage
[x]: MUST Javadoc subpackages have Requires: jpackage-utils
[x]: MUST Javadocs are placed in %{_javadocdir}/%{name} (no -%{version}
     symlink)
[x]: SHOULD Package has BuildArch: noarch (if possible)
[x]: SHOULD Package uses upstream build method (ant/maven/etc.)


==== Maven ====
[x]: MUST Pom files have correct add_maven_depmap call
[x]: MUST Old add_to_maven_depmap macro is not being used
[x]: MUST Packages DOES NOT have Requires(post) and Requires(postun) on
     jpackage-utils for %update_maven_depmap macro
[x]: MUST If package contains pom.xml files install it (including depmaps)
     even when building with ant
[x]: MUST Package DOES NOT use %update_maven_depmap in %post/%postun
[x]: MUST Packages use %{_mavenpomdir} instead of %{_datadir}/maven2/poms


Rpmlint
-------
Checking: maven-patch-plugin-1.1.1-2.fc19.noarch.rpm
          maven-patch-plugin-javadoc-1.1.1-2.fc19.noarch.rpm
          maven-patch-plugin-1.1.1-2.fc19.src.rpm
maven-patch-plugin.noarch: I: enchant-dictionary-not-found en_US
3 packages and 0 specfiles checked; 0 errors, 0 warnings.


Issues
------
[!]: MUST License file installed when any subpackage combination is installed.
     NOTICE file is not installed with javadoc subpackage.


Notes
-----
The antlr-related bug should be fixed now, so you should be able to reenable tests now.
Comment 5 Mattias Ellert 2012-11-25 09:17:11 EST
Thanks for fixing antlr, Running the tests on rawhide work now:

https://koji.fedoraproject.org/koji/taskinfo?taskID=4725218

New version:

Spec URL: http://www.grid.tsl.uu.se/review/maven-patch-plugin.spec
SRPM URL: http://www.grid.tsl.uu.se/review/maven-patch-plugin-1.1.1-3.fc17.src.rpm

Regarding the LICENSE file in the javadoc package - that was already there:

$ rpm -qlp maven-patch-plugin-javadoc-1.1.1-2.fc17.noarch.rpm | grep LIC
/usr/share/doc/maven-patch-plugin-javadoc-1.1.1/LICENSE
Comment 6 Mikolaj Izdebski 2012-11-25 09:31:10 EST
The NOTICE file is still not installed with javadoc package. Once you do that I can approve the package.

Installing this file is required to satisfy requirements of the Apache License [1]. Point 4(d) of the license says "If the Work includes a "NOTICE" text file as part of its distribution, then any Derivative Works that You distribute must include a readable copy of the attribution notices contained within such NOTICE file".

[1] http://www.apache.org/licenses/LICENSE-2.0.txt
Comment 8 Mikolaj Izdebski 2012-11-25 10:16:24 EST
Approved.
Comment 9 Mattias Ellert 2012-11-25 10:32:41 EST
Many thanks for the review.

New Package SCM Request
=======================
Package Name: maven-patch-plugin
Short Description: Maven Patch Plugin
Owners: ellert
Branches: f17 f18 master
InitialCC: java-sig
Comment 10 Gwyn Ciesla 2012-11-25 11:02:20 EST
Git done (by process-git-requests).
Comment 11 Fedora Update System 2012-11-25 14:34:30 EST
maven-patch-plugin-1.1.1-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/maven-patch-plugin-1.1.1-4.fc17
Comment 12 Fedora Update System 2012-11-25 14:34:42 EST
maven-patch-plugin-1.1.1-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/maven-patch-plugin-1.1.1-4.fc18
Comment 13 Fedora Update System 2012-11-25 20:53:53 EST
maven-patch-plugin-1.1.1-4.fc17 has been pushed to the Fedora 17 testing repository.
Comment 14 Fedora Update System 2012-12-01 04:51:43 EST
maven-patch-plugin-1.1.1-4.fc18 has been pushed to the Fedora 18 stable repository.
Comment 15 Fedora Update System 2012-12-03 23:59:56 EST
maven-patch-plugin-1.1.1-4.fc17 has been pushed to the Fedora 17 stable repository.

Note You need to log in before you can comment on or make changes to this bug.