This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 872336 - Wrong definition of O_RSYNC in /usr/include/bits/fcntl-linux.h
Wrong definition of O_RSYNC in /usr/include/bits/fcntl-linux.h
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: glibc (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Law
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-01 16:08 EDT by Tomas Mraz
Modified: 2012-11-02 16:14 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-02 16:14:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tomas Mraz 2012-11-01 16:08:16 EDT
In the current glibc headers package in rawhide the O_RSYNC is defined as __O_SYNC in /usr/include/bits/fcntl-linux.h but the __O_SYNC is defined only in linux kernel private headers. I suppose the O_SYNC without underscore should be used instead as it was done in previous glibc headers package releases.
Comment 1 Jeff Law 2012-11-02 01:05:21 EDT
Yea, all this stuff is in a significant state of flux; it looks like this particular problem has already been fixed upstream.  For reasons unknown I can't upload new sources to Fedora rawhide right now.

Regardless, I'll have it fixed soon.
Comment 2 Vít Ondruch 2012-11-02 03:04:27 EDT
I hope that the upstream fix will apply also for Ruby:

compiling io.c
gcc -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -mtune=generic -fPIC -m64 -include ruby/config.h -include ruby/missing.h -D_FORTIFY_SOURCE=2 -fstack-protector -fno-strict-overflow -fvisibility=hidden -DRUBY_EXPORT   -I. -I.ext/include/x86_64-linux -I./include -I. -o io.o -c io.c
io.c: In function 'Init_IO':
io.c:11670:45: error: '__O_SYNC' undeclared (first use in this function)
io.c:11670:45: note: each undeclared identifier is reported only once for each function it appears in
make: *** [io.o] Error 1
make: *** Waiting for unfinished jobs....
Comment 3 Vít Ondruch 2012-11-02 07:02:06 EDT
(In reply to comment #1)
> For reasons unknown I can't upload new sources to Fedora rawhide right now.

https://bugzilla.redhat.com/show_bug.cgi?id=872124
Comment 4 Jeff Law 2012-11-02 16:14:49 EDT
I updated rawhide's glibc which should fix this problem.

Note You need to log in before you can comment on or make changes to this bug.