This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 872361 - parted shouldn't de-reference symlinks for named md devices(?) - this is blocking Intel fwraid support for F18 Beta
parted shouldn't de-reference symlinks for named md devices(?) - this is bloc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: parted (Show other bugs)
18
All All
urgent Severity high
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
AcceptedBlocker
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-11-01 17:25 EDT by Adam Williamson
Modified: 2012-11-12 08:56 EST (History)
4 users (show)

See Also:
Fixed In Version: parted-3.1-9.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-12 08:56:57 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
strace of 'parted -s /dev/md126 p' on a fresh RAID-1 array booted from Beta TC7 desktop live (15.43 KB, text/plain)
2012-11-06 12:16 EST, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2012-11-01 17:25:10 EDT
This bug is being split off from https://bugzilla.redhat.com/show_bug.cgi?id=866519 . After a series of fixes for correctly presenting Intel fwraid devices in anaconda's disk picker, we eventually ran up against an issue in parted when anaconda tries to actually create the partitions for an installation to such a device.

I don't entirely grok the issue myself, but it is clear it's separate from 866519, it's in parted, and bcl ought to be dealing with it. Here's some strategic IRC copypasta:

<dlehman> bcl: it's not the p delimiter. it's that you instantiate a Device with a path and then when you access its path attr it's been resolved to a different path.
 so I do d=parted.Device(path="/dev/md/foo") ; print d.path => "/dev/md126p3"
<bcl> oh, ok. I misunderstood that one then.
 so foo is a symlink to ../md126p3
<dlehman> right. somewhere in parted it probably has code to not resolve the symlink for /dev/mapper/ paths. if so, it would just need to applied also to /dev/md/ paths.
<bcl> I'll have another look. got any way to reproduce that without special hardware?
<dlehman> you can make a partitioned md device
 should be as simple as making a disklabel on top of a regular (named) md array, adding partitions
...
<bcl> adamw: sounds like parted shouldn't de-reference symlinks.
<bcl> which may cause other issues, so we'll see what I find in the code.
<dlehman> bcl:fwiw  it doesn't dereference symlinks for /dev/mapper/ devices
Comment 1 Adam Williamson 2012-11-01 17:26:22 EDT
I'm going to skip the bureaucracy and mark this as accepted blocker as it can clearly inherit that status from 866519. That was an accepted blocker because it meant Intel fw RAID didn't work; now this bug is what's stopping Intel fw RAID from working. If that was a blocker, this necessarily must be. We're just splitting the issue out for clarity of assignment.
Comment 2 Fedora Update System 2012-11-02 13:32:57 EDT
parted-3.1-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/parted-3.1-9.fc18
Comment 3 Adam Williamson 2012-11-02 22:34:25 EDT
I checked this fix with an image Tim built, it works fine. Will confirm again with TC7 tpmorrow.
Comment 4 Fedora Update System 2012-11-03 15:26:45 EDT
Package parted-3.1-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing parted-3.1-9.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17540/parted-3.1-9.fc18
then log in and leave karma (feedback).
Comment 5 Adam Williamson 2012-11-05 20:52:26 EST
verified fixed in TC7.
Comment 6 Adam Williamson 2012-11-06 12:16:34 EST
Created attachment 639471 [details]
strace of 'parted -s /dev/md126 p' on a fresh RAID-1 array booted from Beta TC7 desktop live

I got strace output from the sticking parted command. Created the RAID-1 array afresh, booted F18 Beta TC7 live, installed strace, and ran 'strace -o parted.txt parted -s /dev/md126 p'. This attachment is the result.
Comment 7 Adam Williamson 2012-11-06 12:17:59 EST
Damn, wrong bug. Sorry. Disregard above comment.
Comment 8 Kamil Páral 2012-11-12 08:56:57 EST
parted-3.1-9.fc18 is now stable, closing.

Note You need to log in before you can comment on or make changes to this bug.