Bug 872468 - Thai font missing from installer environment
Thai font missing from installer environment
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: lorax (Show other bugs)
18
All All
unspecified Severity medium
: ---
: ---
Assigned To: Martin Gracik
Fedora Extras Quality Assurance
AcceptedNTH
:
: 882767 (view as bug list)
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-02 02:34 EDT by Adam Williamson
Modified: 2013-07-04 09:05 EDT (History)
9 users (show)

See Also:
Fixed In Version: lorax-18.23-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 00:32:41 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (from smoke14, I checked tc6 is the same) (108.46 KB, image/png)
2012-11-02 02:36 EDT, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2012-11-02 02:34:29 EDT
The entry for Thai on the locale/language picker screen at the start of newUI is all unicode boxes (see attached screenshot). Looks like we're missing the appropriate font from the installer environment.
Comment 1 Adam Williamson 2012-11-02 02:36:02 EDT
Created attachment 636952 [details]
screenshot (from smoke14, I checked tc6 is the same)
Comment 2 Chris Lumens 2012-11-02 10:21:17 EDT
I don't suppose anyone would know what the font package is?
Comment 3 Adam Williamson 2012-11-02 15:00:23 EDT
/etc/fonts/conf.d/65-nonlatin.conf lists the following for Thai:

serif

			<family>Kinnari</family> <!-- thai -->
			<family>Norasi</family> <!-- thai -->

sans

			<family>Waree</family> <!-- thai -->
			<family>Loma</family> <!-- thai -->
			<family>Garuda</family> <!-- thai -->
			<family>Umpush</family> <!-- thai -->

monospace

			<family>TlwgTypo</family> <!-- thai -->
			<family>TlwgTypist</family> <!-- thai -->
			<family>TlwgTypewriter</family> <!-- thai -->
			<family>TlwgMono</family> <!-- thai -->


I think the preference is top-to-bottom, so that would mean Waree is the preferred Thai sans font. So, I guess what you want is thai-scalable-waree-fonts .

There are samples at http://linux.thai.net/~thep/font-samples/thaifonts-scalable-img.html if you want to use your extensive Thai knowledge to decide which one looks nicest ;)
Comment 4 Adam Williamson 2012-11-02 15:04:04 EDT
http://slice-of-thai.com/fonts/ seems to be aware of all of them and prefer Garuda, but eh.
Comment 5 Mike FABIAN 2012-11-12 04:29:41 EST
The problem still exists in Fedora-18-Beta-TC8-x86_64-netinst.iso
Comment 6 Akira TAGOH 2012-12-03 00:11:11 EST
*** Bug 882767 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2012-12-05 20:42:16 EST
lorax-18.23-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.23-1.fc18
Comment 8 Fedora Update System 2012-12-06 15:16:51 EST
Package lorax-18.23-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lorax-18.23-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19867/lorax-18.23-1.fc18
then log in and leave karma (feedback).
Comment 9 Adam Williamson 2012-12-13 16:47:02 EST
Proposing NTH because, ridiculously, this didn't get in before Final freeze. Affects a supported language, you can't install in Thai with this problem.
Comment 10 Fedora Update System 2012-12-14 20:23:19 EST
lorax-18.24-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/lorax-18.24-1.fc18
Comment 11 Adam Williamson 2012-12-17 14:31:55 EST
Discussed at 2012-12-17 NTH review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-17/f18final-blocker-review-5.2012-12-17-16.40.log.txt . Accepted as NTH - always bad to break a language.
Comment 12 satellitgo 2012-12-17 14:34:35 EST
seen also in SoaS TC3  anaconda 18.37.2

some languages are a series of squares in anaconda language selection screen
Comment 13 Adam Williamson 2012-12-17 17:45:28 EST
That's different, as lives are composed differently. As SoaS is built on top of the -minimal kickstart, not the -live-base kickstart, it is missing quite a lot of stuff that other spins have, which may include various language support packages.
Comment 14 Adam Williamson 2012-12-17 21:41:30 EST
Seems fixed in TC3, I see actual letters for Thai. No idea if the chosen font is a good one, but it has to beat boxes. :)
Comment 15 Fedora Update System 2012-12-20 00:32:45 EST
lorax-18.24-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.