Bug 872548 - Duplicated main agenda group on session reset
Summary: Duplicated main agenda group on session reset
Keywords:
Status: VERIFIED
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: jBPM 5, jBPM Console
Version: BRMS 5.3.0.GA
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ER4
: BRMS 5.3.1 GA
Assignee: Mario Fusco
QA Contact: Marek Winkler
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-02 12:17 UTC by Maciej Swiderski
Modified: 2020-04-27 01:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When a rule or a process raises an exception the agenda is reset by marshaling the old one and unmarhaling it into a new one. The unmarhaling process had a bug causing the duplication of the main agenda group in the resulting agenda. After the raising of an Exception and the subsequent reset of the agenda, the agenda itself was no longer usable. This has been resolved, and now the agenda works correctly even after an exception is thrown by a rule or a process.
Clone Of:
Environment:
Last Closed:
Type: Bug


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 862296 0 high VERIFIED IllegalArgumentException when opening Business Central 2021-02-22 00:41:40 UTC
Red Hat Issue Tracker JBRULES-3677 0 Major Resolved Duplicated main agenda group on session reset 2014-07-02 17:10:56 UTC

Internal Links: 862296

Description Maciej Swiderski 2012-11-02 12:17:39 UTC
Description of problem:


In case knowledge session is reset (for instance due to transaction rollback) main agenda group is duplicated. First time is added by clear method in DefaultAgenda and then right after by the marshaller

Consequence of it is that rules are not fired after session reset.

This is a backport of jira JBRULES-3677

Version-Release number of selected component (if applicable):


How reproducible:
See bz https://bugzilla.redhat.com/show_bug.cgi?id=862296 for all steps that needs to be taken to reproduce it. That bz was about transactions but revealed problem with handling rule tasks in the processes

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 JBoss JIRA Server 2012-11-02 14:09:35 UTC
Mario Fusco <mario.fusco> updated the status of jira JBRULES-3677 to Resolved

Comment 2 Mario Fusco 2012-11-02 14:11:05 UTC
Fix available and ready to be backported.

Comment 4 lcarlon 2012-11-09 03:52:46 UTC
Hi Mario,

could you review this bug to see if it should be included in the release notes, and provide the content if it should.

(This is the last one)

Thanks
Lee

Comment 5 Marek Winkler 2012-11-13 10:37:06 UTC
Verified on 5.3.1.BRMS-ER4.


Note You need to log in before you can comment on or make changes to this bug.