Bug 872568 - SELinux is preventing /usr/bin/bash from 'execute' accesses on the file bash.
Summary: SELinux is preventing /usr/bin/bash from 'execute' accesses on the file bash.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Grepl
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:39bb30ccdf35adeaa1eb695fe80...
: 872565 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-02 13:07 UTC by Kamil Páral
Modified: 2013-01-09 12:11 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-07 04:29:47 UTC
Type: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-11-02 13:07 UTC, Kamil Páral
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-11-02 13:07 UTC, Kamil Páral
no flags Details

Description Kamil Páral 2012-11-02 13:07:28 UTC
Description of problem:
This is inside VM and happened after suspending and resuming the machine using virsh dompmsuspend and virsh dompmwakeup.

Additional info:
libreport version: 2.0.14
kernel:         3.6.1-1.fc18.x86_64

description:
:SELinux is preventing /usr/bin/bash from 'execute' accesses on the file bash.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that bash should be allowed execute access on the bash file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep 01grub /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:virt_qemu_ga_t:s0
:Target Context                system_u:object_r:shell_exec_t:s0
:Target Objects                bash [ file ]
:Source                        01grub
:Source Path                   /usr/bin/bash
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           bash-4.2.37-6.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-36.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.6.1-1.fc18.x86_64 #1 SMP Mon Oct
:                              8 17:19:09 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-11-02 09:05:23 EDT
:Last Seen                     2012-11-02 09:05:23 EDT
:Local ID                      16f98292-1a0d-461b-be4c-f3b5c3f1fcd4
:
:Raw Audit Messages
:type=AVC msg=audit(1351861523.732:328): avc:  denied  { execute } for  pid=1697 comm="pm-suspend" name="bash" dev="vda3" ino=2554 scontext=system_u:system_r:virt_qemu_ga_t:s0 tcontext=system_u:object_r:shell_exec_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1351861523.732:328): arch=x86_64 syscall=execve success=yes exit=0 a0=1c2a460 a1=1c29a40 a2=1bfd970 a3=7fff28abc110 items=0 ppid=1645 pid=1697 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=01grub exe=/usr/bin/bash subj=system_u:system_r:virt_qemu_ga_t:s0 key=(null)
:
:Hash: 01grub,virt_qemu_ga_t,shell_exec_t,file,execute
:
:audit2allow
:
:#============= virt_qemu_ga_t ==============
:allow virt_qemu_ga_t shell_exec_t:file execute;
:
:audit2allow -R
:
:#============= virt_qemu_ga_t ==============
:allow virt_qemu_ga_t shell_exec_t:file execute;
:

Comment 1 Kamil Páral 2012-11-02 13:07:31 UTC
Created attachment 637073 [details]
File: type

Comment 2 Kamil Páral 2012-11-02 13:07:33 UTC
Created attachment 637074 [details]
File: hashmarkername

Comment 3 Miroslav Grepl 2012-11-05 10:49:19 UTC
Is qemu-guest-agent supposed to be executing "pm-suspend"?

Comment 4 Miroslav Grepl 2012-11-05 10:50:37 UTC
*** Bug 872565 has been marked as a duplicate of this bug. ***

Comment 5 Kamil Páral 2012-11-05 14:28:56 UTC
According to this test case:
https://fedoraproject.org/wiki/QA:Testcase_Virtualization_Guest_Suspend_Hibernate
it seems to be supposed to do that.

Comment 6 Paolo Bonzini 2012-11-05 23:24:17 UTC
It's supposed to execute pm-is-supported, pm-hibernate, pm-suspend, pm-suspend-hybrid and /sbin/shutdown

Comment 7 Miroslav Grepl 2012-11-06 09:30:40 UTC
Fixed in selinux-policy-3.11.1-51.fc18

Comment 8 Fedora Update System 2012-11-28 20:56:35 UTC
selinux-policy-3.11.1-57.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-57.fc18

Comment 9 Fedora Update System 2012-11-30 06:34:44 UTC
Package selinux-policy-3.11.1-57.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-57.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19374/selinux-policy-3.11.1-57.fc18
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2012-12-02 19:28:48 UTC
Package selinux-policy-3.11.1-59.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-59.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19374/selinux-policy-3.11.1-59.fc18
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2012-12-06 20:11:06 UTC
Package selinux-policy-3.11.1-60.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-60.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-19374/selinux-policy-3.11.1-60.fc18
then log in and leave karma (feedback).

Comment 12 Fedora Update System 2012-12-07 04:29:49 UTC
selinux-policy-3.11.1-60.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.