This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 872582 - error: internal error block_io_throttle inserted entry was not in expected format
error: internal error block_io_throttle inserted entry was not in expected fo...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Libvirt Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-02 09:30 EDT by Kamil Páral
Modified: 2013-01-06 15:13 EST (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-06 15:13:49 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kamil Páral 2012-11-02 09:30:45 EDT
Description of problem:
I was trying to follow:
https://fedoraproject.org/wiki/QA:Testcase_Virtualization_IO_Throttling

But:
# virsh blkdeviotune Machine1 vda
error: Unable to get block I/O throttle parameters
error: internal error block_io_throttle inserted entry was not in expected format


Version-Release number of selected component (if applicable):
libvirt-0.10.2.1-2.fc18.x86_64
libvirt-client-0.10.2.1-2.fc18.x86_64
libvirt-daemon-0.10.2.1-2.fc18.x86_64
libvirt-daemon-config-network-0.10.2.1-2.fc18.x86_64
libvirt-daemon-config-nwfilter-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-interface-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-lxc-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-network-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-nodedev-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-nwfilter-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-qemu-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-secret-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-storage-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-uml-0.10.2.1-2.fc18.x86_64
libvirt-daemon-driver-xen-0.10.2.1-2.fc18.x86_64
libvirt-daemon-kvm-0.10.2.1-2.fc18.x86_64
libvirt-gconfig-0.1.3-1.fc18.x86_64
libvirt-glib-0.1.3-1.fc18.x86_64
libvirt-gobject-0.1.3-1.fc18.x86_64
libvirt-python-0.10.2.1-2.fc18.x86_64
python-virtinst-0.600.3-2.fc18.noarch
virt-manager-0.9.4-3.fc18.noarch
virt-manager-common-0.9.4-3.fc18.noarch
virt-viewer-0.5.4-2.fc18.x86_64
Comment 1 Eric Blake 2012-11-02 10:03:04 EDT
Fixed by these commits, and will be in 0.10.2.2:

commit 23d47b33a2f8b524c32d556d6d55a7ccb0c5903a
Author: Stefan Hajnoczi <stefanha@redhat.com>
Date:   Thu Nov 1 18:20:56 2012 +0100

    qemu: Fix name comparison in qemuMonitorJSONBlockIoThrottleInfo()
    
    The string comparison logic was inverted and matched the first drive
    that does *not* have the name we search for.
    
    Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>

commit 04ee70bfda21bfdb48b55f074aed25fc75bb9226
Author: Stefan Hajnoczi <stefanha@redhat.com>
Date:   Thu Nov 1 18:20:55 2012 +0100

    qemu: Keep QEMU host drive prefix in BlkIoTune
    
    The QEMU -drive id= begins with libvirt's QEMU host drive prefix
    ("drive-"), which is stripped off in several places two convert between
    host ("-drive") and guest ("-device") device names.
    
    In the case of BlkIoTune it is unnecessary to strip the QEMU host drive
    prefix because we operate on "info block"/"query-block" output that uses
    host drive names.
    
    Stripping the prefix incorrectly caused string comparisons to fail since
    we were comparing the guest device name against the host device name.
    
    Signed-off-by: Stefan Hajnoczi <stefanha@redhat.com>
Comment 2 Fedora Update System 2012-12-09 19:45:15 EST
libvirt-0.10.2.2-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/libvirt-0.10.2.2-1.fc18

Note You need to log in before you can comment on or make changes to this bug.