Bug 872640 - mouse pointer does not move in server mode (but it is able to click)
Summary: mouse pointer does not move in server mode (but it is able to click)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer
Version: 3.1.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: ---
Assignee: Marc-Andre Lureau
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-02 16:11 UTC by David Jaša
Modified: 2013-04-10 15:52 UTC (History)
6 users (show)

Fixed In Version: mingw-virt-viewer-0.5.3-17.el6
Doc Type: Bug Fix
Doc Text:
Previously, the mouse pointer could become stuck in server mode when using a Windows 7 client with dual monitors. The libspice-client-gtk has been updated to restore predictable mouse behavior.
Clone Of:
Environment:
Last Closed: 2012-12-04 17:59:24 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)
screencast (4.06 MB, video/mp4)
2012-11-13 12:15 UTC, David Jaša
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2012:1525 0 normal SHIPPED_LIVE new package: mingw-virt-viewer 2012-12-04 22:56:09 UTC

Description David Jaša 2012-11-02 16:11:42 UTC
Description of problem:
mouse pointer does not move in server mode (but it is able to click)

Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.3-14 and -15

How reproducible:
always

Steps to Reproduce:
1. open services.msc in windows guest, select "RHEV Spice Agent", hover over "Stop"
2. click stop
3.
  
Actual results:
mouse pointer is shown at some bogus location and it doesn't move

Expected results:
mouse pointer works normally

Additional info:
if you click next time, the service gets started - because "start" button is where "stop" button was and the pointer didn't move

Comment 1 Marc-Andre Lureau 2012-11-04 23:34:57 UTC
I can't reproduce. I tried with tablet and there is no jump. Without tablet, there is a tiny jump, but the mouse is still perfectly usable. What version of Windows didn't use? I tried with Windows 8. Can you try with different version of Windows? I suppose the guest has QXL driver installed?

Comment 2 David Jaša 2012-11-05 12:19:07 UTC
I didn't use tablet in any case. I got "perfectly usable" server mouse in a single case actually: when I had the cursor grabbed on the secondary screen of dual-monitor guest. In any other case (Fedora 17 VM, single-monitor VM with or without qxl driver, dual monitor VMs with mouse grabbed on primary screen), I hit this bug.

Client: Windows 7 32b and 64b, mingw-virt-viewer-0.5.3-15 and -16. I could possibly try on XP, too.

Comment 3 Tomas Jamrisko 2012-11-06 17:22:20 UTC
Funny thing. I could reproduce this bug only after connecting a second monitor to the client windows machine. After disconnecting the second monitor everything returned back to normal.

Comment 4 David Jaša 2012-11-07 11:16:00 UTC
Confirmed, the bug isn't reproducible on single-monitor client, on -16 even in situations that were 100% reproducers (two-monitor windowed guest with overlapping windows). Plug the second monitor in and the bug will occur again...

Comment 7 Marc-Andre Lureau 2012-11-13 10:16:37 UTC
I can't reproduce, but I fixed two small related bugs while looking into this. Can you try to reproduce with http://elmarco.fedorapeople.org/libspice-client-gtk-2.0-4.dll (overwrite the one in $prefix/bin), if you manage to reproduce it would be nice to make it a screencast (even with a phone)

Comment 8 David Jaša 2012-11-13 12:15:21 UTC
Created attachment 644075 [details]
screencast

The actual behavior is different based on actual screen layout and r-v window position:

 r-v on monitor |  left            right
     ---        |
primary monitor |
----------------+-----------------------------------
left            |  works OK        cursor is not
                |                  grabbed
                |
right           |  cursor is not   cursor is grabbed but it isn't
                |  grabbed         displayed and can not move

You should be able to recognize all the behaviours on the screencast. My client monitor configuration is two 1920x1080 screens side-by-side with primary monitor typically on the right.

Comment 9 David Jaša 2012-11-13 12:31:28 UTC
The recorded behaviour is with your .dll used instead of package one.

Comment 10 Marc-Andre Lureau 2012-11-13 13:19:50 UTC
(In reply to comment #9)
> The recorded behaviour is with your .dll used instead of package one.

I think I got it. Can you give the new http://elmarco.fedorapeople.org/libspice-client-gtk-2.0-4.dll a try? I am missing physical dual-head windows here. thanks!

Comment 11 David Jaša 2012-11-13 13:53:49 UTC
Now the behavior is correct for if primary screen is top or left one regardless of r-v window position. If primary screen is right or bottom, "cursor is grabbed but it isn't displayed and can not move" scenario occurs.

Comment 12 Marc-Andre Lureau 2012-11-13 14:44:40 UTC
(In reply to comment #11)
> Now the behavior is correct for if primary screen is top or left one
> regardless of r-v window position. If primary screen is right or bottom,
> "cursor is grabbed but it isn't displayed and can not move" scenario occurs.

do I understand correctly just lower-right corner case of your table is left?

Comment 13 David Jaša 2012-11-13 17:59:59 UTC
(In reply to comment #12)
> 
> do I understand correctly just lower-right corner case of your table is left?

exactly.

Comment 14 Marc-Andre Lureau 2012-11-13 20:32:28 UTC
(In reply to comment #13)
> (In reply to comment #12)
> > 
> > do I understand correctly just lower-right corner case of your table is left?
> 
> exactly.

ok, I am quite happy to report that I can reproduce that final? corner-case :) looking at it

Comment 15 Marc-Andre Lureau 2012-11-13 22:57:02 UTC
David, can you try with the latest version of http://elmarco.fedorapeople.org/libspice-client-gtk-2.0-4.dll. It works for me now. Thanks a lot!

Comment 16 David Jaša 2012-11-14 10:29:18 UTC
Works for me too in all the cases outlined above.

Comment 17 Marc-Andre Lureau 2012-11-14 16:24:06 UTC
patch sent to ML, building in brew

Comment 18 Marc-Andre Lureau 2012-11-14 16:24:39 UTC
please add acks!

Comment 19 Marc-Andre Lureau 2012-11-15 22:08:58 UTC
fixed in mingw-virt-viewer-0.5.3-17.el6

Comment 23 errata-xmlrpc 2012-12-04 17:59:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1525.html


Note You need to log in before you can comment on or make changes to this bug.