Bug 872696 - QMF queue events do not propagate to HA backups
QMF queue events do not propagate to HA backups
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp (Show other bugs)
Development
Unspecified Unspecified
high Severity high
: 2.3
: ---
Assigned To: Alan Conway
MRG Quality Engineering
: OtherQA, Patch
Depends On:
Blocks: 698367
  Show dependency treegraph
 
Reported: 2012-11-02 14:45 EDT by Jason Dillaman
Modified: 2013-03-19 12:39 EDT (History)
5 users (show)

See Also:
Fixed In Version: qpid-cpp-0.18-9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 12:39:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Quick patch to prevent duplicate output tasks (1.81 KB, patch)
2012-11-08 14:47 EST, Jason Dillaman
no flags Details | Diff
Quick patch to prevent duplicate output tasks (2.07 KB, patch)
2012-11-08 16:11 EST, Jason Dillaman
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Apache JIRA QPID-4430 None None None 2012-11-12 16:26:13 EST

  None (edit)
Description Jason Dillaman 2012-11-02 14:45:43 EDT
Description of problem:
After unsubscribing the last consumer from an auto-delete queue, the delete event was not propagated to the backup nodes.  Additionally, after re-creating a queue with the same name, the the backup did not receive the declare event.  The original queue declare event was correctly propagated to the backup.

Version-Release number of selected component (if applicable):
qpid-cpp-0.18-6

How reproducible:
100%

Steps to Reproduce:
1. Subscribe to an auto-delete queue
2. Unsubscribe from the auto-delete queue
  
Actual results:
The backup node did not receive the delete event.

Expected results:
The backup node should receive the delete event.
Comment 1 Jason Dillaman 2012-11-05 10:48:53 EST
After additional investigation, the issue appears to have been exposed due to channel errors that resulted in the link reconnecting (see BZ873347).  The QMF channel did not have any errors in the log but somehow the backup missed a queue creation event and thus failed to replicate a queue.
Comment 2 Jason Dillaman 2012-11-07 12:55:55 EST
Issue is not 100% reproducible, but has happened often across numerous machines.
Comment 3 Jason Dillaman 2012-11-08 14:47:04 EST
Created attachment 641055 [details]
Quick patch to prevent duplicate output tasks
Comment 4 Jason Dillaman 2012-11-08 14:49:00 EST
Discovered that the inter-broker link had hundreds of thousands of enqueued OutputTasks -- representing only a few unique consumers.  There should only be only a single output task for a given consumer.  This appears to have stalled the delivery of QMF messages to the backup broker.
Comment 5 Jason Dillaman 2012-11-08 16:11:33 EST
Created attachment 641080 [details]
Quick patch to prevent duplicate output tasks

Note You need to log in before you can comment on or make changes to this bug.