Bug 872700 - semodule in RHEL-6 behaves differently than in RHEL-7
Summary: semodule in RHEL-6 behaves differently than in RHEL-7
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libsemanage
Version: 6.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Petr Lautrbach
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-02 18:59 UTC by Milos Malik
Modified: 2015-07-22 07:33 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-07-22 07:33:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:1403 normal SHIPPED_LIVE libsemanage bug fix update 2015-07-20 18:07:13 UTC

Description Milos Malik 2012-11-02 18:59:50 UTC
Description of problem:

Version-Release number of selected component (if applicable):
policycoreutils-2.0.83-19.26.el6
libsemanage-2.0.43-4.2.el6

How reproducible:
always

Steps to Reproduce:
# semodule -l | grep perm
permissivedomains	1.0.0	
# semodule -e permissivedomains
libsemanage.semanage_direct_enable: Module permissivedomains was not found.
semodule:  Failed!
# semodule -d permissivedomains
# semodule -d permissivedomains
libsemanage.semanage_direct_disable: Module permissivedomains was not found.
semodule:  Failed!
# semodule -l | grep perm
permissivedomains	1.0.0	Disabled
#
  
Actual results:
 * semodule fails when enabling an already enabled module
 * semodule fails when disabling an already disabled module

Expected results:
 * semodule succeeds when enabling an already enabled module
 * semodule succeeds when disabling an already disabled module

Comment 2 Daniel Walsh 2012-11-05 17:22:01 UTC
You want the RHEL7 method back ported form RHEL6?

Comment 3 Milos Malik 2012-11-06 07:30:54 UTC
I would like to see RHEL-6 semodule behaving in the same way as in RHEL-7:
 * when a policy module xyz is already enabled, another "semodule -e xyz" command should not lead to error message
 * when a policy module xyz is already disabled, another "semodule -d xyz" command should not lead to error message
 * error messages mentioned in comment#0 are misleading, the policy module is present and is already in the desired state

Comment 4 RHEL Product and Program Management 2012-12-14 07:19:56 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 6 Petr Lautrbach 2015-02-24 13:17:37 UTC
It was fixed/change in Fedora in libsemanage package [1] [2]. Both patches seems to be simply backportable.

[1] https://github.com/fedora-selinux/selinux/commit/654dcb897e49908a958dae55cf29793412c4b390
[2] https://github.com/fedora-selinux/selinux/commit/c1323f22c7ad93b975eb8b6a251b893bc88f240f

Comment 9 errata-xmlrpc 2015-07-22 07:33:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1403.html


Note You need to log in before you can comment on or make changes to this bug.