Bug 872773 - [abrt] pkgwat-0.3-2.fc18: pkg_resources.py:588:resolve:DistributionNotFound: PIL
Summary: [abrt] pkgwat-0.3-2.fc18: pkg_resources.py:588:resolve:DistributionNotFound: PIL
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pkgwat
Version: 18
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Ralph Bean
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:b0ddaf807106f6150ccc01448c9...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-03 00:40 UTC by Gerard Ryan
Modified: 2012-11-10 03:13 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-10 03:13:16 UTC
Type: ---


Attachments (Terms of Use)
File: executable (15 bytes, text/plain)
2012-11-03 00:40 UTC, Gerard Ryan
no flags Details
File: environ (2.76 KB, text/plain)
2012-11-03 00:40 UTC, Gerard Ryan
no flags Details
File: dso_list (38 bytes, text/plain)
2012-11-03 00:40 UTC, Gerard Ryan
no flags Details
File: core_backtrace (394 bytes, text/plain)
2012-11-03 00:40 UTC, Gerard Ryan
no flags Details

Description Gerard Ryan 2012-11-03 00:40:02 UTC
Description of problem:
Fedora 18 Alpha

yum install pkgwat

pkgwat search nethack


Version-Release number of selected component:
pkgwat-0.3-2.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
cmdline:        /usr/bin/python /usr/bin/pkgwat search nethack
kernel:         3.6.5-2.fc18.x86_64

backtrace:
:pkg_resources.py:588:resolve:DistributionNotFound: PIL
:
:Traceback (most recent call last):
:  File "/usr/bin/pkgwat", line 5, in <module>
:    from pkg_resources import load_entry_point
:  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 2815, in <module>
:    working_set.require(__requires__)
:  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 690, in require
:    needed = self.resolve(parse_requirements(requirements))
:  File "/usr/lib/python2.7/site-packages/pkg_resources.py", line 588, in resolve
:    raise DistributionNotFound(req)
:DistributionNotFound: PIL
:
:Local variables in innermost frame:
:dist: None
:to_activate: [pkgwat.cli 0.3 (/usr/lib/python2.7/site-packages)]
:req: Requirement.parse('PIL')
:requirements: [Requirement.parse('fabulous'), Requirement.parse('cliff'), Requirement.parse('six'), Requirement.parse('pkgwat.api>=0.3')]
:processed: {Requirement.parse('pkgwat.cli==0.3'): True}
:env: <pkg_resources.Environment object at 0x83b690>
:installer: None
:self: <pkg_resources.WorkingSet object at 0x83b210>
:best: {'pil': None}
:replacement: True

Comment 1 Gerard Ryan 2012-11-03 00:40:06 UTC
Created attachment 637357 [details]
File: executable

Comment 2 Gerard Ryan 2012-11-03 00:40:08 UTC
Created attachment 637358 [details]
File: environ

Comment 3 Gerard Ryan 2012-11-03 00:40:10 UTC
Created attachment 637359 [details]
File: dso_list

Comment 4 Gerard Ryan 2012-11-03 00:40:12 UTC
Created attachment 637360 [details]
File: core_backtrace

Comment 5 Ralph Bean 2012-11-03 02:22:56 UTC
pkgwat-0.3-3 should hopefully fix it.

As a workaround in the meantime you can yum install python-imaging and python-fabulous.

Comment 6 Fedora Update System 2012-11-03 02:30:47 UTC
pkgwat-0.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pkgwat-0.3-3.fc18

Comment 7 Fedora Update System 2012-11-03 19:31:21 UTC
Package pkgwat-0.3-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pkgwat-0.3-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17548/pkgwat-0.3-3.fc18
then log in and leave karma (feedback).


Note You need to log in before you can comment on or make changes to this bug.