Bug 872791 - TypeError: Argument 1 does not allow None as a value
TypeError: Argument 1 does not allow None as a value
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
abrt_hash:e1beb459df3d56c687be8d29a0a...
:
: 872795 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker 858801 872282
  Show dependency treegraph
 
Reported: 2012-11-03 03:03 EDT by Steve Tyler
Modified: 2012-11-09 20:33 EST (History)
11 users (show)

See Also:
Fixed In Version: anaconda-18.25-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:16:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (3.77 MB, text/plain)
2012-11-03 03:03 EDT, Steve Tyler
no flags Details
File: environ (880 bytes, text/plain)
2012-11-03 03:03 EDT, Steve Tyler
no flags Details
File: type (9 bytes, text/plain)
2012-11-03 03:03 EDT, Steve Tyler
no flags Details
File: ifcfg.log (16.47 KB, text/plain)
2012-11-03 03:03 EDT, Steve Tyler
no flags Details
File: storage.log (2.13 MB, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: version (2 bytes, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: program.log (809.42 KB, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: product (6 bytes, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: anaconda.log (143.70 KB, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: packaging.log (1.11 KB, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: cmdline_file (162 bytes, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: release (33 bytes, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: messages (669.43 KB, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
File: other involved packages (32 bytes, text/plain)
2012-11-03 03:04 EDT, Steve Tyler
no flags Details
anaconda-tb-G_2Git from Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso (471.69 KB, text/plain)
2012-11-03 04:52 EDT, Steve Tyler
no flags Details

  None (edit)
Description Steve Tyler 2012-11-03 03:03:37 EDT
Description of problem:
Select 'Chinese (Taiwan)' for install language.

Version-Release number of selected component:
anaconda-18.24-1.fc18.x86_64

Additional info:
libreport version: 2.0.14
cmdline:        /usr/bin/python  /sbin/anaconda --liveinst --method=livecd:///dev/mapper/live-osimg-min --lang en_US.UTF-8
kernel:         3.6.1-1.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.24 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/gi/types.py", line 47, in function
:    return info.invoke(*args, **kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1639, in _populate_right_side
:    typeCombo.set_active(partition_pos)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1956, in on_selector_clicked
:    self._populate_right_side(selector)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1820, in _show_first_mountpoint
:    self.on_selector_clicked(page._members[0])
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/custom.py", line 1974, in on_page_clicked
:    self._show_first_mountpoint(page=page)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/ui/gui/spokes/lib/accordion.py", line 119, in _onExpanded
:    cb(obj.get_child())
:TypeError: Argument 1 does not allow None as a value
Comment 1 Steve Tyler 2012-11-03 03:03:51 EDT
Created attachment 637386 [details]
File: anaconda-tb
Comment 2 Steve Tyler 2012-11-03 03:03:53 EDT
Created attachment 637387 [details]
File: environ
Comment 3 Steve Tyler 2012-11-03 03:03:55 EDT
Created attachment 637388 [details]
File: type
Comment 4 Steve Tyler 2012-11-03 03:03:56 EDT
Created attachment 637389 [details]
File: ifcfg.log
Comment 5 Steve Tyler 2012-11-03 03:04:03 EDT
Created attachment 637390 [details]
File: storage.log
Comment 6 Steve Tyler 2012-11-03 03:04:05 EDT
Created attachment 637391 [details]
File: version
Comment 7 Steve Tyler 2012-11-03 03:04:09 EDT
Created attachment 637392 [details]
File: program.log
Comment 8 Steve Tyler 2012-11-03 03:04:11 EDT
Created attachment 637393 [details]
File: product
Comment 9 Steve Tyler 2012-11-03 03:04:12 EDT
Created attachment 637394 [details]
File: anaconda.log
Comment 10 Steve Tyler 2012-11-03 03:04:14 EDT
Created attachment 637395 [details]
File: hashmarkername
Comment 11 Steve Tyler 2012-11-03 03:04:15 EDT
Created attachment 637396 [details]
File: packaging.log
Comment 12 Steve Tyler 2012-11-03 03:04:17 EDT
Created attachment 637397 [details]
File: cmdline_file
Comment 13 Steve Tyler 2012-11-03 03:04:19 EDT
Created attachment 637398 [details]
File: release
Comment 14 Steve Tyler 2012-11-03 03:04:23 EDT
Created attachment 637399 [details]
File: messages
Comment 15 Steve Tyler 2012-11-03 03:04:25 EDT
Created attachment 637400 [details]
File: other involved packages
Comment 16 Steve Tyler 2012-11-03 03:25:47 EDT
Select 'Chinese (China)' for install language.

Package: anaconda-18.24-1.fc18.x86_64
OS Release: Fedora release 18
Comment 17 Steve Tyler 2012-11-03 03:29:25 EDT
This was with anaconda-18.24-1 on Fedora-18-Beta-TC6-x86_64-Live-Desktop.iso. I successfully completed at least six previous test installs with other languages. I reproduced the crash a second time. Then I tried installing in English, and that succeeded. Installing with zh_CN also crashed.

$ qemu-kvm -m 4096 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC6/Fedora-18-Beta-TC6-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 18 Steve Tyler 2012-11-03 03:32:38 EDT
Choose Dutch for install language.

Package: anaconda-18.24-1.fc18.x86_64
OS Release: Fedora release 18
Comment 19 Steve Tyler 2012-11-03 04:12:40 EDT
Choose 'Chinese (Taiwan)' for install language.

Package: anaconda-18.24-1.fc18.x86_64
OS Release: Fedora release 18
Comment 20 Steve Tyler 2012-11-03 04:14:37 EDT
(In reply to comment #19)
> Choose 'Chinese (Taiwan)' for install language.
> 
> Package: anaconda-18.24-1.fc18.x86_64
> OS Release: Fedora release 18

This time it was with Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso:

$ qemu-kvm -m 4096 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC7/Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 21 Steve Tyler 2012-11-03 04:52:09 EDT
Created attachment 637431 [details]
anaconda-tb-G_2Git from Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso

Crash while installing in Japanese.

$ qemu-kvm -m 4096 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC7/Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 22 Wolfgang Pirker 2012-11-03 08:34:50 EDT
* select installation destination, click on Continue
* click combobox I don't need help
* click on a expander
* then the unkown error warning dialog pops up

as installation medium a USB thumb drive was used. Created with the livecd-iso-to-disk tool.



Package: anaconda-18.24-1.fc18.x86_64
OS Release: Fedora release 18
Comment 23 Steve Tyler 2012-11-03 10:36:09 EDT
Downgrade to anaconda-18.23-1.
Choose Dutch for install language.


Package: anaconda-18.23-1.fc18.x86_64
OS Release: Fedora release 18
Comment 24 Steve Tyler 2012-11-03 10:59:46 EDT
This bug does not occur in anaconda-18.22-1. Tested with:
1. Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso
2. Dutch, Japanese.

So the problem was introduced in anaconda-18.23-1 (Comment 23).

$ qemu-kvm -m 4096 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC7/Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 25 Adam Williamson 2012-11-03 12:39:08 EDT
w_pirker: what language did you pick for install? Does the error occur if you pick English?
Comment 26 Adam Williamson 2012-11-03 12:39:46 EDT
This looks like a blocker.
Comment 27 Steve Tyler 2012-11-03 14:02:31 EDT
The crash does not occur with these languages:
Bosnian
Basque
Armenian
Georgian
Bengali (India)

NB: This list is not comprehensive ...
Comment 28 Wolfgang Pirker 2012-11-03 15:40:36 EDT
Adam, I did choose Deutsch (German) as language. I tested it if it happens with English as well. It doesn't happen then.
Comment 29 Brian Lane 2012-11-03 18:44:19 EDT
I think this is related to glade translations not always working right. The point where this fails is trying to match a hard-coded translated string to the translated string in the Type combobox. Not finding a match would cause this traceback.
Comment 30 Adam Williamson 2012-11-05 11:40:32 EST
Discussed at 2012-11-05 QA meeting acting as a blocker review meeting. Accepted as a blocker per criterion "The installer must boot and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick", in the case of many non-English languages (we've seen several people hit this bug with various languages).
Comment 31 Chris Lumens 2012-11-05 12:20:32 EST
Well that was tedious.  Posting a patch later today.
Comment 32 Steve Tyler 2012-11-05 13:35:19 EST
*** Bug 872795 has been marked as a duplicate of this bug. ***
Comment 33 Fedora Update System 2012-11-05 20:37:33 EST
anaconda-18.25-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.25-1.fc18
Comment 34 Steve Tyler 2012-11-06 10:51:30 EST
anaconda-18.24-1 reproducer:

Create a disc image with partitions.

Select one of these install languages:
    Chinese (Taiwan)
    Dutch
    Japanese
    Spanish
    NB: This bug does not occur with all install languages.

Click Installation Destination.
Click Continue.
Check "I don't need help ...".
Click "Reclaim space".
Click "+" to expand the list of preexisting partitions.

NB: If you don't read the install language, you will need to memorize the locations of the buttons and boxes.

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC7/Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse
Comment 35 Steve Tyler 2012-11-06 13:28:40 EST
This bug does not occur with anaconda-18.25-1 using the reproducer in Comment 34.[1]

Tested with:
$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC7/Fedora-18-Beta-TC7-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on -usbdevice mouse

[1] The reproducer does not provide test complete coverage for the changes in the commit to fix this bug:
-rw-r--r--	pyanaconda/ui/gui/spokes/custom.py	94	
-rw-r--r--	pyanaconda/ui/gui/spokes/datetime_spoke.py	4	
-rw-r--r--	pyanaconda/ui/gui/spokes/keyboard.py	4	
-rw-r--r--	pyanaconda/ui/gui/spokes/source.py	14	
4 files changed, 58 insertions, 58 deletions

Mark strings at the top of spokes with N_; translate later with _ (#872791).
http://git.fedorahosted.org/cgit/anaconda.git/commit/?id=0d5138002d0f842cacd90562e9b3a96a20329720
Comment 36 Fedora Update System 2012-11-06 13:49:09 EST
Package anaconda-18.25-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.25-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17691/anaconda-18.25-1.fc18
then log in and leave karma (feedback).
Comment 37 Fedora Update System 2012-11-06 21:09:32 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 38 Adam Williamson 2012-11-07 03:16:50 EST
Built a live image with anaconda 18.26 for smoke testing. Tried to install in German. Hit this crash in custom partitioning. I expect it'll be a dupe of 872791 which was supposed to be fixed in 18.26, so fails QA.

Package: anaconda-18.26-1.fc18.x86_64
OS Release: Fedora release 18
Comment 39 Chris Lumens 2012-11-07 10:00:55 EST
Please attach the traceback.
Comment 40 Fedora Update System 2012-11-07 13:46:45 EST
Package anaconda-18.26-1.fc18, lorax-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.26-1.fc18 lorax-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17714/lorax-18.22-1.fc18,anaconda-18.26-1.fc18
then log in and leave karma (feedback).
Comment 41 Adam Williamson 2012-11-07 14:10:09 EST
STOP IT BODHI
Comment 42 Adam Williamson 2012-11-07 14:47:48 EST
OK, so my test case was actually crazier than I thought (late night error, sorry). It was this:

1. Pick Deutsch (Deutschland) at the pre-hub language select screen
2. Change back to English (U.S.) by clicking on the language option on the hub
3. Go to custom partitioning and try to remove an existing partition

Apparently it's 'never going to work' to change the language from the hub, so we should just take that option out. I'll file that separately. If I leave the install in German, I don't hit this traceback, though I do see another bug which I'll also file separately. Setting VERIFIED.
Comment 43 Adam Williamson 2012-11-07 14:52:18 EST
Filed https://bugzilla.redhat.com/show_bug.cgi?id=874263 for the reproducer in comment #42.
Comment 44 Fedora Update System 2012-11-07 22:23:46 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 45 Adam Williamson 2012-11-08 04:16:33 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken). Subsequent dupes are likely https://bugzilla.redhat.com/show_bug.cgi?id=874263 or some other variation.
Comment 46 Steve Tyler 2012-11-08 09:25:38 EST
Adam: The commit[1] to fix this bug appears to have introduced:

Bug 873762 - [zh_CN] [zh_TW] installer hangs in Installation Summary when keyboard spoke clicked

See:
[master] [PATCH] Encode unicode strings from XklWrapper (#873762)
https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-November/002008.html

The commit made 58 insertions, 58 deletions in 4 files.[2] I am concerned that this bug is being closed prematurely without fully analyzing the commit or testing all of the changes.

[1] Mark strings at the top of spokes with N_; translate later with _ (#872791).
http://git.fedorahosted.org/cgit/anaconda.git/commit/?id=0d5138002d0f842cacd90562e9b3a96a20329720

[2] The diffstat from Comment 35:
-rw-r--r--	pyanaconda/ui/gui/spokes/custom.py	94	
-rw-r--r--	pyanaconda/ui/gui/spokes/datetime_spoke.py	4	
-rw-r--r--	pyanaconda/ui/gui/spokes/keyboard.py	4	
-rw-r--r--	pyanaconda/ui/gui/spokes/source.py	14	
4 files changed, 58 insertions, 58 deletions
Comment 47 Steve Tyler 2012-11-08 09:36:53 EST
Here are the posts from anaconda-patches:
[PATCH] fixes for f18-beta
https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-November/001927.html
Comment 48 Vratislav Podzimek 2012-11-09 07:12:18 EST
(In reply to comment #46)
> Adam: The commit[1] to fix this bug appears to have introduced:
> 
> Bug 873762 - [zh_CN] [zh_TW] installer hangs in Installation Summary when
> keyboard spoke clicked
> 
> See:
> [master] [PATCH] Encode unicode strings from XklWrapper (#873762)
> https://lists.fedorahosted.org/pipermail/anaconda-patches/2012-November/
> 002008.html
> 
> The commit made 58 insertions, 58 deletions in 4 files.[2] I am concerned
> that this bug is being closed prematurely without fully analyzing the commit
> or testing all of the changes.
Yes the fix for this bug introduced bug 873762, but only by hitting the issue that was hidden before by actually using translated strings.
Comment 49 Steve Tyler 2012-11-09 08:01:21 EST
(In reply to comment #48)
...
> Yes the fix for this bug introduced bug 873762, but only by hitting the
> issue that was hidden before by actually using translated strings.

Thanks for your comment. I will rephrase my summary: :-)
"The commit to fix this bug _exposed_ Bug 873762."
Comment 50 Adam Williamson 2012-11-09 20:33:45 EST
Steve: when an update is marked as fixing a bug, the bug is usually automatically closed when the update is pushed stable. That mechanism is currently broken so I just went through and did the same thing manually, but this is what would have happened anyway if Bodhi weren't broken.

The anaconda build in question fixed something like 25-30 bugs; it's really not practical for us to go through and thoroughly test every single change before pushing the update stable or closing the bugs. We'd never get done. We _did_ specifically verify and test the blockers, including this one. As Vratislav points out, this fix was correct and did not introduce any regression, it just allowed you to hit a bug that was present all along in any case. There would be no benefit in leaving this bug open, closing it is correct.

Note You need to log in before you can comment on or make changes to this bug.