Bug 872849 - BTRFSError: 12
BTRFSError: 12
Status: CLOSED DUPLICATE of bug 868468
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:c19d279bf1a09293cc61db16959...
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-03 15:49 EDT by Reartes Guillermo
Modified: 2012-12-18 12:56 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-06 18:01:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: anaconda-tb (363.47 KB, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: product (6 bytes, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: type (9 bytes, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: ifcfg.log (641 bytes, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: storage.log (189.37 KB, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: version (11 bytes, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: environ (794 bytes, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: executable (14 bytes, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: anaconda.log (9.65 KB, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: syslog (64.85 KB, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: packaging.log (3.05 KB, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: cmdline_file (96 bytes, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: release (24 bytes, text/plain)
2012-11-03 15:49 EDT, Reartes Guillermo
no flags Details
File: program.log (50.80 KB, text/plain)
2012-11-03 15:50 EDT, Reartes Guillermo
no flags Details
storage.log of the previous comment (187.37 KB, text/plain)
2012-11-03 17:18 EDT, Reartes Guillermo
no flags Details
storage.log of the previous comment (187.37 KB, text/plain)
2012-11-03 17:21 EDT, Reartes Guillermo
no flags Details
traceback from my 18.24 cleanish reproducer (229.47 KB, text/plain)
2012-11-06 16:30 EST, Adam Williamson
no flags Details
storage.log from my reproducer (96.69 KB, text/x-log)
2012-11-06 16:31 EST, Adam Williamson
no flags Details
program.log from my reproducer (19.64 KB, text/plain)
2012-11-06 16:31 EST, Adam Williamson
no flags Details

  None (edit)
Description Reartes Guillermo 2012-11-03 15:49:13 EDT
Description of problem:
a previous F18 instance, using automatic partitioning type BTRFS of 2 disks.
i selected these 2 disks, and tried automatic partitioning again but with LVM, in the reclaim space
dialog, i set all to 'delete' but for the last disks i choose 'shrink' wich does not make sense.
if you are swiching from BTRFS to LVM you cannot shrink and most likely no preserve too, since the btrfs previously created spans the two disks and so will be the LVM that will be created.


Version-Release number of selected component:
anaconda-18.24

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.5-2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.24 exception report
:Traceback (most recent call first):
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/btrfs.py", line 46, in btrfs
:    raise BTRFSError(ret)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicelibs/btrfs.py", line 95, in delete_subvolume
:    return btrfs(args)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 4115, in _destroy
:    btrfs.delete_subvolume(mountpoint, self.name)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devices.py", line 819, in destroy
:    self._destroy()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/deviceaction.py", line 286, in execute
:    self.device.destroy()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/devicetree.py", line 323, in processActions
:    action.execute()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 293, in doIt
:    self.devicetree.processActions()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 131, in turnOnFilesystems
:    storage.doIt()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 113, in doInstall
:    turnOnFilesystems(storage)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:BTRFSError: 12
Comment 1 Reartes Guillermo 2012-11-03 15:49:24 EDT
Created attachment 637612 [details]
File: anaconda-tb
Comment 2 Reartes Guillermo 2012-11-03 15:49:26 EDT
Created attachment 637613 [details]
File: product
Comment 3 Reartes Guillermo 2012-11-03 15:49:28 EDT
Created attachment 637614 [details]
File: type
Comment 4 Reartes Guillermo 2012-11-03 15:49:31 EDT
Created attachment 637615 [details]
File: ifcfg.log
Comment 5 Reartes Guillermo 2012-11-03 15:49:37 EDT
Created attachment 637616 [details]
File: storage.log
Comment 6 Reartes Guillermo 2012-11-03 15:49:39 EDT
Created attachment 637617 [details]
File: version
Comment 7 Reartes Guillermo 2012-11-03 15:49:41 EDT
Created attachment 637618 [details]
File: environ
Comment 8 Reartes Guillermo 2012-11-03 15:49:44 EDT
Created attachment 637619 [details]
File: executable
Comment 9 Reartes Guillermo 2012-11-03 15:49:46 EDT
Created attachment 637620 [details]
File: anaconda.log
Comment 10 Reartes Guillermo 2012-11-03 15:49:49 EDT
Created attachment 637621 [details]
File: syslog
Comment 11 Reartes Guillermo 2012-11-03 15:49:52 EDT
Created attachment 637622 [details]
File: hashmarkername
Comment 12 Reartes Guillermo 2012-11-03 15:49:54 EDT
Created attachment 637623 [details]
File: packaging.log
Comment 13 Reartes Guillermo 2012-11-03 15:49:56 EDT
Created attachment 637624 [details]
File: cmdline_file
Comment 14 Reartes Guillermo 2012-11-03 15:49:58 EDT
Created attachment 637625 [details]
File: release
Comment 15 Reartes Guillermo 2012-11-03 15:50:01 EDT
Created attachment 637626 [details]
File: program.log
Comment 16 Reartes Guillermo 2012-11-03 17:17:04 EDT
In another new guest selecting several disks, i installed with automatic partitioning type btrfs ok.

Then i tried to install over with automatic partitioning type plain and set all partitions to 'delete'. Anaconda could not delete the previously created btrfs setup.
Comment 17 Reartes Guillermo 2012-11-03 17:18:40 EDT
Created attachment 637685 [details]
storage.log of the previous comment
Comment 18 Reartes Guillermo 2012-11-03 17:21:59 EDT
Created attachment 637687 [details]
storage.log of the previous comment
Comment 19 Adam Williamson 2012-11-06 15:47:05 EST
I can't recall precisely what happened, but I think this is the result of something odd that happened while I was removing existing partitions - a previous btrfs install of F18 - in custom partitioning. I think I clicked on the root partition, then did some stuff to it in the right hand pane, then clicked on it in the left hand pane again, and it disappeared from the list; I clicked the '-' button to delete it, and the message that popped up suggested either that the partition was called '5' or it was part of a group called '5' or something like that. I fiddled about some more, then went to complete the install, and this crash happened during partitioning. I'll try and reproduce more precisely.

Package: anaconda-18.24
OS Release: Fedora release 18-Beta-TC7
Comment 20 Adam Williamson 2012-11-06 16:26:46 EST
So this is definitely to do with removing existing btrfs partitions.

I can actually hit it simply by using guided partitioning on a certain btrfs layout I have in a VM. No entry into custom part is needed. All I have to do is tell the 'guided freeing up space' dialog to delete all the existing partitions, and continue with install, and it explodes. It's really choking on this existing layout somehow.

Here's some info on the layout:

btrfs subvol list:

ID 256 gen 12 top level 5 path home
ID 258 gen 26 top level 5 path root

btrfs filesystem show:

Label: 'fedora'  uuid: 5b678d48-5fc8-492a-9ce2-d99112a692b4
	Total devices 1 FS bytes used 596.00MB
	devid    1 size 12.54GB used 3.04GB path /dev/vda2

Btrfs Btrfs v0.19

parted -s /dev/vda p:

Model: Virtio Block Device (virtblk)
Disk /dev/vda: 16.1GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags: 

Number  Start   End     Size    Type     File system  Flags
 1      1049kB  525MB   524MB   primary               boot
 2      525MB   14.0GB  13.5GB  primary


I'll also attach the logs from my cleanest reproducer.
Comment 21 Adam Williamson 2012-11-06 16:30:00 EST
Created attachment 639625 [details]
traceback from my 18.24 cleanish reproducer
Comment 22 Adam Williamson 2012-11-06 16:31:02 EST
Created attachment 639626 [details]
storage.log from my reproducer
Comment 23 Adam Williamson 2012-11-06 16:31:25 EST
Created attachment 639627 [details]
program.log from my reproducer
Comment 24 David Lehman 2012-11-06 18:01:46 EST

*** This bug has been marked as a duplicate of bug 868468 ***
Comment 25 Clyde E. Kunkel 2012-12-18 12:56:09 EST
Hit this in TC3, but did not save logs so can't contribute meaningfully except to note that I had created a btrfs subvolume in running TC2 system.  Had to deleted all partitions when I tried to reinstall using TC3.

Note You need to log in before you can comment on or make changes to this bug.