Bug 872851 - [abrt] rhythmbox-2.98-4.fc18: Process /usr/bin/rhythmbox was killed by signal 11 (SIGSEGV)
[abrt] rhythmbox-2.98-4.fc18: Process /usr/bin/rhythmbox was killed by signal...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pygobject3 (Show other bugs)
18
All Linux
high Severity high
: ---
: ---
Assigned To: John (J5) Palmieri
Fedora Extras Quality Assurance
abrt_hash:852139614877e151645207f75a1...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-03 16:08 EDT by Stephan Peccini
Modified: 2013-01-08 16:31 EST (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-08 16:31:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (5.09 KB, text/plain)
2012-11-03 16:08 EDT, Stephan Peccini
no flags Details
File: environ (1.49 KB, text/plain)
2012-11-03 16:08 EDT, Stephan Peccini
no flags Details
File: limits (1.29 KB, text/plain)
2012-11-03 16:09 EDT, Stephan Peccini
no flags Details
File: backtrace (51.67 KB, text/plain)
2012-11-03 16:09 EDT, Stephan Peccini
no flags Details
File: cgroup (130 bytes, text/plain)
2012-11-03 16:09 EDT, Stephan Peccini
no flags Details
File: executable (18 bytes, text/plain)
2012-11-03 16:09 EDT, Stephan Peccini
no flags Details
File: maps (103.65 KB, text/plain)
2012-11-03 16:09 EDT, Stephan Peccini
no flags Details
File: dso_list (23.30 KB, text/plain)
2012-11-03 16:09 EDT, Stephan Peccini
no flags Details
File: proc_pid_status (932 bytes, text/plain)
2012-11-03 16:09 EDT, Stephan Peccini
no flags Details
File: var_log_messages (3.54 KB, text/plain)
2012-11-03 16:09 EDT, Stephan Peccini
no flags Details
File: open_fds (1.17 KB, text/plain)
2012-11-03 16:09 EDT, Stephan Peccini
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 690514 None None None Never

  None (edit)
Description Stephan Peccini 2012-11-03 16:08:53 EDT
Description of problem:
Rhythmbox crashes as soon as I try to listen to a music.

Version-Release number of selected component:
rhythmbox-2.98-4.fc18

Additional info:
libreport version: 2.0.18
abrt_version:   2.0.18
backtrace_rating: 4
cmdline:        rhythmbox
crash_function: rb_signal_accumulator_value_array
kernel:         3.6.5-2.fc18.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #0 rb_signal_accumulator_value_array at rb-util.c:1117
: #1 accumulate at gsignal.c:3055
: #5 create_stream at rb-player-gst-xfade.c:2245
: #6 rb_player_gst_xfade_open at rb-player-gst-xfade.c:3332
: #7 rb_shell_player_open_location at rb-shell-player.c:1679
: #8 rb_shell_player_set_playing_entry at rb-shell-player.c:1796
: #9 rb_shell_player_playpause at rb-shell-player.c:2456
: #10 rb_shell_player_cmd_play at rb-shell-player.c:2342
: #15 _gtk_action_emit_activate at gtkaction.c:801
: #16 gtk_action_activate at gtkaction.c:832
Comment 1 Stephan Peccini 2012-11-03 16:08:56 EDT
Created attachment 637631 [details]
File: core_backtrace
Comment 2 Stephan Peccini 2012-11-03 16:08:58 EDT
Created attachment 637632 [details]
File: environ
Comment 3 Stephan Peccini 2012-11-03 16:09:00 EDT
Created attachment 637633 [details]
File: limits
Comment 4 Stephan Peccini 2012-11-03 16:09:02 EDT
Created attachment 637634 [details]
File: backtrace
Comment 5 Stephan Peccini 2012-11-03 16:09:04 EDT
Created attachment 637635 [details]
File: cgroup
Comment 6 Stephan Peccini 2012-11-03 16:09:06 EDT
Created attachment 637636 [details]
File: executable
Comment 7 Stephan Peccini 2012-11-03 16:09:09 EDT
Created attachment 637637 [details]
File: maps
Comment 8 Stephan Peccini 2012-11-03 16:09:12 EDT
Created attachment 637638 [details]
File: dso_list
Comment 9 Stephan Peccini 2012-11-03 16:09:14 EDT
Created attachment 637639 [details]
File: proc_pid_status
Comment 10 Stephan Peccini 2012-11-03 16:09:16 EDT
Created attachment 637640 [details]
File: var_log_messages
Comment 11 Stephan Peccini 2012-11-03 16:09:18 EDT
Created attachment 637641 [details]
File: open_fds
Comment 12 Fabio Valentini 2012-12-05 15:48:53 EST
Rhythmbox crashes anytime I start playback of _any_ media, regardless of codec, local or radio stream ...

The only useful debug output is:
"TypeError: can't convert return value to desired type
Segmentation fault (core dumped)"


backtrace_rating: 4
Package: rhythmbox-2.98-4.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 Gergely POLONKAI 2012-12-08 08:54:11 EST
Tried to start playback.

backtrace_rating: 4
Package: rhythmbox-2.98-4.fc18
Architecture: i686
OS Release: Fedora release 18 (Spherical Cow)
Comment 14 Lance Lassetter 2012-12-11 16:23:08 EST
ladspa (pulseaudio-equalizer) cannot be removed i think this is crashing pulseaudio and sound is distorted

backtrace_rating: 4
Package: rhythmbox-2.98-4.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 15 John Dulaney 2012-12-15 12:30:19 EST
Crashing on playback, no matter what format file I've tried.
Comment 16 Fedor Butikov 2012-12-16 16:25:19 EST
Error oappearing when i try to play any track

backtrace_rating: 4
Package: rhythmbox-2.98-4.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 17 John Dulaney 2012-12-18 08:57:29 EST
Marking as a blocker as per Final criteria "All applications listed under the Applications menu or category must withstand a basic functionality test and not crash after a few minutes of normal use. They must also have working Help and Help -> About menu items"
Comment 18 Jaroslav Reznik 2012-12-19 10:27:43 EST
Rhythmbox (2.98-4) works for me, at least ogg playback.
Comment 19 Cosimo Cecchi 2012-12-19 10:32:15 EST
From the backtrace it also looks like this might be related having the crossfade option enabled, which is disabled by default.
If that's the case, I think it's questionable whether this should actually be a blocker.
Comment 20 Ray Strode [halfline] 2012-12-19 11:43:01 EST
This is seemingly a bug in pygobject3 introspection triggered by the ReplayGain plugin.

It does this:

→       def create_stream_filter_cb(self, player, uri):•
→       →       print "creating rgvolume instance for stream %s" % uri•
→       →       rgvolume = Gst.ElementFactory.make("rgvolume", None)•
→       →       rgvolume.connect("notify::target-gain", self.xfade_target_gain_cb)•
→       →       self.set_rgvolume(rgvolume)•
→       →       return [rgvolume]•

as a handler for this signal:

→       signals[GET_STREAM_FILTERS] =•
→       →       g_signal_new ("get-stream-filters",•
→       →       →             G_OBJECT_CLASS_TYPE (object_class),•
→       →       →             G_SIGNAL_RUN_LAST,•
→       →       →             0,•
→       →       →             rb_signal_accumulator_value_array, NULL,•
→       →       →             rb_marshal_BOXED__STRING,•
→       →       →             G_TYPE_ARRAY,•
→       →       →             1,•
→       →       →             G_TYPE_STRING);•

So the assumption is that the "return [rgvolume]" will implicity create a GArray.  pygobject3 has a function pyg_value_from_pyobject which handles GValueArrays but not GArrays:

             else if (PySequence_Check(obj) &&                          
                        G_VALUE_HOLDS(value, G_TYPE_VALUE_ARRAY))       
                 return pyg_value_array_from_pyobject(value, obj, NULL);

This isn't really a blocker bug by the criteria, since we don't enable the ReplayGain plugin by default.
Comment 21 Adam Williamson 2012-12-19 12:47:30 EST
Discussed at 2012-12-19 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-19/f18final-blocker-review-6.2012-12-19-17.02.log.txt . Rejected as a blocker on the grounds that you have to enable a non-default plugin to make it crash, but it'd be good to get a fix for this ASAP, be nice to have it as a 0-day. Some suggestion that we might need to file this upstream, as apparently the maintainer ignores RH bugs?
Comment 22 Ray Strode [halfline] 2012-12-19 13:13:49 EST
filed upstream here:

http://bugzilla.gnome.org/690514
Comment 23 Ray Strode [halfline] 2012-12-19 13:16:25 EST
(moving to pygobject since the bug is there really)
Comment 24 Fedora Update System 2012-12-19 16:20:50 EST
pygobject3-3.4.2-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pygobject3-3.4.2-5.fc18
Comment 25 Fedora Update System 2012-12-20 20:31:46 EST
Package pygobject3-3.4.2-5.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pygobject3-3.4.2-5.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20727/pygobject3-3.4.2-5.fc18
then log in and leave karma (feedback).
Comment 26 Adam Williamson 2012-12-20 21:20:31 EST
Why we didn't consider this for NTH I've no idea. Obviously it'd be good to get it in as NTH so it's fixed on lives.
Comment 27 Fedora Update System 2012-12-21 05:44:59 EST
pygobject3-3.4.2-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pygobject3-3.4.2-6.fc18
Comment 28 Tim Flink 2012-12-21 11:59:13 EST
(In reply to comment #26)
> Why we didn't consider this for NTH I've no idea. Obviously it'd be good to
> get it in as NTH so it's fixed on lives.

IIRC, it was because the plugin in question isn't on the lives and therefore doesn't affect livecds and could be fixed with an update. I could be mis-remembering something here, though.
Comment 29 John Dulaney 2012-12-21 16:51:40 EST
tflink, it is, in fact on the lives and is installed by default.  It is merely not enabled (unless you install to a system while preserving /home, and thus settings where I had previously enabled it).
Comment 30 Adam Williamson 2012-12-21 17:03:48 EST
Discussed at 2012-12-21 blocker review meeting: http://meetbot.fedoraproject.org/fedora-bugzappers/2012-12-21/f18final-blocker-review-7.2012-12-21-18.33.log.txt . Rejected as NTH - it does affect lives as the plugin is present there, but the feeling was that poking pygobject for such a relatively trivial bug was not a good plan.
Comment 31 Ray Strode [halfline] 2013-01-07 10:36:34 EST
Upstream bug is closed FIXED now.
Comment 32 Fedora Update System 2013-01-08 16:31:24 EST
pygobject3-3.4.2-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.