Bug 872898 - other Fatal error: Exception down the road
Summary: other Fatal error: Exception down the road
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-review
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Stanislav Ochotnicky
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-04 02:27 UTC by Sergio Monteiro Basto
Modified: 2013-03-11 19:36 UTC (History)
3 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2013-03-04 22:24:46 UTC


Attachments (Terms of Use)

Description Sergio Monteiro Basto 2012-11-04 02:27:35 UTC
Description of problem:
Review a package which have files .7z in SOURCES  
finish with :

+ 7za x /builddir/build/SOURCES/mamehistory147.7z
/var/tmp/rpm-tmp.YgM54Y: line 35: 7za: command not found
error: Bad exit status from /var/tmp/rpm-tmp.YgM54Y (%prep)
RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.YgM54Y (%prep)
Finish: shell
Finish: lock buildroot

^CException down the road.

Version-Release number of selected component (if applicable):
fedora-review-0.3.0-1.fc17.noarch 

How reproducible:
Review a package which have files .7z in SOURCES 

when tries 
mock --no-cleanup-after --no-clean --shell "rpmbuild --nodeps -bp /builddir/build/SPECS/*spec"

fails with 7za: command not found 


11-04 02:15 root         DEBUG    Mock command: mock, -r, fedora-rawhide-x86_64-rpmfusion_nonfree, --no-cleanup-after, --no-clean, --resultdir=/home/sergio/rpmfusion/mame-data-extras/review-mame-data-extras/results, --shell, rpmbuild --nodeps -bp /builddir/build/SPECS/*spec
11-04 02:15 root         DEBUG    Mock output: INFO: mock.py version 1.1.26 starting...
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: run
Start: lock buildroot
Start: device setup
Finish: device setup
Start: shell
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.YgM54Y
+ umask 022
+ cd /builddir/build/BUILD
+ cd /builddir/build/BUILD
+ rm -rf mame-data-extras-0.147
+ /usr/bin/mkdir -p mame-data-extras-0.147
+ cd mame-data-extras-0.147
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ 7za x /builddir/build/SOURCES/mamehistory147.7z
/var/tmp/rpm-tmp.YgM54Y: line 35: 7za: command not found
error: Bad exit status from /var/tmp/rpm-tmp.YgM54Y (%prep)




Expected results:
not fail

Comment 1 Pierre-YvesChibon 2012-11-04 08:38:47 UTC
To me, this feels more like a bug in the spec file (missing BR) than a bug in fedora-review

Comment 2 Sergio Monteiro Basto 2012-11-04 15:20:09 UTC
(In reply to comment #1)
> To me, this feels more like a bug in the spec file (missing BR) than a bug
> in fedora-review

The error is not in build time , 
here is the example, you may test it :
https://bugzilla.rpmfusion.org/show_bug.cgi?id=2492#c11

Comment 3 Pierre-YvesChibon 2012-11-04 15:46:57 UTC
If your mock configuration adjusted to include the RPMFusion repositories?

Can you build this package without problem in mock?

Comment 4 Sergio Monteiro Basto 2012-11-04 16:30:33 UTC
(In reply to comment #3)
> If your mock configuration adjusted to include the RPMFusion repositories?
> 
> Can you build this package without problem in mock?

yes. Sorry , you will need  add --mock-config fedora-rawhide-x86_64-rpmfusion_nonfree 

package from rpmfusion is mock-rpmfusion-nonfree-18.0-1.fc17.noarch

Comment 5 Pierre-YvesChibon 2012-11-04 16:32:56 UTC
Fedora-review can not depend on package from RPMFusion.

However, you can specify to fedora-review which mock configuration to use (see --help)

Comment 6 Sergio Monteiro Basto 2012-11-04 17:16:43 UTC
I did:
$ yum install mock-rpmfusion-nonfree-18.0-1.fc17.noarch
$ wget http://lesloueizeh.com/belegdol/mame-data-extras.spec
$ wget http://lesloueizeh.com/belegdol/mame-data-extras-0.147-2.fc19.src.rpm
$ fedora-review -n mame-data-extras --mock-config 
   fedora-rawhide-x86_64rpmfusion_nonfree

and hit this bug ...

Comment 7 Sergio Monteiro Basto 2012-11-05 17:19:57 UTC
fedora-review -n mame-data-extras -m fedora-rawhide-x86_64 --no-build -o offline 

Processing local files: mame-data-extras

whats means :
Packages required by --no-build are not installed: mame-data-extras-robby, mame-data-extras

This  fedora-review doesn't obey to --no-build ?
and think that is a package ?

Comment 8 Alec Leamas 2012-11-07 19:15:29 UTC
The no-build option is badly documented. It can be used if (and only if) fedora-review has built the package in a previous run. The message above means that f-r detects that the package from previous run is not installed in mock. This should not be fatal, but generate some errors for not installed packages.

Using --no-build only makes sense when one wants to re-run f-r with e. g., other options or plugins.

I'll try to reproduce your error. Meanwhile, could you describe your usecase a little, so we can figure out how to handle it? (I'm on IRC #fedora-review as well)

Comment 9 Alec Leamas 2012-11-07 19:30:45 UTC
Using the command in comment #6 fails for me, the configuration looks wrong.

Using -m fedora-18-i386-rpmfusion_free instead the build  seems to work a little longer, but fails after a while anyway.

Looking into the logfile ~/.cache/fedora-review.log I find the mock command which f-r runs:
mock -r fedora-18-i386-rpmfusion_free --no-cleanup-after --no-clean --resultdir=/home/leamas/tmp/FedoraReview/mame-data-extras/results --rebuild /home/leamas/tmp/FedoraReview/mame-data-extras-0.147-2.fc19.src.rpm

Running this "by hand"  the build fails, final message:

Getting requirements for mame-data-extras-0.147-2.fc18.src
 --> p7zip-9.20.1-4.fc18.i686
Error: No Package found for unrar

Here's something I don't understand...

Comment 10 Pierre-YvesChibon 2012-11-07 19:57:50 UTC
Ok this is weird, I could replicate the problem this week-end but I cannot anymore (with the same spec/srpm).

Can you still?

Comment 11 Sergio Monteiro Basto 2012-11-09 00:18:13 UTC
(In reply to comment #10)
> Ok this is weird, I could replicate the problem this week-end but I cannot
> anymore (with the same spec/srpm).
> 
> Can you still?

No , not the same today . 
I got 

+ 7za x /builddir/build/SOURCES/mamehistory147.7z
/var/tmp/rpm-tmp.1EhdKb: line 35: 7za: command not found
error: Bad exit status from /var/tmp/rpm-tmp.1EhdKb (%prep)

but review finish with: 
Review template in: /home/sergio/rpmfusion/mame-data-extras/review-mame-data-extras/mame-data-extras-review.txt

Comment 12 Alec Leamas 2012-11-09 03:36:44 UTC
Could you please attach the log file ~/.cache/fedora-review.log?

Comment 13 Alec Leamas 2012-11-09 04:45:10 UTC
OK, found it. This happens while installing the sources:

11-09 05:23 root         DEBUG    Mock command: mock, -r, fedora-18-i386-rpmfusion_nonfree, --no-cleanup-after, --no-clean, --resultdir=/home/mk/FedoraReview/review-mame-data-extras/results, --shell, rpmbuild --nodeps -bp /builddir/build/SPECS/*spec

[cut]

Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.Z86yxb
+ umask 022
+ cd /builddir/build/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /builddir/build/BUILD
+ rm -rf mame-data-extras-0.147
+ /usr/bin/mkdir -p mame-data-extras-0.147
+ cd mame-data-extras-0.147
+ /usr/bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ 7za x /builddir/build/SOURCES/mamehistory147.7z
/var/tmp/rpm-tmp.Z86yxb: line 39: 7za: command not found
error: Bad exit status from /var/tmp/rpm-tmp.Z86yxb (%prep)

Although I havn't digged into why, this does not happen on devel. On 3.1.1 the reason seems to be that the build requirements are not installed in mock when unpacking the sources. This is most often not an issue, but this particular spec uses specific tools (7za) to unpack the sources.

Will investigate why devel works later, possibly filing a trac bug.

Sergio: The unpacked sources is probably not a big issue. However, you might be interested in walking around this by using the devel branch as described in https://fedorahosted.org/FedoraReview/wiki/UseDevelopmentVersion.

Comment 14 Alec Leamas 2012-11-09 07:00:39 UTC
Trac ticket: https://fedorahosted.org/FedoraReview/ticket/173

Comment 15 Fedora Update System 2013-01-29 17:21:03 UTC
fedora-review-0.4.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-1.fc17

Comment 16 Fedora Update System 2013-01-29 17:21:42 UTC
fedora-review-0.4.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-1.fc18

Comment 17 Fedora Update System 2013-01-29 17:22:53 UTC
fedora-review-0.4.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-1.el6

Comment 18 Fedora Update System 2013-01-29 20:02:12 UTC
Package fedora-review-0.4.0-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing fedora-review-0.4.0-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-0216/fedora-review-0.4.0-1.el6
then log in and leave karma (feedback).

Comment 19 Fedora Update System 2013-02-04 21:03:05 UTC
fedora-review-0.4.0-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-2.el6

Comment 20 Fedora Update System 2013-02-04 21:03:43 UTC
fedora-review-0.4.0-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-2.fc17

Comment 21 Fedora Update System 2013-02-04 21:04:12 UTC
fedora-review-0.4.0-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-2.fc18

Comment 22 Fedora Update System 2013-02-08 15:40:38 UTC
fedora-review-0.4.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-3.fc18

Comment 23 Fedora Update System 2013-02-08 16:05:30 UTC
fedora-review-0.4.0-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-3.fc17

Comment 24 Fedora Update System 2013-02-21 13:23:57 UTC
fedora-review-0.4.0-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-4.fc18

Comment 25 Fedora Update System 2013-02-21 13:24:49 UTC
fedora-review-0.4.0-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-4.fc17

Comment 26 Fedora Update System 2013-02-21 13:26:22 UTC
fedora-review-0.4.0-4.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/fedora-review-0.4.0-4.el6

Comment 27 Fedora Update System 2013-03-04 22:24:48 UTC
fedora-review-0.4.0-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 28 Fedora Update System 2013-03-04 22:26:46 UTC
fedora-review-0.4.0-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 29 Fedora Update System 2013-03-11 19:36:05 UTC
fedora-review-0.4.0-4.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.