This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 872899 - [abrt] fedup-0.7-1.fc17: fedup-cli:179:parse_args:TypeError: argument of type 'NoneType' is not iterable
[abrt] fedup-0.7-1.fc17: fedup-cli:179:parse_args:TypeError: argument of type...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
abrt_hash:ebd15166a228a2f49aa38d3041a...
:
: 873083 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-03 22:48 EDT by Sergio Monteiro Basto
Modified: 2012-12-17 18:45 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-17 18:45:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: environ (4.32 KB, text/plain)
2012-11-03 22:49 EDT, Sergio Monteiro Basto
no flags Details
File: smolt_data (3.32 KB, text/plain)
2012-11-03 22:49 EDT, Sergio Monteiro Basto
no flags Details
File: core_backtrace (154 bytes, text/plain)
2012-11-03 22:49 EDT, Sergio Monteiro Basto
no flags Details

  None (edit)
Description Sergio Monteiro Basto 2012-11-03 22:48:57 EDT
Description of problem:
just run the example:
fedup-cli --network 18 


Version-Release number of selected component:
fedup-0.7-1.fc17

Additional info:
libreport version: 2.0.16
abrt_version:   2.0.16
cmdline:        /usr/bin/python /usr/bin/fedup-cli --network 18
kernel:         3.6.5-1.fc17.x86_64

backtrace:
:fedup-cli:179:parse_args:TypeError: argument of type 'NoneType' is not iterable
:
:Traceback (most recent call last):
:  File "/usr/bin/fedup-cli", line 253, in <module>
:    args = parse_args()
:  File "/usr/bin/fedup-cli", line 179, in parse_args
:    if '://' in args.instrepo:
:TypeError: argument of type 'NoneType' is not iterable
:
:Local variables in innermost frame:
:p: ArgumentParser(prog='fedup-cli', usage='%(prog)s SOURCE [options]', description='Prepare system for upgrade.', version=None, formatter_class=<class 'argparse.HelpFormatter'>, conflict_handler='error', add_help=True)
:net: <argparse._ArgumentGroup object at 0x18d2d50>
:args: Namespace(bootloader=True, cacheonly=False, clean_metadata=False, debuglog=None, device=None, expire_cache=False, instrepo=None, iso=None, loglevel=30, network='18', reboot=False, repos=[], skipkernel=False, skippkgs=False)
:req: <argparse._ArgumentGroup object at 0x18d2c10>
Comment 1 Sergio Monteiro Basto 2012-11-03 22:49:00 EDT
Created attachment 637865 [details]
File: environ
Comment 2 Sergio Monteiro Basto 2012-11-03 22:49:02 EDT
Created attachment 637866 [details]
File: smolt_data
Comment 3 Sergio Monteiro Basto 2012-11-03 22:49:04 EDT
Created attachment 637867 [details]
File: core_backtrace
Comment 4 Tim Flink 2012-11-05 10:23:20 EST
Yeah, the error message isn't incredibly friendly but it's saying that the command isn't properly formed.

At the moment, --instrepo is required for fedup to run and it needs to point to a repo with a kernel and upgrade.img in the .treeinfo.

I have a side repo like that set up for testing:
http://tflink.fedorapeople.org/fedup/f18-upgrade/<arch>

Make sure that you replace <arch> with the arch you're using (i386, x86_64)
Comment 5 Tim Flink 2012-11-05 10:23:53 EST
*** Bug 873083 has been marked as a duplicate of this bug. ***
Comment 6 Will Woods 2012-11-05 17:57:02 EST
Should be fixed (or, at least, the error message should be clearer) by commit 79e9f88:
  
  https://github.com/wgwoods/fedup/commit/79e9f88
Comment 7 Jens Petersen 2012-11-06 01:35:57 EST
Presumably once the upgrade bits are included in f18 trees
there will be no need to specify a repo./?
Comment 8 Tim Flink 2012-11-07 11:35:37 EST
(In reply to comment #7)
> Presumably once the upgrade bits are included in f18 trees
> there will be no need to specify a repo./?

That is my understanding of the plan, yes. The current requirement for --instrepo is temporary until fedup is completely integrated in to the F18 build process.
Comment 9 Will Woods 2012-12-17 18:45:10 EST
Seems like this is fixed in 0.7.1, so...

Note You need to log in before you can comment on or make changes to this bug.