Bug 872950 - engine [Live Storage Migration]: cannot concurrently live migrate several disks of the same VM
Summary: engine [Live Storage Migration]: cannot concurrently live migrate several dis...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.1.0
Hardware: x86_64
OS: Linux
high
high
Target Milestone: ---
: 3.1.5
Assignee: Daniel Erez
QA Contact: Dafna Ron
URL:
Whiteboard: storage
Depends On:
Blocks: 874080 889080
TreeView+ depends on / blocked
 
Reported: 2012-11-04 15:24 UTC by Dafna Ron
Modified: 2016-02-10 17:02 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: Release Note
Doc Text:
Live storage migration does not support concurrent migration of disks from a single virtual machine. Instead live migration of each disk attached to the virtual machine must be manually initiated in serial.
Clone Of:
: 874080 (view as bug list)
Environment:
Last Closed: 2012-11-08 06:43:05 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)
log (124.68 KB, application/x-xz)
2012-11-04 15:24 UTC, Dafna Ron
no flags Details

Description Dafna Ron 2012-11-04 15:24:08 UTC
Created attachment 638040 [details]
log

Description of problem:

I tried moving a second disk while the first disk was still moving (snapshot has already been created) and failed to move with CanDoAction: 

2012-11-04 17:04:25,421 WARN  [org.ovirt.engine.core.bll.MoveDiskCommand] (ajp-/127.0.0.1:8702-9) CanDoAction of action LiveMigrateDisk failed. Reasons:VAR__ACTION__MOVE,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_DISKS_ARE_LOCKED,$diskAliase
s DAFFI_Disk1


Version-Release number of selected component (if applicable):

si23

How reproducible:

100%

Steps to Reproduce:
1. run a vm with multiple disks
2. move one disk
3. once the first snapshot was created try to move the second disk
  
Actual results:

we fail with CanDoAction:

2012-11-04 17:04:25,421 WARN  [org.ovirt.engine.core.bll.MoveDiskCommand] (ajp-/127.0.0.1:8702-9) CanDoAction of action LiveMigrateDisk failed. Reasons:VAR__ACTION__MOVE,VAR__TYPE__VM_DISK,ACTION_TYPE_FAILED_DISKS_ARE_LOCKED,$diskAliase
s DAFFI_Disk1

Expected results:

since we are working with multiple domains I would expect that a locked disk should not block me form moving a second as long as the first snapshot was already created. 

Additional info: engine log


Note You need to log in before you can comment on or make changes to this bug.