Bug 873036 - [RHEVM Web Admin Portal localization] Zanata source strings (rhevm-3.1 version) containing "oVirt" and "Engine"
[RHEVM Web Admin Portal localization] Zanata source strings (rhevm-3.1 versio...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: 3.2.0
Assigned To: Einav Cohen
Yuko Katabami
ux
: i18n, Translation, ZStream
: 873035 (view as bug list)
Depends On:
Blocks: 867431 884824 885737 888785
  Show dependency treegraph
 
Reported: 2012-11-04 18:43 EST by Yuko Katabami
Modified: 2015-09-22 09 EDT (History)
9 users (show)

See Also:
Fixed In Version: sf13
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 888785 (view as bug list)
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sgrinber: Triaged+


Attachments (Terms of Use)

  None (edit)
Description Yuko Katabami 2012-11-04 18:43:42 EST
Description of problem:
rhevm-3.1 version of zanata strings still contain a number of oVirt branding.

Version-Release number of selected component (if applicable): n/a


How reproducible:


Steps to Reproduce:
1. In Zanata, run project-wide search & replace with keyword "oVirt" and search  source strings.
2. List of strings containing "oVirt" are listed.
3. Please also run search with keyword "Engine".
  
Actual results:
There are a number of source strings containing "oVirt", "oVirt Engine" and "Engine".

Expected results:
These need to be updated with appropriate branding (i.e. "Red Hat Enterprise Virtualization Manager" and "Manager")

Additional info:
I will list those strings in the comment field below.
Comment 1 Yuko Katabami 2012-11-04 18:55:46 EST
Internal oVirt Engine Error
oVirt Engine has stopped
oVirt History Service Started
oVirt History Service Stopped
oVirt History Service Error
About oVirt Engine
Could not connect to oVirt Engine Service, please try to refresh the page. If the problem persists contact your System Administrator.
oVirt Engine for Servers and Desktops:
oVirt Engine Hypervisor Hosts:
Internal oVirt Engine Error
Fencing is disabled due to oVirt Engine service start up sequence.
Permission denied. oVirt Engine Administrator permission is required.
Authentication Failed. Error in DNS configuration. Please verify the oVirt Engine Host has a valid reverse DNS (PTR) record.
Authentication Failed. oVirt Engine clock is not synchronized with directory services (must be within 5 minutes difference). Please verify the clocks are synchronized and restart the service.
There is no valid license for oVirt Engine
Login failed, if the oVirt Engine Service was restarted please wait few seconds and try again, if the problem persists please check your oVirt Engine license.
oVirt Engine has detected that the system clock has been modified
oVirt Engine's evaluation period has expired
oVirt Engine is in evaluation mode. Evaluation period will end in ${DaysLeft} days
Fencing is disabled due to oVirt Engine service start up sequence.
Permission denied. oVirt Engine Administrator permission is required.
Authentication Failed. Error in DNS configuration. Please verify the oVirt Engine Host has a valid reverse DNS (PTR) record.
Authentication Failed. oVirt Engine clock is not synchronized with directory services (must be within 5 minutes difference). Please verify the clocks are synchronized and restart the service.
There is no valid license for oVirt Engine
Login failed, if the oVirt Engine Service was restarted please wait few seconds and try again, if the problem persists please check your oVirt Engine license.
oVirt Engine has detected that the system clock has been modified
oVirt Engine's evaluation period has expired
oVirt Engine is in evaluation mode. Evaluation period will end in ${DaysLeft} days

Verify connectivity between Host and Engine
Check this checkbox to ensure you won't lose connectivity to the engine.
If after changing the networks configuration the connectivity from the Host to the Engine is lost, changes are rolled back .
Network engine is mandatory, it cannot be modified.
The management Network (engine) is mandatory and cannot be removed.
The default gateway should be set only on engine network
Engine is running in Maintenance mode and is not accepting commands.
This action is not allowed when Engine is preparing for maintenance.
Network engine is mandatory, it cannot be modified.
The management Network (engine) is mandatory and cannot be removed.
The default gateway should be set only on engine network
Engine is running in Maintenance mode and is not accepting commands.
This action is not allowed when Engine is preparing for maintenance.
Comment 2 Yuko Katabami 2012-11-04 18:58:48 EST
Please note that strings containing "engine.log" are excluded from the above list as we have already confirmed with Red Hat Japan that it can remain as is in the localized strings.

Please do not push the update until the merge/copytrans issue is solved.
Comment 4 Einav Cohen 2012-11-06 17:05:06 EST
1. 
--
> Network engine is mandatory, it cannot be modified.
> The management Network (engine) is mandatory and cannot be removed.
> The default gateway should be set only on engine network

For these messages (in which "engine" represents the Management Network):
- in oVirt: "engine" is going to be replaced with "ovirtmgmt"
- in rhev-m: "engine" is going to be replaced with "rhevm"

-------------

2. 
--
> Verify connectivity between Host and Engine
> Check this checkbox to ensure you won't lose connectivity to the engine.
> If after changing the networks configuration the connectivity from the Host to the Engine is lost, changes are rolled back .
> Engine is running in Maintenance mode and is not accepting commands.
> This action is not allowed when Engine is preparing for maintenance.

Messages above are going to stay as-is in both oVirt and RHEV-M, as Engine is a valid term for both oVirt and RHEV-M when referring to the service.

-------------

3. 
--
> About oVirt Engine
> oVirt Engine for Servers and Desktops:
> oVirt Engine Hypervisor Hosts:
> There is no valid license for oVirt Engine
> oVirt Engine's evaluation period has expired
> oVirt Engine is in evaluation mode. Evaluation period will end in ${DaysLeft} days

Messages above will remain as-is in oVirt, and are going to be replaced with the following messages in RHEV-M:

- About Red Hat Enterprise Virtualization Manager
- Red Hat Enterprise Virtualization Manager for Servers and Desktops:
- Red Hat Enterprise Virtualization Hypervisor Hosts:
- There is no valid license for Red Hat Enterprise Virtualization Manager
- Red Hat Enterprise Virtualization Manager's evaluation period has expired
- Red Hat Enterprise Virtualization Manager is in evaluation mode. Evaluation period will end in ${DaysLeft} days

-------------

4. 
--
> Internal oVirt Engine Error
> oVirt Engine has stopped
> oVirt History Service Started
> oVirt History Service Stopped
> oVirt History Service Error
> Could not connect to oVirt Engine Service, please try to refresh the page. If the problem persists contact your System Administrator.
> Fencing is disabled due to oVirt Engine service start up sequence.
> Permission denied. oVirt Engine Administrator permission is required.
> Authentication Failed. Error in DNS configuration. Please verify the oVirt Engine Host has a valid reverse DNS (PTR) record.
> Authentication Failed. oVirt Engine clock is not synchronized with directory services (must be within 5 minutes difference). Please verify the clocks are synchronized and restart the service.
> Login failed, if the oVirt Engine Service was restarted please wait few seconds and try again, if the problem persists please check your oVirt Engine license.
> oVirt Engine has detected that the system clock has been modified

These messages are going to have "oVirt" removed from them, both in oVirt and rhev-m.
Comment 5 Einav Cohen 2012-11-06 22:08:43 EST
patch sent upstream:
http://gerrit.ovirt.org/#/c/9095/
Comment 9 Einav Cohen 2012-11-26 18:31:21 EST
*** Bug 873035 has been marked as a duplicate of this bug. ***
Comment 18 Lijun Li 2013-05-02 02:27:27 EDT
Also checked the rhevm-3.1 version of the oVirt in Zanata: 'Search "oVirt" returned no results' and based on Comment 16 / Comment 17 , moving to VERIFIED.
Comment 19 Itamar Heim 2013-06-11 05:34:04 EDT
3.2 has been released
Comment 20 Itamar Heim 2013-06-11 05:34:06 EDT
3.2 has been released
Comment 21 Itamar Heim 2013-06-11 05:49:53 EDT
3.2 has been released

Note You need to log in before you can comment on or make changes to this bug.