Bug 873038 - Entering an env name of "Library" when creating an organization does not give clear error message
Entering an env name of "Library" when creating an organization does not give...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Adam Price
Tazim Kolhar
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-04 18:44 EST by sachua
Modified: 2016-04-25 20:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Error message updated when user attempts to use "Library" as a new environment name.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 14:18:48 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of error message (67.16 KB, image/png)
2012-11-04 18:44 EST, sachua
no flags Details
Library Org default (73.66 KB, image/png)
2012-12-04 06:36 EST, Tazim Kolhar
no flags Details

  None (edit)
Description sachua 2012-11-04 18:44:09 EST
Created attachment 638294 [details]
Screenshot of error message

Description of problem:
When creating a new organization with a new name and using the default label, an error message is received (see attached screenshot).

Version-Release number of selected component (if applicable):

1.2

How reproducible:

Tried different organization names and getting the same error message.

Steps to Reproduce:
1. Create a new organization.
2. Type in a name and use the default label.
3. Save and the error message will appear.
  
Actual results:

Unable to create a new organization.

Expected results:

To be able to create a new organization without error message.

Additional info:
Comment 1 Tom McKay 2012-11-05 09:01:16 EST
The problem is not with the organization name, but rather with the environment name. "Library" is a built-in environment for all orgs and so cannot be used here. In this form you should enter a _first_ environment, the one that will come after Library.

I am changing the subject to reflect this accurately.
Comment 2 Tom McKay 2012-11-20 10:33:10 EST
  Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 6a07d19b538882651936b3bbd330481961b91e1a
      https://github.com/Katello/katello/commit/6a07d19b538882651936b3bbd330481961b91e1a
  Author: Adam Price <komidore64@gmail.com>
  Date:   2012-11-19 (Mon, 19 Nov 2012)
Comment 4 Tazim Kolhar 2012-12-04 06:36:11 EST
Created attachment 657445 [details]
Library Org default

VERIFIED :

# rpm -qa | grep katello
katello-cli-1.2.4-3h.el6_3.noarch
katello-headpin-1.2.6-3h.el6_3.noarch
katello-cli-common-1.2.4-3h.el6_3.noarch
katello-glue-candlepin-1.2.6-3h.el6_3.noarch
katello-selinux-1.2.1-1h.el6_3.noarch
katello-headpin-all-1.2.6-3h.el6_3.noarch
katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-common-1.2.6-3h.el6_3.noarch
katello-configure-1.2.3-1h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
Comment 6 errata-xmlrpc 2013-02-21 14:18:48 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHSA-2013-0544.html

Note You need to log in before you can comment on or make changes to this bug.