Bug 8731 - up2date broken on 6.2beta2/x86
Summary: up2date broken on 6.2beta2/x86
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date
Version: 6.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-01-21 23:05 UTC by Bill Bradford
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-02-28 16:32:19 UTC


Attachments (Terms of Use)

Description Bill Bradford 2000-01-21 23:05:24 UTC
[mrbill@area51 mrbill]$ up2date

(here it asked me for root's pw in a pop-up window)

Traceback (innermost last):
  File "/usr/sbin/up2date", line 118, in ?
    from gui import Gui
  File "/usr/share/up2date/gui.py", line 10, in ?
    from client import Client
  File "/usr/share/up2date/client.py", line 12, in ?
    from rpmdb import *
  File "/usr/share/up2date/rpmdb.py", line 19, in ?
    from package import *
  File "/usr/share/up2date/package.py", line 24, in ?
    import rpm
ImportError: No module named rpm

And, if I try to run it as root, same thing:

[root@area51 /root]# export DISPLAY=localhost:0
[root@area51 /root]# up2date
Traceback (innermost last):
  File "/usr/sbin/up2date", line 118, in ?
    from gui import Gui
  File "/usr/share/up2date/gui.py", line 10, in ?
    from client import Client
  File "/usr/share/up2date/client.py", line 12, in ?
    from rpmdb import *
  File "/usr/share/up2date/rpmdb.py", line 19, in ?
    from package import *
  File "/usr/share/up2date/package.py", line 24, in ?
    import rpm
ImportError: No module named rpm

Comment 1 Preston Brown 2000-02-28 16:32:59 UTC
you need to install the rpm-python module.


Note You need to log in before you can comment on or make changes to this bug.