Bug 873101 - Exception starting after upgrade to 1.8
Exception starting after upgrade to 1.8
Status: CLOSED CURRENTRELEASE
Product: Spacewalk
Classification: Community
Component: Server (Show other bugs)
1.8
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Tomas Lestach
Red Hat Satellite QA List
:
Depends On:
Blocks: space19
  Show dependency treegraph
 
Reported: 2012-11-05 01:23 EST by Alex Mondshain
Modified: 2013-03-06 13:35 EST (History)
2 users (show)

See Also:
Fixed In Version: spacewalk-java-1.8.180
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-06 13:35:25 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alex Mondshain 2012-11-05 01:23:50 EST
Description of problem:
After upgrade from 1.7 to 1.8 i am getting the following exception in both tomcat and taskomatic logs  


Version-Release number of selected component (if applicable):
1.8

2012-11-05 01:05:18,056 [TP-Processor1] ERROR com.redhat.rhn.common.hibernate.ConnectionManager - FATAL ERROR creating HibernateFactory
org.hibernate.InvalidMappingException: Could not parse mapping document from resource com/redhat/rhn/taskomatic/TaskoBunch.hbm.xml
        at org.hibernate.cfg.Configuration.addResource(Configuration.java:569)
        at com.redhat.rhn.common.hibernate.ConnectionManager.createSessionFactory(ConnectionManager.java:208)
        at com.redhat.rhn.common.hibernate.ConnectionManager.initialize(ConnectionManager.java:132)
        at com.redhat.rhn.common.hibernate.ConnectionManager.getSession(ConnectionManager.java:285)
        at com.redhat.rhn.common.hibernate.HibernateFactory.getSession(HibernateFactory.java:318)
        at com.redhat.rhn.common.hibernate.HibernateFactory.saveObject(HibernateFactory.java:277)
        at com.redhat.rhn.common.hibernate.HibernateFactory.saveObject(HibernateFactory.java:291)
        at com.redhat.rhn.domain.session.WebSessionFactory.save(WebSessionFactory.java:71)
        at com.redhat.rhn.manager.session.SessionManager.makeSession(SessionManager.java:87)
        at com.redhat.rhn.frontend.servlets.PxtSessionDelegateImpl.createPxtSession(PxtSessionDelegateImpl.java:167)
        at com.redhat.rhn.frontend.servlets.PxtSessionDelegateImpl.loadPxtSession(PxtSessionDelegateImpl.java:113)
        at com.redhat.rhn.frontend.servlets.PxtSessionDelegateImpl.getPxtSession(PxtSessionDelegateImpl.java:46)
        at com.redhat.rhn.frontend.struts.RequestContext.getWebSession(RequestContext.java:532)
        at com.redhat.rhn.frontend.struts.RequestContext.getLoggedInUser(RequestContext.java:172)
        at com.redhat.rhn.manager.acl.AclManager.hasAcl(AclManager.java:49)
        at com.redhat.rhn.frontend.taglibs.RequireTag.doStartTag(RequireTag.java:101)
        at org.apache.jsp.WEB_002dINF.decorators.layout_005fhead_jsp._jspx_meth_rhn_005frequire_005f0(Unknown Source)
        at org.apache.jsp.WEB_002dINF.decorators.layout_005fhead_jsp._jspService(Unknown Source)
        at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:646)
        at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:551)
        at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:488)
        at org.apache.jasper.runtime.JspRuntimeLibrary.include(JspRuntimeLibrary.java:968)
        at org.apache.jsp.WEB_002dINF.decorators.layout_005fc_jsp._jspService(Unknown Source)
        at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:646)
        at org.apache.catalina.core.ApplicationDispatcher.doInclude(ApplicationDispatcher.java:551)
        at org.apache.catalina.core.ApplicationDispatcher.include(ApplicationDispatcher.java:488)
        at org.apache.jasper.runtime.JspRuntimeLibrary.include(JspRuntimeLibrary.java:968)
        at org.apache.jasper.runtime.PageContextImpl.include(PageContextImpl.java:622)
        at com.opensymphony.module.sitemesh.taglib.page.ApplyDecoratorTag.doEndTag(ApplyDecoratorTag.java:258)
        at org.apache.jsp.WEB_002dINF.pages.common.errors._500_jsp._jspx_meth_page_005fapplyDecorator_005f0(Unknown Source)
        at org.apache.jsp.WEB_002dINF.pages.common.errors._500_jsp._jspService(Unknown Source)
        at org.apache.jasper.runtime.HttpJspBase.service(HttpJspBase.java:70)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:717)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:290)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206)
        at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:646)
        at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:438)
        at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:374)
        at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:302)
        at org.apache.catalina.core.StandardHostValve.custom(StandardHostValve.java:415)
        at org.apache.catalina.core.StandardHostValve.status(StandardHostValve.java:342)
        at org.apache.catalina.core.StandardHostValve.throwable(StandardHostValve.java:286)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:141)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:298)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:291)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:769)
        at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:698)
        at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:891)
        at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690)
        at java.lang.Thread.run(Thread.java:679)
Caused by: org.hibernate.InvalidMappingException: Could not parse mapping document from input stream
        at org.hibernate.cfg.Configuration.addInputStream(Configuration.java:508)
        at org.hibernate.cfg.Configuration.addResource(Configuration.java:566)
        ... 60 more
Caused by: org.dom4j.DocumentException: Connection refused Nested exception: Connection refused
        at org.dom4j.io.SAXReader.read(SAXReader.java:484)
        at org.hibernate.cfg.Configuration.addInputStream(Configuration.java:499)
        ... 61 more
Comment 1 Jan Pazdziora 2012-11-07 17:07:54 EST
We've released updated packages to the Spacewalk 1.8 yum repos -- could you please yum upgrade and restart Spacewalk to see if they fix the problem for you?
Comment 2 Jan Pazdziora 2012-11-10 11:25:55 EST
Moving ON_QA.
Comment 3 Stephen Herr 2013-03-06 13:35:25 EST
Spacewalk 1.9 has been released.

https://fedorahosted.org/spacewalk/wiki/ReleaseNotes19

Note You need to log in before you can comment on or make changes to this bug.