Bug 873106 - transaction space error not handled correctly
Summary: transaction space error not handled correctly
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Chris Lumens
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 875422 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-05 06:36 UTC by Tao Wu
Modified: 2014-10-28 23:45 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-11-23 07:48:53 UTC
Type: Bug


Attachments (Terms of Use)
screenshot (29.91 KB, image/png)
2012-11-05 06:36 UTC, Tao Wu
no flags Details
anaconda log (6.87 KB, text/x-log)
2012-11-05 06:37 UTC, Tao Wu
no flags Details
program log (42.28 KB, text/x-log)
2012-11-05 06:37 UTC, Tao Wu
no flags Details
packageing log (37.72 KB, text/x-log)
2012-11-06 02:10 UTC, Tao Wu
no flags Details
syslog (60.34 KB, application/octet-stream)
2012-11-06 02:10 UTC, Tao Wu
no flags Details
[18.28 log anaconda-tb-Yhv0R3] PayloadInstallError: Could not run transaction. (349.50 KB, text/plain)
2012-11-12 04:46 UTC, Steve Tyler
no flags Details
[18.29] screenshot showing "You need more space on the following file systems: 756.20 MB on /" (37.64 KB, image/png)
2012-11-16 17:24 UTC, Steve Tyler
no flags Details

Description Tao Wu 2012-11-05 06:36:48 UTC
Created attachment 638343 [details]
screenshot

Description of problem:
anaconda 18.24 (Fedora 18 TC7) of 32bit can't install successfully with default packages.

Version-Release number of selected component (if applicable):
18.24

How reproducible:


Steps to Reproduce:
1.Boot the installer using any available means 
2.Do not make any modifications in Software Selection 
3.
  
Actual results:


Expected results:
Anaconda completes successfully 

Additional info:
Anaconda crashed during the "Preparing the transaction".

Comment 1 Tao Wu 2012-11-05 06:37:29 UTC
Created attachment 638344 [details]
anaconda log

Comment 2 Tao Wu 2012-11-05 06:37:56 UTC
Created attachment 638345 [details]
program log

Comment 3 Chris Lumens 2012-11-05 15:27:49 UTC
Please attach /tmp/packaging.log and /tmp/syslog to this bug report.  Thanks.

Comment 4 Tao Wu 2012-11-06 02:10:25 UTC
Created attachment 639045 [details]
packageing log

Comment 5 Tao Wu 2012-11-06 02:10:59 UTC
Created attachment 639046 [details]
syslog

Comment 6 Tao Wu 2012-11-06 02:11:50 UTC
Hi Chris, the /tmp/packaging.log and /tmp/syslog have been uploaded, thanks!

Comment 7 Chris Lumens 2012-11-12 04:21:53 UTC
*** Bug 875422 has been marked as a duplicate of this bug. ***

Comment 8 Steve Tyler 2012-11-12 04:46:28 UTC
Created attachment 643204 [details]
[18.28 log anaconda-tb-Yhv0R3] PayloadInstallError: Could not run transaction.

Here's a reproducer with anaconda 18.28:

1. Create a 5120M disc image:
qemu-img create f18-test-4.img 5120M

2. Start installer from DVD:
$ qemu-kvm -m 1024 -hda f18-test-4.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC8/Fedora-18-Beta-TC8-x86_64-DVD.iso -usb -vga qxl -boot menu=on -usbdevice mouse

3. Auto-create partitions and filesystems.

4. Begin Installation.

Install fails with "Could not run transaction." message.

Comment 9 Steve Tyler 2012-11-12 05:27:49 UTC
Traceback from the attached anaconda-tb-Yhv0R3:

anaconda 18.28 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/packaging/yumpayload.py", line 1323, in install
    raise exn
  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 124, in doInstall
    payload.install()
  File "/usr/lib64/python2.7/threading.py", line 504, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
    threading.Thread.run(self, *args, **kwargs)
PayloadInstallError: Could not run transaction.

Comment 10 Chris Lumens 2012-11-12 21:51:06 UTC
Aside from actually displaying the error messages, we should clean this up to where closing the error dialog does not throw an exception.

Comment 11 Fedora Update System 2012-11-13 01:23:39 UTC
anaconda-18.29-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.29-1.fc18

Comment 12 Tao Wu 2012-11-13 09:40:21 UTC
It has been verified to work fine on F18 TC8.

Comment 13 Fedora Update System 2012-11-13 19:06:42 UTC
Package anaconda-18.29-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.29-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18105/anaconda-18.29-1.fc18
then log in and leave karma (feedback).

Comment 14 Steve Tyler 2012-11-16 17:24:31 UTC
Created attachment 646498 [details]
[18.29] screenshot showing "You need more space on the following file systems: 756.20 MB on /"

Verifying that when there is not enough file system space, anaconda 18.29 on the F18-Beta-TC9 DVD reports the amount of additional space needed to complete the install, and that after clicking Exit Installer, the installer exits and restarts instead of attempting to report a bug. Thanks.

It might be useful to report the current and required file system sizes too, so the user doesn't have to do the addition ...

NB: The error records in packaging.log report the cumulative space needed for each package and all previous packages, but the wording suggests that they are reporting the space needed for each package alone:

[snippets from packaging.log]
...
11:07:45,399 INFO packaging: running transaction
11:07:49,306 ERR packaging: error [2] running transaction: Could not run transaction.
11:07:49,308 ERR packaging: installing package evolution-help-3.6.1-1.fc18.noarch needs 17MB on the / filesystem
11:07:49,309 ERR packaging: installing package orca-3.6.1-1.fc18.x86_64 needs 37MB on the / filesystem
...
11:07:49,415 ERR packaging: installing package pcmciautils-018-3.fc18.x86_64 needs 721MB on the / filesystem
11:07:49,415 ERR packaging: installing package xorg-x11-drv-nouveau-1:1.0.3-1.fc18.x86_64 needs 722MB on the / filesystem

==
Tested with:
$ qemu-img create f18-test-4.img 5G
$ qemu-kvm -m 1024 -hda f18-test-4.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC9/Fedora-18-Beta-TC9-x86_64-DVD.iso -usb -vga qxl -boot menu=on -usbdevice mouse

Comment 15 Fedora Update System 2012-11-23 07:48:55 UTC
anaconda-18.29-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.