Bug 873107 - Suspend doesn't work after kernel upgrade 3.6.x
Summary: Suspend doesn't work after kernel upgrade 3.6.x
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 16
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 880609 905613 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-05 06:53 UTC by Rafael Torres
Modified: 2013-01-29 18:55 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-05 06:49:28 UTC
Type: Bug


Attachments (Terms of Use)
Dmesg output (84.16 KB, text/plain)
2012-12-16 22:30 UTC, Rafael Torres
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Launchpad 1069707 0 None None None Never
Linux Kernel 50111 0 None None None Never

Description Rafael Torres 2012-11-05 06:53:15 UTC
I'm using a Sony VAIO VPCS12V9E notebook with fedora 16 installed. I just upgraded from to Kernel 3.4.9-2 to 3.6.2-1, and suspend is not working anymore . When I select suspend from the gnome menu ( or using pm-suspend), suspend doesn't work:
- the screen goes black, but does not turn off
- num Lock works,
- caps Lock works
- notebook is on, and doesn't enter suspend mode.
In this state, i can only press power button (hard power off);

I belive that suspend is not working because the acpi module was not loaded. Checking the boot log I could found the following log:

[ 28.649495] BUG: unable to handle kernel paging request at 0000000000ff1000
[ 28.649503] IP: [<ffffffff812e1c0d>] memcpy+0xd/0x110
[ 28.649515] PGD 12fd62067 PUD 12da5c067 PMD 0
[ 28.649522] Oops: 0000 [#1] SMP
[ 28.649526] Modules linked in: sony_laptop(+) atl1c iTCO_wdt iTCO_vendor_support intel_ips soundcore snd_page_alloc i2c_i801 microcode rfkill joydev i2c_core lpc_ich mfd_core uinput sunrpc binfmt_misc mmc_block mxm_wmi crc32c_intel ghash_clmulni_intel sdhci_pci sdhci mmc_core firewire_ohci firewire_core crc_itu_t video wmi
[ 28.649555] CPU 2
[ 28.649559] Pid: 706, comm: modprobe Not tainted 3.6.2-1.fc16.x86_64 #1 Sony Corporation VPCS12V9E/VAIO
[ 28.649560] RIP: 0010:[<ffffffff812e1c0d>] [<ffffffff812e1c0d>] memcpy+0xd/0x110
[ 28.649563] RSP: 0018:ffff88012ea65c30 EFLAGS: 00010246
[ 28.649564] RAX: ffff88012ea65c60 RBX: ffff88012ca377c0 RCX: 0000000000000001
[ 28.649565] RDX: 0000000000000000 RSI: 0000000000ff1000 RDI: ffff88012ea65c60
[ 28.649566] RBP: ffff88012ea65c48 R08: 0000000000000001 R09: 0000000000000000
[ 28.649567] R10: 0000000000000000 R11: 0000000000000000 R12: ffff88012ea65c60
[ 28.649568] R13: ffff88012ffb8010 R14: ffff88013199a800 R15: 0000000000000100
[ 28.649569] FS: 00007f9da2756700(0000) GS:ffff880137c80000(0000) knlGS:0000000000000000
[ 28.649571] CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
[ 28.649572] CR2: 0000000000ff1000 CR3: 000000012d454000 CR4: 00000000000007e0
[ 28.649573] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
[ 28.649574] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
[ 28.649575] Process modprobe (pid: 706, threadinfo ffff88012ea64000, task ffff88013023c560)
[ 28.649576] Stack:
[ 28.649577] ffffffffa0138553 ffff88013199a800 0000000000000135 ffff88012ea65ca8
[ 28.649579] ffffffffa013861f 0000000000000009 0000000000000000 0000000000000000
[ 28.649581] 0000000000000000 0000000000000000 000000008a133f54 ffff88012ea65c98
[ 28.649583] Call Trace:
[ 28.649590] [<ffffffffa0138553>] ? sony_nc_buffer_call.constprop.11+0x43/0xa0 [sony_laptop]
[ 28.649593] [<ffffffffa013861f>] sony_nc_rfkill_setup+0x6f/0x1b0 [sony_laptop]
[ 28.649597] [<ffffffffa013a9ab>] sony_nc_function_setup+0x2ab/0x920 [sony_laptop]
[ 28.649600] [<ffffffffa013b21b>] sony_nc_add+0x1fb/0x650 [sony_laptop]
[ 28.649605] [<ffffffff812005ed>] ? sysfs_do_create_link+0xed/0x220
[ 28.649610] [<ffffffff81335f08>] acpi_device_probe+0x4e/0x11c
[ 28.649614] [<ffffffff813bd161>] driver_probe_device+0x91/0x3b0
[ 28.649616] [<ffffffff813bd52b>] __driver_attach+0xab/0xb0
[ 28.649618] [<ffffffff813bd480>] ? driver_probe_device+0x3b0/0x3b0
[ 28.649621] [<ffffffff813bb356>] bus_for_each_dev+0x56/0x90
[ 28.649623] [<ffffffff813bcbee>] driver_attach+0x1e/0x20
[ 28.649625] [<ffffffff813bc6f0>] bus_add_driver+0x1a0/0x2c0
[ 28.649627] [<ffffffffa014c000>] ? 0xffffffffa014bfff
[ 28.649628] [<ffffffff813bda7a>] driver_register+0x7a/0x160
[ 28.649630] [<ffffffffa014c000>] ? 0xffffffffa014bfff
[ 28.649632] [<ffffffff813367f2>] acpi_bus_register_driver+0x43/0x45
[ 28.649635] [<ffffffffa014c057>] sony_laptop_init+0x57/0x1000 [sony_laptop]
[ 28.649640] [<ffffffff8100203f>] do_one_initcall+0x3f/0x170
[ 28.649644] [<ffffffff810bfd3e>] sys_init_module+0xbe/0x230
[ 28.649649] [<ffffffff816211a9>] system_call_fastpath+0x16/0x1b
[ 28.649650] Code: 2b 43 50 88 43 4e 48 83 c4 08 5b 5d c3 90 e8 eb fb ff ff eb e6 90 90 90 90 90 90 90 90 90 48 89 f8 48 89 d1 48 c1 e9 03 83 e2 07 <f3> 48 a5 89 d1 f3 a4 c3 20 4c 8b 06 4c 8b 4e 08 4c 8b 56 10 4c
[ 28.649669] RIP [<ffffffff812e1c0d>] memcpy+0xd/0x110
[ 28.649671] RSP <ffff88012ea65c30>
[ 28.649672] CR2: 0000000000ff1000
[ 28.649674] ---[ end trace 6cf6386889527f26 ]---
[ 28.649955] udevd[614]: '/sbin/modprobe -bv acpi:SNY5001:' [706] terminated by signal 9 (Killed)


Kernel parameters: 
linux	/vmlinuz-3.6.2-1.fc16.x86_64 root=/dev/mapper/vg_rafababu001-lv_root ro single rd.md=0 rd.dm=0 rd.lvm.lv=vg_rafababu001/lv_root rd.lvm.lv=vg_rafababu001/lv_swap quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0  KEYTABLE=us-acentos LANG=en_US.UTF-8

Comment 1 Josh Boyer 2012-12-14 17:57:07 UTC
Can you try this scratch build when it completes and let us know if the kernel oops is gone from dmesg?

http://koji.fedoraproject.org/koji/taskinfo?taskID=4791583

Comment 2 Rafael Torres 2012-12-16 22:29:32 UTC
Issue fixed ! It is working properly now. Thanks for your time and support.

I will attach DMESG output for your appreciation. 

Should I close the bug or u have to close it ?

[]'s

Comment 3 Rafael Torres 2012-12-16 22:30:43 UTC
Created attachment 664570 [details]
Dmesg output

Comment 4 Josh Boyer 2012-12-17 13:38:05 UTC
(In reply to comment #2)
> Issue fixed ! It is working properly now. Thanks for your time and support.
> 
> I will attach DMESG output for your appreciation. 
> 
> Should I close the bug or u have to close it ?

I'll get that patch into the Fedora kernels and do an official submission via our update tool.  That will close this bug out for us.

Thank you very much for testing.

Comment 5 Fedora Update System 2012-12-18 15:22:59 UTC
kernel-3.6.11-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.11-1.fc17

Comment 6 Fedora Update System 2012-12-18 15:42:00 UTC
kernel-3.6.11-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.11-3.fc18

Comment 7 Fedora Update System 2012-12-18 15:43:08 UTC
kernel-3.6.11-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/kernel-3.6.11-1.fc16

Comment 8 Fedora Update System 2012-12-18 21:30:26 UTC
Package kernel-3.6.11-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.11-3.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-20594/kernel-3.6.11-3.fc18
then log in and leave karma (feedback).

Comment 9 Josh Boyer 2013-01-02 15:09:09 UTC
*** Bug 880609 has been marked as a duplicate of this bug. ***

Comment 10 Fedora Update System 2013-01-05 06:49:30 UTC
kernel-3.6.11-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 11 Fedora Update System 2013-01-05 06:56:53 UTC
kernel-3.6.11-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2013-01-11 23:16:56 UTC
kernel-3.6.11-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 13 Josh Boyer 2013-01-29 18:55:21 UTC
*** Bug 905613 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.