Bug 873336 - SSL handshake error when trying to consume test content
SSL handshake error when trying to consume test content
Status: CLOSED DUPLICATE of bug 859128
Product: Subscription Asset Manager
Classification: Red Hat
Component: thumbslug (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-05 10:17 EST by Jeff Weiss
Modified: 2014-11-09 17:52 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 09:43:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
test manifest (25.96 KB, application/zip)
2012-11-05 10:17 EST, Jeff Weiss
no flags Details

  None (edit)
Description Jeff Weiss 2012-11-05 10:17:48 EST
Created attachment 638699 [details]
test manifest

Description of problem:


Version-Release number of selected component (if applicable):
Headpin Version: 1.2.1-1.git.308.104177f.el6

How reproducible:
always

Steps to Reproduce:
1. with fresh org+env, Upload attached manifest with content url http://hudson.rhq.lab.eng.bos.redhat.com/cds/
2. Install the autoconfig rpm on a client, eg 
http://myhost/pub/candlepin-cert-consumer-myhost-1.0-1.noarch.rpm
3. register a client to the org/env you created
4. on client, subscribe to Nature product
5. on client, yum repolist

Actual results:
$ yum repolist
Loaded plugins: product-id, security, subscription-manager
Updating certificate-based repositories.

Please use yum-config-manager to configure which software
repositories are used with Red Hat Subscription Management.

https://10-16-120-150.dhcp.rhq.lab.eng.bos.redhat.com:8088/content/nature/6Server/x86_64/rpms/repodata/repomd.xml: [Errno 14] PYCURL ERROR 52 - "Empty reply from server"
Trying other mirror.
repo id                              repo name                            status
nature-enterprise                    Nature Enterprise                    0
rhel6-updates                        rhel6-updates                        0
repolist: 0


Expected results:
repolist shows packages

Additional info:
from thumbslug log:

Nov 05 10:04:47 [New I/O server worker #1-4] ERROR org.candlepin.thumbslug.HttpRequestHandler - Exception caught!
javax.net.ssl.SSLHandshakeException: null cert chain
	at sun.security.ssl.Handshaker.checkThrown(Handshaker.java:1031)
	at sun.security.ssl.SSLEngineImpl.checkTaskThrown(SSLEngineImpl.java:508)
	at sun.security.ssl.SSLEngineImpl.readNetRecord(SSLEngineImpl.java:759)
	at sun.security.ssl.SSLEngineImpl.unwrap(SSLEngineImpl.java:727)
	at javax.net.ssl.SSLEngine.unwrap(SSLEngine.java:624)
	at org.jboss.netty.handler.ssl.SslHandler.unwrap(SslHandler.java:881)
	at org.jboss.netty.handler.ssl.SslHandler.decode(SslHandler.java:605)
	at org.jboss.netty.handler.codec.frame.FrameDecoder.callDecode(FrameDecoder.java:282)
	at org.jboss.netty.handler.codec.frame.FrameDecoder.messageReceived(FrameDecoder.java:216)
	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:274)
	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:261)
	at org.jboss.netty.channel.socket.nio.NioWorker.read(NioWorker.java:349)
	at org.jboss.netty.channel.socket.nio.NioWorker.processSelectedKeys(NioWorker.java:280)
	at org.jboss.netty.channel.socket.nio.NioWorker.run(NioWorker.java:200)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Caused by: javax.net.ssl.SSLHandshakeException: null cert chain
	at sun.security.ssl.Alerts.getSSLException(Alerts.java:192)
	at sun.security.ssl.SSLEngineImpl.fatal(SSLEngineImpl.java:1467)
	at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:259)
	at sun.security.ssl.Handshaker.fatalSE(Handshaker.java:247)
	at sun.security.ssl.ServerHandshaker.clientCertificate(ServerHandshaker.java:1388)
	at sun.security.ssl.ServerHandshaker.processMessage(ServerHandshaker.java:179)
	at sun.security.ssl.Handshaker.processLoop(Handshaker.java:609)
	at sun.security.ssl.Handshaker$1.run(Handshaker.java:549)
	at sun.security.ssl.Handshaker$1.run(Handshaker.java:547)
	at java.security.AccessController.doPrivileged(Native Method)
	at sun.security.ssl.Handshaker$DelegatedTask.run(Handshaker.java:968)
	at org.jboss.netty.handler.ssl.SslHandler$2.run(SslHandler.java:1012)
	at org.jboss.netty.handler.ssl.ImmediateExecutor.execute(ImmediateExecutor.java:37)
	at org.jboss.netty.handler.ssl.SslHandler.runDelegatedTasks(SslHandler.java:1009)
	at org.jboss.netty.handler.ssl.SslHandler.unwrap(SslHandler.java:899)
	... 11 more
Comment 1 Jeff Weiss 2012-11-05 10:29:48 EST
Woops, I copied the wrong thumbslug stack.  This should be the relevant one:

Nov 05 10:23:55 [New I/O server worker #1-6] ERROR org.candlepin.thumbslug.HttpRequestHandler - Exception caught!
java.lang.NoClassDefFoundError: net/oauth/OAuthException
	at org.candlepin.thumbslug.HttpRequestHandler.requestStartReceived(HttpRequestHandler.java:173)
	at org.candlepin.thumbslug.HttpRequestHandler.messageReceived(HttpRequestHandler.java:80)
	at org.candlepin.thumbslug.HttpRequestLogger.handleUpstream(HttpRequestLogger.java:102)
	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:302)
	at org.jboss.netty.handler.codec.replay.ReplayingDecoder.unfoldAndFireMessageReceived(ReplayingDecoder.java:522)
	at org.jboss.netty.handler.codec.replay.ReplayingDecoder.callDecode(ReplayingDecoder.java:506)
	at org.jboss.netty.handler.codec.replay.ReplayingDecoder.messageReceived(ReplayingDecoder.java:443)
	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:302)
	at org.jboss.netty.handler.codec.frame.FrameDecoder.unfoldAndFireMessageReceived(FrameDecoder.java:317)
	at org.jboss.netty.handler.codec.frame.FrameDecoder.callDecode(FrameDecoder.java:299)
	at org.jboss.netty.handler.codec.frame.FrameDecoder.messageReceived(FrameDecoder.java:216)
	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:274)
	at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:261)
	at org.jboss.netty.channel.socket.nio.NioWorker.read(NioWorker.java:349)
	at org.jboss.netty.channel.socket.nio.NioWorker.processSelectedKeys(NioWorker.java:280)
	at org.jboss.netty.channel.socket.nio.NioWorker.run(NioWorker.java:200)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
	at java.lang.Thread.run(Thread.java:679)
Caused by: java.lang.ClassNotFoundException: net.oauth.OAuthException
	at java.net.URLClassLoader$1.run(URLClassLoader.java:217)
	at java.security.AccessController.doPrivileged(Native Method)
	at java.net.URLClassLoader.findClass(URLClassLoader.java:205)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:321)
	at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:294)
	at java.lang.ClassLoader.loadClass(ClassLoader.java:266)
	... 19 more
Comment 2 James Bowes 2012-11-08 09:43:47 EST

*** This bug has been marked as a duplicate of bug 859128 ***

Note You need to log in before you can comment on or make changes to this bug.