Bug 873342 - RuntimeError: no window manager available
RuntimeError: no window manager available
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
18
x86_64 Unspecified
urgent Severity unspecified
: ---
: ---
Assigned To: Martin Sivák
Dan Mashal
abrt_hash:0031cc6158ef6a013ed42f02e13...
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-05 10:32 EST by wagerrard
Modified: 2012-11-10 04:26 EST (History)
5 users (show)

See Also:
Fixed In Version: firstboot-18.6-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-10 04:26:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: executable (19 bytes, text/plain)
2012-11-05 10:32 EST, wagerrard
no flags Details
File: environ (123 bytes, text/plain)
2012-11-05 10:32 EST, wagerrard
no flags Details
File: type (9 bytes, text/plain)
2012-11-05 10:33 EST, wagerrard
no flags Details
File: product (6 bytes, text/plain)
2012-11-05 10:33 EST, wagerrard
no flags Details
File: hashmarkername (9 bytes, text/plain)
2012-11-05 10:33 EST, wagerrard
no flags Details
File: firstboot-tb (1.13 KB, text/plain)
2012-11-05 10:33 EST, wagerrard
no flags Details
File: version (2 bytes, text/plain)
2012-11-05 10:33 EST, wagerrard
no flags Details
File: release (33 bytes, text/plain)
2012-11-05 10:33 EST, wagerrard
no flags Details

  None (edit)
Description wagerrard 2012-11-05 10:32:53 EST
Description of problem:
Installed MATE.  MATE came up after first boot, not expected second phase of the install.

Version-Release number of selected component:
firstboot-18.5-1.fc18.x86_64

Additional info:
libreport version: 2.0.18
cmdline:        /usr/bin/python  /usr/sbin/firstboot
kernel:         3.6.5-2.fc18.x86_64

description:
:Traceback from firstboot:
:firstboot 18.5 exception report
:Traceback (most recent call last):
:  File "/usr/sbin/firstboot", line 141, in <module>
:    frontend.start_wm()
:  File "/usr/lib/python2.7/site-packages/firstboot/frontend.py", line 116, in start_wm
:    raise RuntimeError(err)
:RuntimeError: no window manager available
Comment 1 wagerrard 2012-11-05 10:32:56 EST
Created attachment 638701 [details]
File: executable
Comment 2 wagerrard 2012-11-05 10:32:58 EST
Created attachment 638702 [details]
File: environ
Comment 3 wagerrard 2012-11-05 10:33:00 EST
Created attachment 638703 [details]
File: type
Comment 4 wagerrard 2012-11-05 10:33:01 EST
Created attachment 638704 [details]
File: product
Comment 5 wagerrard 2012-11-05 10:33:03 EST
Created attachment 638705 [details]
File: hashmarkername
Comment 6 wagerrard 2012-11-05 10:33:04 EST
Created attachment 638706 [details]
File: firstboot-tb
Comment 7 wagerrard 2012-11-05 10:33:06 EST
Created attachment 638707 [details]
File: version
Comment 8 wagerrard 2012-11-05 10:33:29 EST
Created attachment 638708 [details]
File: release
Comment 9 wagerrard 2012-11-05 18:06:46 EST
I should add that I rebooted into MATE again, as Root, opened a Terminal, entered "Firstboot", got the second part of the install, and finished it per a normal install.
Comment 10 Dan Mashal 2012-11-05 19:57:19 EST
isntall of Fc18 TC7 netinstall MATE Desktop

Package: firstboot-18.5-1.fc18.x86_64
OS Release: Fedora release 18
Comment 11 Fedora Update System 2012-11-05 20:08:41 EST
mate-window-manager-1.4.1-13.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-17597/mate-window-manager-1.4.1-13.fc18
Comment 12 Adam Williamson 2012-11-05 20:11:46 EST
+1 NTH, breaks MATE installs as firstboot doesn't run.
Comment 13 Dan Mashal 2012-11-06 00:06:22 EST
Please add 'marco' to the list of WMs in   /lib/python2.7/site-packages/firstboot/constants.py for MATE.
Comment 14 Martin Sivák 2012-11-06 04:48:41 EST
This should be fixed in firstboot-18.6-1.
Comment 15 Fedora Update System 2012-11-06 05:09:50 EST
firstboot-18.6-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/firstboot-18.6-1.fc18
Comment 16 Fedora Update System 2012-11-06 13:48:41 EST
Package firstboot-18.6-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firstboot-18.6-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17688/firstboot-18.6-1.fc18
then log in and leave karma (feedback).
Comment 17 Adam Williamson 2012-11-06 15:09:06 EST
could we have the two packages that fix this edited together as a single update to minimize the possibility of mistakes, please? thanks.
Comment 19 Adam Williamson 2012-11-07 13:09:59 EST
Discussed 2012-11-07 NTH review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-07/f18beta-blocker-review-7.2012-11-07-17.03.log.txt . Accepted as NTH as a showstopper for a non-release-blocking desktop.
Comment 21 Dan Mashal 2012-11-08 23:27:44 EST
Seems to be fixed in smoke16. Thank you.
Comment 22 Fedora Update System 2012-11-10 00:13:07 EST
mate-window-manager-1.4.1-13.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.