Bug 873387 - After minimal DVD install there is no login prompt on tty1
After minimal DVD install there is no login prompt on tty1
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
18
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
AcceptedBlocker
:
: 872845 874459 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-11-05 12:56 EST by Kamil Páral
Modified: 2012-11-14 04:51 EST (History)
17 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-14 04:51:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
anaconda-ks.cfg (802 bytes, text/plain)
2012-11-05 12:59 EST, Kamil Páral
no flags Details
anaconda.log (8.37 KB, text/plain)
2012-11-05 12:59 EST, Kamil Páral
no flags Details
anaconda.packaging.log (43.99 KB, text/plain)
2012-11-05 12:59 EST, Kamil Páral
no flags Details
anaconda.program.log (44.44 KB, text/plain)
2012-11-05 12:59 EST, Kamil Páral
no flags Details
anaconda.storage.log (116.58 KB, text/plain)
2012-11-05 12:59 EST, Kamil Páral
no flags Details
anaconda syslog (64.92 KB, text/plain)
2012-11-05 12:59 EST, Kamil Páral
no flags Details
boot.log (5.01 KB, text/plain)
2012-11-05 13:01 EST, Kamil Páral
no flags Details
messages (49.35 KB, text/plain)
2012-11-05 13:01 EST, Kamil Páral
no flags Details

  None (edit)
Description Kamil Páral 2012-11-05 12:56:33 EST
Description of problem:
I did a minimal installation of F18 Beta TC7 (I tried both architectures). After the new system boots (or on any subsequent boot), there is no login prompt on tty1. tty2-6 contain login prompt ok.

Version-Release number of selected component (if applicable):
systemd-195-2.fc18.i686
systemd-libs-195-2.fc18.i686
systemd-sysv-195-2.fc18.i686


How reproducible:
always

Steps to Reproduce:
1. install minimal system
2. boot
3. see no prompt on tty1, just blinking cursor
Comment 1 Kamil Páral 2012-11-05 12:57:07 EST
This seems to break Beta criterion:
 When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should provide a working login prompt without any unintended user intervention when boot is complete, and all virtual consoles intended to provide a working login prompt should do so 
https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria
Comment 2 Kamil Páral 2012-11-05 12:59:16 EST
Created attachment 638762 [details]
anaconda-ks.cfg
Comment 3 Kamil Páral 2012-11-05 12:59:19 EST
Created attachment 638763 [details]
anaconda.log
Comment 4 Kamil Páral 2012-11-05 12:59:23 EST
Created attachment 638764 [details]
anaconda.packaging.log
Comment 5 Kamil Páral 2012-11-05 12:59:26 EST
Created attachment 638765 [details]
anaconda.program.log
Comment 6 Kamil Páral 2012-11-05 12:59:30 EST
Created attachment 638766 [details]
anaconda.storage.log
Comment 7 Kamil Páral 2012-11-05 12:59:35 EST
Created attachment 638767 [details]
anaconda syslog
Comment 8 Kamil Páral 2012-11-05 13:01:14 EST
Created attachment 638768 [details]
boot.log
Comment 9 Kamil Páral 2012-11-05 13:01:19 EST
Created attachment 638769 [details]
messages
Comment 10 Kamil Páral 2012-11-05 13:03:39 EST
Neither enforcing=0 nor selinux=0 as a boot option helps.
Comment 11 Adam Williamson 2012-11-05 13:09:22 EST
Discussed at 2012-11-05 QA meeting acting as a blocker review meeting. Accepted as a blocker per criterion "When booting a system installed without a graphical environment, or when using a correct configuration setting to cause an installed system to boot in non-graphical mode, the system should provide a working login prompt without any unintended user intervention when boot is complete, and all virtual consoles intended to provide a working login prompt should do so".
Comment 12 Kamil Páral 2012-11-05 13:12:12 EST
This is only broken when installing from Beta TC7 DVD, from netinst it works OK, I verified.

<mkovarik> service getty@tty1 is disabled in systemd, it's only from DVD repo, from network repository this issue not occur
Comment 13 Kamil Páral 2012-11-05 13:16:39 EST
DVD:
bash-4.2.37-6.fc18
initscripts-9.41-2.fc18
pam-1.1.6-1.fc18
util-linux-2.22-1.fc18

netinst:
bash-4.2.39-1.fc18
initscripts-9.42-1.fc18
pam-1.1.6-3.fc18
util-linux-2.22.1-2.1.fc18
Comment 14 Reartes Guillermo 2012-11-05 13:43:19 EST
Already reported: 872845
Please mark 872845 bug as dup of this one.

Cheers.
Comment 15 Adam Williamson 2012-11-05 13:52:00 EST
http://fpaste.stg.fedoraproject.org/1500 is the complete rpm -qa from a TC7 netinst (as with other testers, this works for me). http://fpaste.stg.fedoraproject.org/1502 is the complete rpm -qa from a TC7 DVD (as with other testers, this doesn't work for me). from the suspects kparal identified, i'd take a shot at initscripts as the fixer. I'll test just updating initscripts in the DVD case and see if that fixes it.
Comment 16 Adam Williamson 2012-11-05 13:56:01 EST
just updating initscripts doesn't fix it. neither does enforcing=0. http://paste.stg.fedoraproject.org/1503 is the diff between the netinst and dvd cases.
Comment 17 Adam Williamson 2012-11-05 14:03:27 EST
A full 'yum update' doesn't fix this either, so whatever fixes this has to happen at install time, apparently. makes me suspect 'initscripts' again, but it has to be in the install package set. unfortunately, it's difficult or impossible to test install with just cherrypicked additional packages atm.
Comment 18 Bill Nottingham 2012-11-05 23:02:13 EST
*** Bug 872845 has been marked as a duplicate of this bug. ***
Comment 19 Lukáš Nykrýn 2012-11-06 07:52:54 EST
I don't think that initscripts are responsible for this. It looks that         /usr/bin/systemctl enable \
                getty@.service \
                remote-fs.target \
                systemd-readahead-replay.service \
                systemd-readahead-collect.service >/dev/null 2>&1 || :
from %post in systemd.spec is not executed or fails.
Comment 20 Adam Williamson 2012-11-06 12:24:32 EST
I would expect that to result in *no* accessible gettys, though. not just tty1.
Comment 21 Bill Nottingham 2012-11-06 13:53:13 EST
getty@.service has:

[Install]
Alias=getty.target.wants/getty@tty1.service

So, just tty1 there.

The others are auto-spawned.
Comment 22 Adam Williamson 2012-11-07 21:30:27 EST
Note that as we're doing an unfreeze and general push tonight, this might magically go away in TC8, if whatever fixes it happens to get pushed stable.
Comment 23 Kamil Páral 2012-11-08 04:13:27 EST
(In reply to comment #22)
> Note that as we're doing an unfreeze and general push tonight, this might
> magically go away in TC8, if whatever fixes it happens to get pushed stable.

Let's make sure. Please test and provide karma to following updates:
https://admin.fedoraproject.org/updates/FEDORA-2012-17504/bash-4.2.39-1.fc18
https://admin.fedoraproject.org/updates/FEDORA-2012-17741/initscripts-9.42-1.fc18.1
https://admin.fedoraproject.org/updates/FEDORA-2012-17448/util-linux-2.22.1-2.1.fc18
Comment 24 Andre Robatino 2012-11-08 05:10:43 EST
Still broken with smoke16 DVD.

bash-4.2.37-6.fc18.x86_64
initscripts-9.41-2.fc18.x86_64
util-linux-2.22-1.fc18.x86_64
systemd-195-2.fc18.x86_64
Comment 25 Adam Williamson 2012-11-08 05:17:24 EST
smoke16 only had the new anaconda, nothing else: it wasn't done with the stable push packages.
Comment 26 Michal Sekletar 2012-11-08 11:22:02 EST
Installation of a systemd-libs package happens *after* systemd. However, systemd-libs provides shared library libsystemd-daemon, and systemctl is linked against it. Thus, calls to systemctl in a %post of systemd package fail, with an error produced by a dynamic linker, such that it couldn't find shared library. 

There is a circular dependency between systemd and systemd-libs. We should probably remove requirement of systemd by systemd-libs.
Comment 27 Jesse Keating 2012-11-08 12:01:55 EST
*** Bug 874459 has been marked as a duplicate of this bug. ***
Comment 28 Fedora Update System 2012-11-09 11:46:01 EST
systemd-195-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/systemd-195-6.fc18
Comment 29 Fedora Update System 2012-11-09 16:09:54 EST
Package systemd-195-6.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing systemd-195-6.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17924/systemd-195-6.fc18
then log in and leave karma (feedback).
Comment 30 Andre Robatino 2012-11-10 18:00:11 EST
Fixed in 18 Beta TC8.
Comment 31 Kamil Páral 2012-11-12 06:37:56 EST
(In reply to comment #30)
> Fixed in 18 Beta TC8.

Can you provide karma, please? Thanks.

I also verified this.
Comment 32 Tao Wu 2012-11-13 04:26:47 EST
Verified on TC8, and karma has been provided.
Comment 33 Kamil Páral 2012-11-14 04:51:13 EST
anaconda-18.28-1.fc18 is stable now, closing.

Note You need to log in before you can comment on or make changes to this bug.