Bug 8734 - The ftp client function: NEWER doesn't work
The ftp client function: NEWER doesn't work
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: ftp (Show other bugs)
6.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-21 18:44 EST by Joseph Perrin
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-03 14:49:23 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Joseph Perrin 2000-01-21 18:44:52 EST
If you do a *newer* on a file it always says: Local file "x" is newer than
remote file "x", regardless if that is true or not.  The exception: The
file doesn't exist on the client.
Comment 1 Elliot Lee 2000-02-03 14:49:59 EST
'newer' works fine here - note though that a retrieved file is stamped with the
time of retrieval and not the timestamp of the file on the server. Also note
that time zone differences may account for some confusion.
Comment 2 Riley H Williams 2000-02-04 14:05:59 EST
There's another case where 'newer' doesn't work, which is when the FTP server is
running under Win95 with some of the AnonFTP servers that are available for it.
At least one of them ALWAYS reports ALL files as being datestamped "29 Feb 1995"
in its listings - and yes, I'm well aware that the said date does not exist, but
that doesn't stop the said servers from reporting it.

Note that if this is the cause, then there's little (if anything) that can be
done about it at the client end of the link, so one should always be prepared to
check whether the datestamps seen from the server are in fact correct.

Note You need to log in before you can comment on or make changes to this bug.