This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 873445 - Changing encryption state in custom partitioning can lead to failure/crash
Changing encryption state in custom partitioning can lead to failure/crash
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity high
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-05 16:25 EST by Adam Williamson
Modified: 2012-11-08 04:42 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:42:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-11-05 16:25:18 EST
In fixing https://bugzilla.redhat.com/show_bug.cgi?id=869391 , dlehman found related issues when changing encryption state in custom partitioning. In particular, if you check the 'Encrypt my data' checkbox on the disk picker screen, then go into custom partitioning and change some partitions to not be encrypted (they will default to being encrypted if that checkbox was checked prior to entering custom partitioning), this can cause the install to fail or crash, particularly for LVM/btrfs partitions.

dlehman has a fix for this ready, but it will only go in if we accept this issue as NTH. Touching the custom partitioning code is _always_ risky to some extent, but I think this issue is easy enough to hit that it's worth trying to fix. As 18.25 will be spun today, we have enough time to back out of this fix if it turns out to cause bad regressions. dlehman will attach an updates.img to the bug for us to try and break.
Comment 1 Adam Williamson 2012-11-05 16:26:54 EST
oh, forgot to mention - dlehman says the fix for this is not complicated, and he has been testing it.
Comment 2 Jóhann B. Guðmundsson 2012-11-05 16:31:11 EST
+1 nth
Comment 3 Tim Flink 2012-11-05 16:35:34 EST
I'm +1 NTH for a tested fix, I imagine that a lot of people would hit this bug and it's not fixable with an update.
Comment 4 Kevin Fenzi 2012-11-05 16:42:31 EST
+1 NTH
Comment 5 Adam Williamson 2012-11-05 16:44:53 EST
that's 4 +1s, marking accepted NTH. thanks for the votes everyone.
Comment 6 David Lehman 2012-11-05 16:45:48 EST
Updates image:

  http://dlehman.fedorapeople.org/updates/updates-873445.0.img
Comment 7 Adam Williamson 2012-11-05 17:00:42 EST
That updates.img blows up. Following procedure, with TC7 DVD:

1. Boot installer
2. Set install package set to 'minimal'
3. Go to disk picker, pick my only disk, and check 'encrypt my data' checkbox
4. Check the custom partitioning checkbox
5. In custom partitioning, delete existing partitions, then click on /boot

boom - explodes with 'NameError: global name 'changed_encryption' is not defined
Comment 8 Adam Williamson 2012-11-05 17:01:31 EST
correction to 5: I clicked on /, not /boot.
Comment 9 Adam Williamson 2012-11-05 17:15:16 EST
Updated updates.img: http://dlehman.fedorapeople.org/updates/updates-873445.1.img

That one's good for me. I confirmed the bug without the updates.img with the following procedure:

1. Boot installer
2. Set install package set to 'minimal'
3. Go to disk picker, pick my only disk, and check 'encrypt my data' checkbox
4. Check the custom partitioning checkbox
5. In custom partitioning, delete existing partitions, then click on /, in the right-hand pane, expand 'options', and uncheck the 'encrypt' checkbox
6. Finish partitioning and start install

During partitioning, the installer will crash, with "FormatCreateError: ('invalid device specification', '/dev/mapper/fedora')".

Following the same procedure with the .1.img updates image, I get a completed and working installation with no encryption, as expected.

We can test other paths to see if any regressions have crept in - just try various combinations of checking or not checking the box prior to custom partitioning and then encrypting or not encrypting devices inside of custom partitioning, with different filesystem types and so on. But this single case demonstrates the fix for me.
Comment 10 Fedora Update System 2012-11-06 21:09:07 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 11 Fedora Update System 2012-11-07 13:46:24 EST
Package anaconda-18.26-1.fc18, lorax-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.26-1.fc18 lorax-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17714/lorax-18.22-1.fc18,anaconda-18.26-1.fc18
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-11-07 22:23:25 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 13 Adam Williamson 2012-11-08 04:42:06 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.