Bug 873463 - TypeError: sequence item 1: expected string, DiskDevice found
TypeError: sequence item 1: expected string, DiskDevice found
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Lehman
Fedora Extras Quality Assurance
abrt_hash:9b96df01ded4aa9005059d2120e...
:
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-11-05 17:43 EST by Adam Williamson
Modified: 2012-11-08 04:16 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 04:16:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: anaconda-tb (584.40 KB, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: product (6 bytes, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: type (9 bytes, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: ifcfg.log (5.17 KB, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: storage.log (122.90 KB, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: version (11 bytes, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: environ (780 bytes, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: executable (14 bytes, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: anaconda.log (10.53 KB, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: syslog (120.81 KB, text/plain)
2012-11-05 17:43 EST, Adam Williamson
no flags Details
File: hashmarkername (8 bytes, text/plain)
2012-11-05 17:44 EST, Adam Williamson
no flags Details
File: packaging.log (47.14 KB, text/plain)
2012-11-05 17:44 EST, Adam Williamson
no flags Details
File: cmdline_file (110 bytes, text/plain)
2012-11-05 17:44 EST, Adam Williamson
no flags Details
File: release (24 bytes, text/plain)
2012-11-05 17:44 EST, Adam Williamson
no flags Details
File: program.log (222.95 KB, text/plain)
2012-11-05 17:44 EST, Adam Williamson
no flags Details

  None (edit)
Description Adam Williamson 2012-11-05 17:43:36 EST
Description of problem:
Installing to an Intel BIOS RAID (RAID-0, 2x500GB) array. Crashed at very end of install, during bootloader installation.

Version-Release number of selected component:
anaconda-18.24

Additional info:
libreport version: 2.0.17
cmdline:        /usr/bin/python  /sbin/anaconda
kernel:         3.6.5-2.fc18.x86_64

description:
:The following was filed automatically by anaconda:
:anaconda 18.24 exception report
:Traceback (most recent call first):
:  File "/usr/lib/python2.7/site-packages/pykickstart/commands/ignoredisk.py", line 74, in __str__
:    retval += "ignoredisk --only-use=%s\n" % ",".join(self.onlyuse)
:  File "/usr/lib/python2.7/site-packages/pykickstart/commands/ignoredisk.py", line 111, in __str__
:    retval = F8_IgnoreDisk.__str__(self)
:  File "/usr/lib/python2.7/site-packages/pykickstart/base.py", line 284, in __str__
:    retval += obj.__str__()
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 47, in _writeKS
:    f.write(str(ksdata))
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/install.py", line 86, in doConfiguration
:    _writeKS(ksdata)
:  File "/usr/lib64/python2.7/threading.py", line 504, in run
:    self.__target(*self.__args, **self.__kwargs)
:  File "/usr/lib64/python2.7/site-packages/pyanaconda/threads.py", line 91, in run
:    threading.Thread.run(self, *args, **kwargs)
:TypeError: sequence item 1: expected string, DiskDevice found
Comment 1 Adam Williamson 2012-11-05 17:43:41 EST
Created attachment 638935 [details]
File: anaconda-tb
Comment 2 Adam Williamson 2012-11-05 17:43:43 EST
Created attachment 638936 [details]
File: product
Comment 3 Adam Williamson 2012-11-05 17:43:44 EST
Created attachment 638937 [details]
File: type
Comment 4 Adam Williamson 2012-11-05 17:43:46 EST
Created attachment 638938 [details]
File: ifcfg.log
Comment 5 Adam Williamson 2012-11-05 17:43:48 EST
Created attachment 638939 [details]
File: storage.log
Comment 6 Adam Williamson 2012-11-05 17:43:51 EST
Created attachment 638940 [details]
File: version
Comment 7 Adam Williamson 2012-11-05 17:43:53 EST
Created attachment 638941 [details]
File: environ
Comment 8 Adam Williamson 2012-11-05 17:43:54 EST
Created attachment 638942 [details]
File: executable
Comment 9 Adam Williamson 2012-11-05 17:43:57 EST
Created attachment 638943 [details]
File: anaconda.log
Comment 10 Adam Williamson 2012-11-05 17:43:59 EST
Created attachment 638944 [details]
File: syslog
Comment 11 Adam Williamson 2012-11-05 17:44:01 EST
Created attachment 638945 [details]
File: hashmarkername
Comment 12 Adam Williamson 2012-11-05 17:44:02 EST
Created attachment 638946 [details]
File: packaging.log
Comment 13 Adam Williamson 2012-11-05 17:44:04 EST
Created attachment 638947 [details]
File: cmdline_file
Comment 14 Adam Williamson 2012-11-05 17:44:06 EST
Created attachment 638948 [details]
File: release
Comment 15 Adam Williamson 2012-11-05 17:44:08 EST
Created attachment 638949 [details]
File: program.log
Comment 16 Adam Williamson 2012-11-05 17:45:17 EST
Still working through a straightforward 'install to FW raid' test, so this is a blocker.
Comment 18 Adam Williamson 2012-11-05 18:59:36 EST
That fix looks good. Finally I got a complete install to RAID-0, and the installed system boots. Thanks!

Using autopart and leaving it to its own devices, I wind up with /dev/md126p1 as /boot and then volumes for root, home and swap. All seems to work fine. Will test a few other setups for completeness.
Comment 19 Adam Williamson 2012-11-05 20:08:46 EST
beta blocker
Comment 20 Michal Kovarik 2012-11-06 10:13:19 EST
installation on bios raid0(3 members), automatic partitioning, minimal package set. When running post installl scripts

Package: anaconda-18.24
OS Release: Fedora release 18-Beta-TC7
Comment 21 Jesse Keating 2012-11-06 19:13:30 EST
+1 blocker.
Comment 22 Tim Flink 2012-11-06 19:22:20 EST
+1 blocker. With Adam's implied +1, that makes 3. Moving to Accepted.
Comment 23 Adam Williamson 2012-11-06 20:55:48 EST
Michal, since you apparently have Intel BIOS RAID and two disks, can you please test and see if you are affected by https://bugzilla.redhat.com/show_bug.cgi?id=873576 ? Thanks!
Comment 24 Fedora Update System 2012-11-06 21:09:01 EST
anaconda-18.26-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.26-1.fc18
Comment 25 Fedora Update System 2012-11-07 13:46:17 EST
Package anaconda-18.26-1.fc18, lorax-18.22-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.26-1.fc18 lorax-18.22-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17714/lorax-18.22-1.fc18,anaconda-18.26-1.fc18
then log in and leave karma (feedback).
Comment 26 Adam Williamson 2012-11-07 15:33:45 EST
Can be tested with smoke15: https://dl.fedoraproject.org/pub/alt/qa/18/20121106_f18b-smoke15/ (this is kind of a note-to-self)
Comment 27 Tim Flink 2012-11-07 17:09:06 EST
I did an install of TC7 i686 from netinstall to a machine with a dmraid RAID0 array attempting to test #867593. I got through autopart and started the install. The traceback showed up during 'Running post install scripts'

Package: anaconda-18.24
Architecture: i686
OS Release: Fedora release 18-Beta-TC7
Comment 28 Adam Williamson 2012-11-07 20:08:46 EST
confirming that smoke15 is fixed for this. VERIFIED.
Comment 29 Fedora Update System 2012-11-07 22:23:19 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 30 Adam Williamson 2012-11-08 04:16:59 EST
18.26 went stable. Closing. (Bodhi closing of bugs when updates go stable is currently broken).

Note You need to log in before you can comment on or make changes to this bug.