This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 873500 - Test case: Properties strategy should detect outdated translations by using source file history
Test case: Properties strategy should detect outdated translations by using s...
Status: CLOSED DUPLICATE of bug 873489
Product: Zanata
Classification: Community
Component: Component-Maven (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-05 21:48 EST by Sean Flanigan
Modified: 2013-03-03 21:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-20 01:06:17 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2012-11-05 21:48:11 EST
Description of problem:

When pushing Properties content, it is possible for the translation files to have older source strings than the source files, but with the same property keys.  For instance:

source file v1:
greeting=Hello

source file v2:
greeting=Hello World

trans file v1:
greeting=Hallo

NB: even though the ids match, "Hallo" is not a valid translation of the current v2 source "Hello World".


Version-Release number of selected component (if applicable):
2.0.0

How reproducible:

Steps to Reproduce:
1. Push both files above
2. Pull the translation
  
Actual results:

(To be tested)

Expected results:
greeting should be untranslated

Additional info:

It should be possible to tell (guess) that the translation "Hallo" for key "greeting" is obsolete because the v1 source "greeting" with the old string "Hello" already had the translation "Hallo".

If we change the way we generate resIds for Properties files, we will need a migration path for existing content in the database.

We have a similar problem for XLIFF files: bug 873489.
Comment 1 Sean Flanigan 2012-11-20 01:06:17 EST

*** This bug has been marked as a duplicate of bug 873489 ***

Note You need to log in before you can comment on or make changes to this bug.