Bug 873546 - Commands end in successful state after engine restart even if not all their associated tasks were created.
Summary: Commands end in successful state after engine restart even if not all their a...
Keywords:
Status: CLOSED DUPLICATE of bug 968900
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.2.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.3.0
Assignee: Ravi Nori
QA Contact: Elad
URL:
Whiteboard: infra
Depends On:
Blocks: 909694
TreeView+ depends on / blocked
 
Reported: 2012-11-06 07:19 UTC by Yair Zaslavsky
Modified: 2016-02-10 19:43 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-06-30 11:01:23 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 14075 None None None Never
oVirt gerrit 14078 None None None Never
oVirt gerrit 14368 None None None Never

Description Yair Zaslavsky 2012-11-06 07:19:13 UTC
Description of problem:

A command may create several tasks during its execution.
If the command created X tasks out of Y (I.E - vdsm began running X tasks, async_tasks table has X records for the command) and the command crashes, upon restart, the command ends successfully (the tasks information is being retrieved from the data center, the tasks are being polled, and when they end successfully, they cause the command to end successfully as well) 
although not all tasks for it were executed.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Yair Zaslavsky 2012-11-14 12:27:21 UTC
First patch in series:

http://gerrit.ovirt.org/#/c/9232/

Comment 7 Yair Zaslavsky 2013-06-30 11:01:23 UTC
This will be handled in async task mgr improvements.

*** This bug has been marked as a duplicate of bug 968900 ***


Note You need to log in before you can comment on or make changes to this bug.