Bug 873619 - Katello-configure Reset-data fails if tried for multiple times .
Katello-configure Reset-data fails if tried for multiple times .
Status: CLOSED WORKSFORME
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity medium
: rc
: ---
Assigned To: Jordan OMara
SAM QE List
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-06 05:39 EST by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-27 16:27:29 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
UI Login (71.08 KB, image/png)
2012-11-06 05:39 EST, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-11-06 05:39:37 EST
Created attachment 639268 [details]
UI Login

Description of problem:
Katello-configure reset data fails after trying multiple times

Version-Release number of selected component (if applicable):

# rpm -qa | grep katello
katello-headpin-1.2.1-1.git.308.104177f.el6.noarch
katello-common-1.2.1-1.git.308.104177f.el6.noarch
katello-cli-common-1.2.1-1.git.164.3554da3.el6.noarch
katello-certs-tools-1.1.9-1.el6.noarch
katello-selinux-1.1.2-1.el6.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-glue-candlepin-1.2.1-1.git.308.104177f.el6.noarch
katello-cli-1.2.1-1.git.164.3554da3.el6.noarch
katello-configure-1.2.0-1.git.350.371b086.el6.noarch
katello-headpin-all-1.2.1-1.git.308.104177f.el6.noarch

How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=headpin

Steps to Reproduce:
1.Login to UI.
2.populate it with Orgs,Envs,Import Manifests,Register the system
3.# katello-configure --deployment=headpin --reset-data=YES
4. Repeat step 2 and 3 for multiple times.
5. Login to UI again  

Actual results:
Unable to login . screenshot attached

Expected results:
Should be able to login

Additional info:
Comment 1 Jordan OMara 2012-11-27 16:27:29 EST
This works for me on:

katello-glue-candlepin-1.2.6-2h.el6_3.noarch
katello-selinux-1.2.1-1h.el6_3.noarch
katello-headpin-all-1.2.6-2h.el6_3.noarch
katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-common-1.2.6-2h.el6_3.noarch
katello-configure-1.2.3-1h.el6_3.noarch
katello-headpin-1.2.6-2h.el6_3.noarch
katello-cli-1.2.4-2h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.2.4-2h.el6_3.noarch


I reset several times, added a manifest, org, systems, subscriptions, everything

Note You need to log in before you can comment on or make changes to this bug.