Bug 873631 - rhn-migrate-classic-to-rhsm failed with error “No such org: None”
rhn-migrate-classic-to-rhsm failed with error “No such org: None”
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
IDM QE LIST
: QA-Closed
Depends On:
Blocks: 771481 sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-06 06:14 EST by spandey
Modified: 2015-04-23 19:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: subscription-manager-1.1.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:59:36 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description spandey 2012-11-06 06:14:18 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:
2/2

Prerequisites
Rhel6.4 with following subscription-manager rpm .
subscription-manager-migration-1.1.5-1.git.10.64351ef.el6.x86_64
subscription-manager-1.1.5-1.git.10.64351ef.el6.x86_64
subscription-manager-migration-data-1.12.2.5-1.git.0.85ecbf5.el6.noarch

Steps to Repro : 
Login to client console and register client to rhn_classic. 
Execute following command on console “rhn-migrate-classic-to-rhsm” with valid (rhn)user/password.

Expected Result : 
Migration should successfully completed and no error message should display on console. 

Actual Result : 
Migration failed with error message “No such org: None
”

[root@dhcp201-136 ~]# rhn-migrate-classic-to-rhsm 
Red Hat account: qa@redhat.com
Password: 
No such org: None
Comment 2 Adrian Likins 2012-11-12 12:39:10 EST
commit d0ab4be325dc3b2fd0b3713018d51fbf0d7e773b
Author: Alex Wood <awood@redhat.com>
Date:   Sun Nov 4 03:22:46 2012 -0500

    873631: Migrate correctly when there is only one org.
Comment 4 Alex Wood 2012-11-19 10:59:22 EST
*** Bug 877331 has been marked as a duplicate of this bug. ***
Comment 5 spandey 2012-11-26 03:39:31 EST
Verified using following rpm 

subscription-manager-1.8.0-1.git.3.006a990.el6.x86_64
subscription-manager-migration-1.8.0-1.git.3.006a990.el6.x86_64
subscription-manager-firstboot-1.8.0-1.git.3.006a990.el6.x86_64
subscription-manager-gui-1.8.0-1.git.3.006a990.el6.x86_64
subscription-manager-migration-data-1.12.2.6-1.git.0.171d4c3.el6.noarch

Working fine resolving defect as verified.
Comment 7 errata-xmlrpc 2013-02-21 03:59:36 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0350.html

Note You need to log in before you can comment on or make changes to this bug.