Bug 873805 - Systems ui page doesn't handle 410 nicely
Systems ui page doesn't handle 410 nicely
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Tom McKay
Tazim Kolhar
: Triaged
Depends On: 841317 996559
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-06 13:40 EST by Tom McKay
Modified: 2016-04-25 20:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 841317
Environment:
Last Closed: 2013-10-01 06:52:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
System Removed (87.56 KB, image/png)
2013-08-07 05:13 EDT, Tazim Kolhar
no flags Details

  None (edit)
Comment 1 Bryan Kearney 2013-06-07 08:49:27 EDT
I get a friendly error which says:

"Couldn't find System with id=4"

I can then refresh the page and it is ok. I am gonna send this to QA.
Comment 2 Tazim Kolhar 2013-08-07 05:13:20 EDT
Created attachment 783749 [details]
System Removed

VERIFIED :
# rpm -qa | grep katello
katello-selinux-1.4.4-2.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-common-1.4.3-5.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-cli-common-1.4.3-4.el6sat.noarch
katello-glue-elasticsearch-1.4.3-5.el6sam_splice.noarch
katello-headpin-all-1.4.3-5.el6sam_splice.noarch
katello-cli-1.4.3-4.el6sat.noarch
katello-glue-candlepin-1.4.3-5.el6sam_splice.noarch
signo-katello-0.0.10-2.el6sat.noarch
katello-headpin-1.4.3-5.el6sam_splice.noarch


Gets a friendly message : "Couldn't find System with id=3"
Refreshing the page removes the system details from system_list
Comment 4 errata-xmlrpc 2013-10-01 06:52:51 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.