This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 873808 - String Update: Weird strings featuring '[' in CP from OwnerResource.java
String Update: Weird strings featuring '[' in CP from OwnerResource.java
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: 1.3
Assigned To: William Poteat
Og Maciel
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2012-11-06 13:45 EST by Matt Reid
Modified: 2013-10-01 06:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 06:52:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Matt Reid 2012-11-06 13:45:21 EST
Description of problem:
Not sure what its trying to do, but in the keys.pot file from candlepin, we have 
two strings that end with '['. Are those trying to be used to split the string somehow? I think we may need to double check those strings function properly.

#: src/main/java/org/candlepin/resource/OwnerResource.java:460
msgid ""
"Activation key names must be alphanumeric or the characters '-' or '_'. ["
msgstr ""

#: src/main/java/org/candlepin/resource/OwnerResource.java:467
msgid "Activation key name ["
msgstr ""

Version-Release number of selected component (if applicable):
candlepin-0.7.18-1
Comment 1 Tom McKay 2012-12-18 09:41:20 EST
Switching product from Subscription Asset Manager to Candlepin for visibility
Comment 2 William Poteat 2013-01-07 13:35:17 EST
commit cd0ad205241bd5f8b5d1bc8cecca3906182ecaa5
Comment 3 Bryan Kearney 2013-06-07 14:20:16 EDT
Moving all POST bugs to ON_QA since we have delivered a puddle with the bugs.
Comment 4 William Poteat 2013-08-19 08:46:50 EDT
The only way to confirm the fix is to check the code as listed in the bz.
Comment 6 William Poteat 2013-08-20 10:50:25 EDT
master commit dc46b79b2c17827069676116cc876a7f86ee127f
Comment 7 Og Maciel 2013-08-20 10:52:36 EDT
fwiw https://github.com/candlepin/candlepin/commit/cd0ad205241bd5f8b5d1bc8cecca3906182ecaa5

VERIFIED:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.20-1.el6sat.noarch
* signo-katello-0.0.20-1.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 9 errata-xmlrpc 2013-10-01 06:52:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.