Bug 873865 - langsupport groups not getting added
langsupport groups not getting added
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
AcceptedNTH
:
Depends On:
Blocks: F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-11-06 15:57 EST by Jesse Keating
Modified: 2013-01-09 22:37 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-19 19:36:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jesse Keating 2012-11-06 15:57:36 EST
Comps has language support groups that define specific packages that should come in when a particular language is picked.  This is not functioning currently in the re-written yum backend of F18's anaconda.  Because of this some fonts will be missing, same with tools like m17n, and scim-tables, etc...
Comment 1 Jesse Keating 2012-11-06 15:58:27 EST
Proposing nice to have, as it would be nice for people using those languages get the bits they need.
Comment 2 Adam Williamson 2012-11-06 16:00:02 EST
What would the fix for this look like? How icky is it?
Comment 3 Jesse Keating 2012-11-06 16:09:16 EST
The fix just got proposed upstream, basically takes the lang values we're seeing now "es_ES.UTF-8" and truncating it down to just "es".  The rest is existing code.
Comment 4 Jesse Keating 2012-11-06 18:10:42 EST
Patch posted.
Comment 5 Adam Williamson 2012-11-07 13:11:12 EST
Discussed 2012-11-07 NTH review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-11-07/f18beta-blocker-review-7.2012-11-07-17.03.log.txt . Accepted as NTH as it's a significant issue for non-English users that cannot be fixed with an update.
Comment 6 Fedora Update System 2012-11-07 22:23:06 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 7 Adam Williamson 2012-11-19 19:36:56 EST
18.27 has since gone stable, so let's close this. I'm assuming it actually works.

Note You need to log in before you can comment on or make changes to this bug.