Bug 873933 - Unable to translate non-PO projects offline
Unable to translate non-PO projects offline
Status: CLOSED DUPLICATE of bug 870876
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Runa Bhattacharjee
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-06 21:17 EST by Sean Flanigan
Modified: 2013-03-03 21:22 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-07 00:59:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sean Flanigan 2012-11-06 21:17:03 EST
Description of problem:

If a PO project (projectType of podir or gettext) is pushed into Zanata, then downloaded using a non-PO format, the non-PO file can't be uploaded to the server again.

Version-Release number of selected component (if applicable):
2.0.2

How reproducible:


Steps to Reproduce:
1. Push source documents using XLIFF or Properties
2. Download documents as PO (using zip, individual PO download, or mvn/py client with projectType=podir)
3. Translate the document offline
4. Upload the modified document (using PO upload, or mvn/py client)
  
Actual results:
Upload process generates warnings because the TextFlow resIds don't match, and none of the modified translations are accepted.  Translation stats don't change.

Expected results:
Modified translations are accepted.  Translation stats updated to reflect the extra translations.  


Additional info:

You can probably get yourself into similar problems by pushing a PO project and trying to work offline with XLIFF or Properties.

Also, the PO files we generate for non-PO projects may be invalid, with multiple instances of the same msgid, and no msgctxt.

We need an alternative mapping, only used for offline translations, which makes use of msgid and msgctxt, both for downloading and uploading.  We probably need a new projectType for it.  And we should not allow clients to pull using the wrong project type.
Comment 1 Sean Flanigan 2012-11-07 00:59:32 EST

*** This bug has been marked as a duplicate of bug 870876 ***

Note You need to log in before you can comment on or make changes to this bug.