Bug 873963 - RFE: Add virt-install --force-url-distro to work with URLs that disable directory listing
RFE: Add virt-install --force-url-distro to work with URLs that disable direc...
Status: CLOSED UPSTREAM
Product: Virtualization Tools
Classification: Community
Component: virt-manager (Show other bugs)
unspecified
Unspecified Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Cole Robinson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-07 00:51 EST by Tom Prince
Modified: 2014-12-10 14:01 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-12-10 14:01:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
virt-manager-ignore-error-403-on-directories.patch (873 bytes, patch)
2014-08-27 12:47 EDT, Leonardo Chiquitto
no flags Details | Diff

  None (edit)
Description Tom Prince 2012-11-07 00:51:40 EST
Description of problem:

virt-install tries to verifiy that a URL passed to --location is useable
by trying to connect to it. If a proxy like apt-cacher-ng is configured,
that doesn't return directory listings, this will fail, even if requests
for files under that directory would succeed.

Version-Release number of selected component (if applicable):
0.600.3
Comment 1 Cole Robinson 2013-04-21 15:12:26 EDT
virtinst has been merged into virt-manager.git. Moving all virtinst bugs to the virt-manager component.
Comment 2 Cole Robinson 2014-02-01 14:26:41 EST
We should add an option like --force-url-distro, which just assumes that the passed --os-variant value is the distro we are trying to fetch. It's still not that easy, because within each distro category we still probe trees to figure out which layout they are using. Maybe we could swap out the hasFile implementation in this case to just download the file rather than check the directory listing.
Comment 3 Leonardo Chiquitto 2014-08-27 12:47:00 EDT
Created attachment 931592 [details]
virt-manager-ignore-error-403-on-directories.patch

I was also affected by this limitation and would like to suggest the attached patch. Could you consider it for upstream inclusion? Thanks.
Comment 4 Cole Robinson 2014-12-10 14:01:02 EST
Sorry Leonardo, I missed your patch comment :/

I actually just applied a patch upstream that drops the initial directory listing check.

commit 24faf867507484323fea285bdf4097c545ccf71b
Author: Gabriel de Perthuis <g2p.code@gmail.com>
Date:   Mon Dec 8 22:43:38 2014 +0100

    URL installs: remove hasFile("") check

I think that should fix things for yall, so closing this bug. If not, please reopen and explain where things are still failing

Note You need to log in before you can comment on or make changes to this bug.