Bug 873989 - Missing full path in knetattach.desktop
Missing full path in knetattach.desktop
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-runtime (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: rc
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks: 864851
  Show dependency treegraph
 
Reported: 2012-11-07 03:25 EST by Honza Horak
Modified: 2012-11-08 08:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 08:11:50 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Honza Horak 2012-11-07 03:25:27 EST
Description of problem:
I'm seeing a possible issue in /usr/share/applications/kde4/knetattach.desktop,
which contains:
  Exec=knetattach

However, knetattach binary is located under /usr/libexec/kde4/knetattach, so it won't work probably.

Unfortunately, I don't have a working RHEL-7 with KDE, so I cannot confirm it doesn't work, so feel free to close this if it is not a bug.

Version-Release number of selected component (if applicable):
kde-runtime-4.8.3-2.el7.x86_64

How reproducible:
every-time

Steps to Reproduce:
1. rpm -ql kde-runtime | grep knetattach
2. grep Exec /usr/share/applications/kde4/knetattach.desktop

Actual results:
knetattach is located under /usr/libexec/kde4, but knetattach.desktop doesn't use a full path

Expected results:
knetattach.desktop uses a full path
Comment 1 Ngo Than 2012-11-08 08:11:50 EST
it only shows in KDE desktop enviroment and the binary is also in searchs patch


kde4-config --path  exe
/home/than/.kde/libexec/kde4/:/home/than/.kde/bin/:/usr/libexec/kde4/:/usr/bin/

Note You need to log in before you can comment on or make changes to this bug.