Bug 8743 - gnorpm crashes all the time
gnorpm crashes all the time
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnorpm (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-22 06:34 EST by Tim Waugh
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-11 09:46:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2000-01-22 06:34:54 EST
From menu: Operations->Install.
Bang.  Window disappears.
Comment 1 Tim Waugh 2000-01-22 06:37:59 EST
And .xsession-errors says:

gnorpm: error in loading shared libraries: gnorpm: undefined symbol: fdOpen
Comment 2 Jeff Johnson 2000-01-24 07:40:59 EST
This problem does not occur with
	gnorpm-0.9-12
	rpm-3.0.4-0.31
I believe it was due to gnorpm being compiled against the wrong version of rpm.
Comment 3 Tim Waugh 2000-01-24 07:59:59 EST
Sorry, I still get it.

[tim@turmoil tim]$ rpm -q gnorpm rpm
gnorpm-0.9-12
rpm-3.0.4-0.33

(gdb) run
Starting program: /usr/bin/gnorpm
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...(no debugging symbols found)...
(no debugging symbols found)...
Program received signal SIGSEGV, Segmentation fault.
0x805bca9 in rpm_install_dialog_add_file ()
(gdb) bt
#0  0x805bca9 in rpm_install_dialog_add_file ()
#1  0x403afba9 in g_idle_dispatch () from /usr/lib/libglib-1.2.so.0
#2  0x403aebe6 in g_main_dispatch () from /usr/lib/libglib-1.2.so.0
#3  0x403af1a1 in g_main_iterate () from /usr/lib/libglib-1.2.so.0
#4  0x403af341 in g_main_run () from /usr/lib/libglib-1.2.so.0
#5  0x401c3479 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#6  0x8053224 in main ()
#7  0x404a652b in __libc_start_main (main=0x8052ffc <main>, argc=1,
    argv=0xbffffa24, init=0x8050ad8 <_init>, fini=0x806f22c <_fini>,
    rtld_fini=0x4000ac50 <_dl_fini>, stack_end=0xbffffa1c)
    at ../sysdeps/generic/libc-start.c:92
Comment 4 Tim Waugh 2000-02-02 05:18:59 EST
One big datapoint I forgot to mention: I hadn't mounted the CD.  *Literally*,
don't do anything but start GnoRPM, hit install, and select 'Only newer
packages'.
Comment 5 Tim Waugh 2000-02-08 10:44:59 EST
This still happens in piglet.
Comment 6 Elliot Lee 2000-02-14 17:02:59 EST
FWIW, can't reproduce with gnorpm-0.9-14 and rpm-3.0.4-0.38
Comment 7 Tim Waugh 2000-02-15 05:26:59 EST
Sorry, but it still happens here with those versions of gnorpm and rpm.  Did you
try with no CD in the drive?
Comment 8 Tim Waugh 2000-02-22 16:53:59 EST
I can _still_ reproduce this with piglet-0222.

1. Make sure there is no CD-ROM in the drive.
2. Start gnorpm.
3. Hit 'Install'.
4. Change the filter to anything else.

I know there is no CD-ROM in the drive, and I know there is supposed to be.  But
new users _will_ do this!
Comment 9 Tim Waugh 2000-08-11 09:46:44 EDT
This no longer happens in the latest build.

Note You need to log in before you can comment on or make changes to this bug.