Bug 87430 - klipper can't load URLs -- inserts single quote at beginning
klipper can't load URLs -- inserts single quote at beginning
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kdebase (Show other bugs)
9
All Linux
high Severity high
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-26 15:44 EST by Chris Ricker
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-08 07:34:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chris Ricker 2003-03-26 15:44:15 EST
This is on a fresh install of RHL 9 gold (kdebase-3.1-12)

klipper cannot open URLs with mozilla. Attempting to do so always results in the
Mozilla error "The URL is not valid and cannot be loaded". Clicking OK then
displays a second Mozilla error, that "www.'.com" cannot be found.

This is because the URL klipper passes to Mozilla has a single quote (')
inserted at the beginning of it (in other words, highlighting
http://www.google.com gets passed by klipper to Mozilla as the URL
'http://www.google.com)

This bug is specific to klipper and Mozilla; passing URLs via klipper to
konqueror is not broken

This bug makes klipper unusable for those of us who use Mozilla as our web browser
Comment 1 Chris Ricker 2003-04-02 11:47:16 EST
Sometimes it just puts a single quote (') at the beginning, and sometimes it
puts the single quote at both the beginning and the ending

I just got the URL

http://spooge.kittenz.pdx.edu/mail.txt

in my email, for example, and that was passed to mozilla by klipper as

'http://spooge.kittenz.pdx.edu/mail.txt'

It was still passed to konqueror okay, though
Comment 2 Chris Ricker 2003-04-02 11:48:58 EST
Hmm, and the URL

http://www.stahl.bau.tu-bs.de/~hildeb/postfix/client.shtml

got passed by klipper to mozilla as

'http://www.stahl.bau.tu-bs.de/~hildeb/postfix/client.shtml'

maybe it's always putting a single quote at both ends, and I just didn't notice
the ending one before....
Comment 3 Ngo Than 2003-05-08 07:34:22 EDT
it's fixed in kdebase-3.1.1-9 or later.

if you want to have a quick fix, please change the line in
/usr/share/config/klipperrc

ps x |grep -q '[m]ozilla' && mozilla -remote "openURL(%s, new-window)" || mozilla %s

to

ps x |grep -q '[m]ozilla' && mozilla -remote "openURL(`echo %s`, new-window)" ||
mozilla %s

please make sure that you should restart klipper!

Note You need to log in before you can comment on or make changes to this bug.