Bug 874332 - Missing cssselect python module
Summary: Missing cssselect python module
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: calibre
Version: 17
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kevin Fenzi
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 875230 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-11-07 23:35 UTC by Tom Horsley
Modified: 2012-12-17 01:32 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-12-17 01:32:26 UTC
Type: Bug


Attachments (Terms of Use)

Description Tom Horsley 2012-11-07 23:35:49 UTC
Description of problem:

Any attempt to convert an ebook seems to fail with:

...
  File "/usr/lib64/calibre/calibre/ebooks/conversion/plumber.py", line 1051, in run
    from calibre.ebooks.oeb.transforms.flatcss import CSSFlattener
  File "/usr/lib64/calibre/calibre/ebooks/oeb/transforms/flatcss.py", line 20, in <module>
    from calibre.ebooks.oeb.stylizer import Stylizer
  File "/usr/lib64/calibre/calibre/ebooks/oeb/stylizer.py", line 23, in <module>
    from cssselect import HTMLTranslator
ImportError: No module named cssselect

From what I can tell, cssselect is a python module available out in the universe somewhere, but doing yum searches doesn't seem to turn it up in the fedora repos. Seems like it needs to be packaged up so calibre can say it depends on it.

Version-Release number of selected component (if applicable):
calibre-0.9.5-1.fc17.x86_64

How reproducible:
100% of the time when trying to convert MOBI to EPUB.

Steps to Reproduce:
1.pick a mobi book
2.say convert
3.pick epub output format
  
Actual results:
python backtrace

Expected results:
converted book

Additional info:
Conversions worked fine before this new calibre showed up.

Comment 1 Kevin Fenzi 2012-11-08 04:18:58 UTC
Can you downgrade to 0.9.4 and/or 0.9.1 and see if they work as expected?

With f17: 

yum --disablerepo=\* --enablerepo=updates-testing downgrade calibre
(to get 0.9.4)

yum --disablerepo=\* --enablerepo=updates downgrade calibre
(to get 0.9.1)

That would help me isolate when the breakage showed up. Thanks.

Comment 2 Tom Horsley 2012-11-08 11:15:40 UTC
According to my yum.log file, the previous version of calibre on my system
was: Oct 20 14:30:10 Updated: calibre-0.9.2-1.fc17.x86_64

That version definitely worked OK, I converted 3 or 4 mobi files to epub
with it.

And, in fact, the 0.9.5-1 version now works since I found the python cssselect
module on the net and installed it manually.

Comment 3 Kevin Fenzi 2012-11-09 20:16:12 UTC
FYI, I've created a package and filed a review for python-cssselect: 

https://bugzilla.redhat.com/show_bug.cgi?id=875213

Comment 4 Kevin Fenzi 2012-11-09 22:10:27 UTC
*** Bug 875230 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2012-11-09 23:58:54 UTC
python-cssselect-0.7.1-3.fc18,calibre-0.9.5-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/python-cssselect-0.7.1-3.fc18,calibre-0.9.5-2.fc18

Comment 6 Fedora Update System 2012-11-10 00:00:42 UTC
calibre-0.9.5-2.fc17,python-cssselect-0.7.1-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/calibre-0.9.5-2.fc17,python-cssselect-0.7.1-3.fc17

Comment 7 Fedora Update System 2012-11-10 19:40:37 UTC
Package python-cssselect-0.7.1-3.fc18, calibre-0.9.5-2.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing python-cssselect-0.7.1-3.fc18 calibre-0.9.5-2.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17938/python-cssselect-0.7.1-3.fc18,calibre-0.9.5-2.fc18
then log in and leave karma (feedback).

Comment 8 phob0ss13 2012-12-16 04:07:42 UTC
python-cssselect is still not available in fedora repository. Updating from 0.9.1-1 results in error.

Error: Package: calibre-0.9.6-2.fc17.i686 (updates)
           Requires: python-cssselect

Comment 9 Kevin Fenzi 2012-12-16 04:24:11 UTC
Yes, I am aware. Please see bug 887528

Karma is needed for me to push that package out of updates-testing. 

See the above bug for how to test.

Comment 10 Fedora Update System 2012-12-17 01:32:28 UTC
python-cssselect-0.7.1-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.