Bug 874373 - [WebTrans] Entries would not be cleared if you remove the text too quick
[WebTrans] Entries would not be cleared if you remove the text too quick
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-UI (Show other bugs)
development
Unspecified Unspecified
unspecified Severity high
: ---
: 2.0
Assigned To: Patrick Huang
Ding-Yi Chen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-07 22:20 EST by Ding-Yi Chen
Modified: 2013-02-25 22:46 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.0.3-SNAPSHOT (20121119-0019)
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-25 22:46:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ding-Yi Chen 2012-11-07 22:20:43 EST
Description of problem:

When translations are removed from entries, it is expected that the entries are actually clear and states as NEW after we move to another page. 

However, the text was restored after I switched back the page.

Version-Release number of selected component (if applicable):
Zanata version 2.0.3-SNAPSHOT (20121108-0033)

How reproducible:
Always

Steps to Reproduce:
1 Find a multi-paged doucment with at least several translated messages.
  Suppose these messages are at row 1, 2 and 3.
  The longer the message, the more likely the bug be reproduced.
2.Quickly remove the text in row 1, 2 and 3
  If you see "Saving.." in all the rows you modify, it is too slow to reproduce the bug.
  
Actual results:
1. Blue-greening bolders are around the entries you cleard, 
   which indicate these  cells are not yet saved. 
2. Switch to another page and switch back, texts are restored.

Expected results:
Texts are cleared after page switch back.

Additional info:
Comment 1 Patrick Huang 2012-11-15 01:53:10 EST
I believe the cause of this problem is the same as in Bug 803909(right click won't select row)
Focusing on CodeMirror editor won't guarantee row selection. i.e. Right click, or if you use mouse to select trunk of text, it seems like sometimes(if not always) it won't trigger a click event (maybe a drag event instead?). This will be fixed in Bug 803909.
Comment 2 Patrick Huang 2012-11-16 01:02:28 EST
committed into master:
https://github.com/zanata/zanata/commit/ef120a01913519f113bf16b8257e155a63366989
Comment 3 Ding-Yi Chen 2012-11-18 21:28:30 EST
Worked with Zanata version 2.1-SNAPSHOT (20121119-1207)

However, the release branch (2.0.XX) does not work.
Please also put the fix in the release branch.

Reassigned.
Comment 4 Patrick Huang 2012-11-18 23:38:08 EST
committed into release ab0029d21c433c04c93aacb7bcce7112b505aa8a
Comment 5 Ding-Yi Chen 2012-11-26 20:49:35 EST
VERIFIED with Zanata version 2.0.3-SNAPSHOT (20121119-0019)

Note You need to log in before you can comment on or make changes to this bug.