Bug 874391 - After deleting a manifest , the subscriptions within that manifests are visible in the UI until the page is refreshed explicitly
After deleting a manifest , the subscriptions within that manifests are visib...
Status: CLOSED DUPLICATE of bug 877947
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
medium Severity high
: rc
: ---
Assigned To: Tom McKay
Tazim Kolhar
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-07 23:45 EST by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 13:30:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Delete manifests (100.63 KB, image/png)
2012-11-07 23:45 EST, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-11-07 23:45:12 EST
Created attachment 640550 [details]
Delete manifests

Description of problem:

Upload a manifest and try to delete it.
Even after deleting it, the subcriptions are visible in the UI
unless page is refreshed explicitly.

Version-Release number of selected component (if applicable):

# rpm -qa | grep katello
katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.2.2-1h.el6_3.noarch
katello-glue-candlepin-1.2.2-1h.el6_3.noarch
katello-cli-1.2.2-1h.el6_3.noarch
katello-selinux-1.2.1-1h.el6_3.noarch
katello-headpin-all-1.2.2-1h.el6_3.noarch
katello-headpin-1.2.2-1h.el6_3.noarch
katello-configure-1.2.1-1h.el6_3.noarch
katello-common-1.2.2-1h.el6_3.noarch

How reproducible:

# yum install -y katello-headpin-all
# katello-configure --deployment=sam

Steps to Reproduce:
1.Log in to UI
2.Navigate to Content go to Redhat subscriptions
3.Upload manifest
4.Delete it
5.Check if the subscriptions are visible
  
Actual results:

list of subscriptions are still visible



Expected results:

the list should not be visible once the manifest is deleted.
there should be no need to refresh the page explicitly
Additional info:
Comment 1 Tom McKay 2012-11-14 11:16:16 EST
  Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 1dede6d2a0fab24aef5d977e68ac9cde30c396b3
      https://github.com/Katello/katello/commit/1dede6d2a0fab24aef5d977e68ac9cde30c396b3
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2012-11-14 (Wed, 14 Nov 2012)
Comment 3 Tazim Kolhar 2012-11-20 03:14:16 EST
VERIFIED :

# rpm -qa | grep katello
katello-configure-1.2.3-1h.el6_3.noarch
katello-headpin-all-1.2.6-1h.el6_3.noarch
katello-glue-candlepin-1.2.6-1h.el6_3.noarch
katello-cli-1.2.4-1h.el6_3.noarch
katello-selinux-1.2.1-1h.el6_3.noarch
katello-cli-common-1.2.4-1h.el6_3.noarch
katello-headpin-1.2.6-1h.el6_3.noarch
katello-common-1.2.6-1h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.2.1-1h.el6_3.noarch
Comment 4 Og Maciel 2013-01-09 13:30:30 EST

*** This bug has been marked as a duplicate of bug 877947 ***

Note You need to log in before you can comment on or make changes to this bug.