Bug 874426 - Link to manifests missing in import history after uploading manifest
Link to manifests missing in import history after uploading manifest
Status: CLOSED NOTABUG
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.2
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Tom McKay
SAM QE List
:
Depends On:
Blocks: sam12-tracker
  Show dependency treegraph
 
Reported: 2012-11-08 02:49 EST by Tazim Kolhar
Modified: 2016-04-25 20:54 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-08 08:19:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
manifest link (91.06 KB, image/png)
2012-11-08 02:49 EST, Tazim Kolhar
no flags Details
the manifest zip file which was used for uploading (41.82 KB, application/zip)
2012-11-08 02:51 EST, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2012-11-08 02:49:51 EST
Created attachment 640612 [details]
manifest link

Description of problem:

After uploading a manifests the import history containing link
to distributor from where the manifest is downloaded is missing .

Version-Release number of selected component (if applicable):

# rpm -qa | grep katello
katello-certs-tools-1.2.1-1h.el6_3.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-cli-common-1.2.2-1h.el6_3.noarch
katello-glue-candlepin-1.2.2-1h.el6_3.noarch
katello-cli-1.2.2-1h.el6_3.noarch
katello-selinux-1.2.1-1h.el6_3.noarch
katello-headpin-all-1.2.2-1h.el6_3.noarch
katello-headpin-1.2.2-1h.el6_3.noarch
katello-configure-1.2.1-1h.el6_3.noarch
katello-common-1.2.2-1h.el6_3.noarch

How reproducible:
# yum install -y katello-headpin-all
# katello-configure --deployment=sam

Steps to Reproduce:
1.Login to UI
2.Navigate to Content -> Redhat Subscriptions
3.Upload a manifest
4.Check import history contains link to the distributor from where
  the manifest was downloaded  
Actual results:

Link is missing

Expected results:

A link is provided 

Additional info:
Comment 1 Tazim Kolhar 2012-11-08 02:51:02 EST
Created attachment 640619 [details]
the manifest zip file  which was used for uploading
Comment 2 Tom McKay 2012-11-08 08:19:27 EST
Not all manifests have the required information to link back to their source. If this manifest came from the production or stage customer portal in the past week, then we can open a BZ against that system If it is older than that or from another source, then this is working as intended.

Please download try with a new manifest downloaded from production or stage and let me know.
Comment 3 Tazim Kolhar 2012-11-08 23:49:20 EST
It works with the newly downloaded manifests.

Note You need to log in before you can comment on or make changes to this bug.