Bug 874475 - black stripe over desktop on the right side of screen
black stripe over desktop on the right side of screen
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: xorg-x11-drv-intel (Show other bugs)
7.0
x86_64 Linux
unspecified Severity low
: beta
: 7.0
Assigned To: Lyude
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-08 04:47 EST by Vladimir Benes
Modified: 2016-05-09 09:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-05-09 09:28:57 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
xorg.0.log (61.17 KB, text/x-log)
2012-11-08 04:53 EST, Vladimir Benes
no flags Details

  None (edit)
Description Vladimir Benes 2012-11-08 04:47:30 EST
Description of problem:
I've found strange issue when moving my acer screen into non native mode. Native mode is 1680x1050 but when I switch it to 1680x945 the display is somehow moved to right (so it has black boarder on the left) and it has strange black boarder on the right side that hides its content (I cannot see notification area of gnome shell and I cannot see gnome shell menu on the right.  

xrandr says it's set to 1680x945 but monitor says it's 1280x960. This can maybe explain that black boarder as xrandr thinks it's 1680 and draws according to it but screen thinks it's 1280 and do the same according to the different resolution. There is a small black boarder on the bottom which is solid (no content in it).   

Version-Release number of selected component (if applicable):
Acer-B223PW

00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09) (prog-if 00 [VGA controller])

connected via dock -> DVI

xorg-x11-server-Xorg-1.13.0-7.el7.x86_64
xorg-x11-drv-intel-2.20.12-1.el7.x86_64
How reproducible:


Steps to Reproduce:
1.obtain lenovo x220 and acer screen (b223PW)
2.set resolution to 1680*945

  
Actual results:
crippled display

Expected results:
see whole screen

Additional info:
Comment 1 Vladimir Benes 2012-11-08 04:53:31 EST
Created attachment 640686 [details]
xorg.0.log
Comment 2 Vladimir Benes 2012-11-08 04:56:02 EST
shouldn't be xrandr advertising just modes that are supported by screen? maybe a bug in xorg-x11-server-utils?
Comment 4 Adam Jackson 2012-11-14 13:18:41 EST
(In reply to comment #2)
> shouldn't be xrandr advertising just modes that are supported by screen?
> maybe a bug in xorg-x11-server-utils?

xrandr is not where the "is this mode supported" logic lives, so, no.
Comment 5 Adam Jackson 2013-01-03 14:35:26 EST
Ick, this is the "minimode" nonsense in the kernel.  That's the only place a 1680x945 could be coming from.
Comment 6 Adam Jackson 2014-02-19 17:03:35 EST
Just cosmetic, and something I would want to fix in upstream drm directly, moving to 7.1.
Comment 10 Lyude 2016-04-28 15:28:17 EDT
Hi, is this problem still present if you try the kernel here?

http://file.rdu.redhat.com/~btissoir/RHEL-7.3-skylake-xgl-csb/kernel-3.10.0-370.el7.rhel73drm.10.x86_64.rpm
Comment 11 Vladimir Benes 2016-05-09 09:28:57 EDT
nope, it looks like it's fixed for some time already. closing

Note You need to log in before you can comment on or make changes to this bug.