Bug 874524 - Title number is wrong when a guest with 4 monitors running on RHEVM.
Title number is wrong when a guest with 4 monitors running on RHEVM.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice (Show other bugs)
7.0
x86_64 Linux
low Severity low
: rc
: ---
Assigned To: Jonathon Jongsma
SPICE QE bug list
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-11-08 06:26 EST by Geyang Kong
Modified: 2016-04-26 10:40 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-04-22 06:04:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot (699.98 KB, image/png)
2012-11-08 21:17 EST, Geyang Kong
no flags Details
New screen shot (960.64 KB, application/octet-stream)
2013-05-10 01:48 EDT, Geyang Kong
no flags Details
Log file (112.45 KB, text/plain)
2013-05-10 01:48 EDT, Geyang Kong
no flags Details

  None (edit)
Description Geyang Kong 2012-11-08 06:26:11 EST
Description of problem:
  Title number is wrong when a guest with 4 monitors running on RHEVM.

Version-Release number of selected component (if applicable):
virt-viewer-0.5.2-16.el6.x86_64

Reproduce steps:
1. Install a win7 x86_64 guest on rhevm.
2. Edit the guest, make sure it has spice device and 4 monitors
3. Install qxl driver
4. Restart guest.
5. Extend the desktop to 4 monitors.
6. Right click on desktop, choose screen resolution.
7. Click Identify.
8. Compare numbers on displays with form title numbers.

Actual results:
1. The 3rd monitor is displayed in 4th form.
2. The 4th monitor is displayed in 3rd form

Expected results:
1. Number of displays should be same as title number.

Additional info:
Comment 2 Geyang Kong 2012-11-08 21:17:08 EST
Created attachment 641217 [details]
screenshot
Comment 5 Marc-Andre Lureau 2013-05-09 18:53:38 EDT
Do you have a reproducer? I have never encountered that bug.

From what I can read in virt-viewer code, it already correctly reports monitor number (thanks to nth-display property, although it is more nth-monitor)

However, I don't think the Windows QXL driver guarantees mapping of nth monitor to nth channel. Moving there for now.
Comment 6 Geyang Kong 2013-05-10 01:46:53 EDT
Yes, I can still reproduce this. And this time, I got a log file with SPICE_DEBUG=1. I will attach log file and new snapshot later.
Comment 7 Geyang Kong 2013-05-10 01:48:01 EDT
Created attachment 745927 [details]
New screen shot
Comment 8 Geyang Kong 2013-05-10 01:48:58 EDT
Created attachment 745928 [details]
Log file
Comment 11 Alon Levy 2014-05-01 04:49:24 EDT
I could not reproduce this with spice-guest-tools 0.7.4 (http://www.spice-space.org/download/windows/spice-guest-tools/spice-guest-tools-0.74.exe) running 

The driver is not responsible for spice display channels.

The order of channel creation is implicit by the order of pci card initialization, to make it explicit we need to add a number to the interface (QXLInterface) between qemu and spice.

# Main VGA channel creation
main->..->pc_vga_init->..->qxl_init_primary->qxl_init_common->..->spice_server_add_interface->red_dispatcher_init->red_dispatcher_display_channel_create

# Later via ordering of statements in qemu's main
main->qemu_opts_foreach->device_init_func->qdev_device_add->..->qxl_init_secondary->..->spice_server_add_interface->red_dispatcher_init->red_dispatcher_display_channel_create

Since main ordering can change in the future (red_dispatcher calls are serialized via a pipe) we should add an identifier.

Needs fixes in spice & qemu, moving to spice (will clone later). Already at low priority.
Comment 15 Marc-Andre Lureau 2015-04-21 20:43:59 EDT
Can you still reproduce? thanks
Comment 16 zhoujunqin 2015-04-22 03:28:19 EDT
(In reply to Marc-Andre Lureau from comment #15)
> Can you still reproduce? thanks

Hi Marc-Andre Lureau,
Since bug reporter is not here, please needinfo to me if you're not clear with following steps, thanks.

I cannot reproduce this issue any more.

Environment:
Host setup with 7.1 released iso.
Guest: Prepare a win7 x86_64 guest on rhevm.

Packages version:
libvirt-1.2.14-1.el7.x86_64
spice-gtk-0.22-2.el7.x86_64
xorg-x11-drv-qxl-0.1.1-12.el7.x86_64
virt-viewer-0.6.0-12.el7.x86_64
spice-vdagent-0.14.0-9.el7.x86_64

Steps:
1. Prepare a win7 x86_64 guest on rhevm, make sure it has spice device and 4 monitors and qxl driver installed.
2. Extend the desktop to 4 monitors.
3. Right click on desktop, choose screen resolution.
4. Click Identify.
5. Compare numbers on displays with form title numbers.

After step5, Number of displays are same with title number.
Comment 17 Marc-Andre Lureau 2015-04-22 06:04:12 EDT
(In reply to zhoujunqin from comment #16)
> (In reply to Marc-Andre Lureau from comment #15)
> > Can you still reproduce? thanks
> 
> Hi Marc-Andre Lureau,
> Since bug reporter is not here, please needinfo to me if you're not clear
> with following steps, thanks.
> 
> I cannot reproduce this issue any more.

thanks, let's close it then

Note You need to log in before you can comment on or make changes to this bug.